WordPress.org

Plugin Reviews

Backup

Make backups of your WordPress site to Google Drive.

Average Rating
2.8 out of 5 stars
You are currently viewing the reviews that provided a rating of 1 star. Click here to see all reviews.
not working
By , for WP 4.2.4

BadRequestException<internalReason>The Doclist API has been shut down. Please use the new Drive API, https://developers.google.com/drive/

After backup
By ,

After installing the Plugin my site crashed.

Half Backup
By ,

Not all files Backup

My screen went blank.
By ,

Its shine to be broken.

Not supported
By ,

Not working properly

Need help, went blank
By , for WP 4.0.1

I've just downloaded the plugin, but once installed. My screen went blank. I can no longer access Wp-Admin nor my website...

Not working properly
By , for WP 3.5.2

This plugin not working properly

Couldn't get it to work it never backed-up my website
By ,

Whenever I clicked on "back-up now" I went to a blank screen that had the number 0. If I waited for the scheduled back-ups they never happened and I never got an email that they failed.

Sorry. I wish it worked.

Worked once, now it fails with no error
By , for WP 3.5

Getting this plugin installed initially was a pain (the Google API steps were not very clear), but after that it seemed to work well. I had it running successfully on two sites.

After the first week, the first site stopped working. No more backups, yet there was no notification of failures or error messages. When I try to run a backup manually, I get a blank screen, which is possibly the most frustrating thing for a user to see.

Second site still works, but I'll be looking for another plugin.

Do not use this high-risk plugin (basically malware)
By , for WP 3.4.2

First off, see this thread http://wordpress.org/support/topic/turning-off-backup-deleted-all-server-contents-cant-restore-any-backup?replies=6

In versions before 2.2 it had a bug that will delete your entire WordPress installation if you tried to deactivate and/or update it...which it did to one of my client's.

It deleted the entire website, everything - poof. He says that it's fixed in 2.2 - but something as off the chain as that bug makes me skeptical of anything else.

You must log in to submit a review. You can also log in or register using the form near the top of this page.