WordPress.org

Plugin Reviews

All in One SEO Pack

All in One SEO Pack is a WordPress SEO plugin to automatically optimize your WordPress blog for Search Engines such as Google.

134526

254 reviews
Average Rating
4.4 out of 5 stars
I think it's much better than Yoast. Offers a lot more.
By , for WP 4.3.1

This plugin covers a lot and allows the a lot to much be on autopilot.

I think it is much better than Yoast.

I switched from Premium SEO, which has more features but is quite heavy in the backend. All In One SEO is just as great and a ton less weight!

Perfect!
By , for WP 4.3.1

Very good plugin, full of stuff, full of options, really handy.

Once you get it working as you wish, it's unstoppable.

All In One Seo
By , for WP 4.3.1

Thanks For Reviews and plugins.
I got the good ideas from all reviews..

Thanks Agains.

I works Perfectly on latest Version 4.3.1.

Makes it easy
By , for WP 4.3.1

It was a close call between this and Yoast SEO plugin, for me this makes it easier. Thanks a lot.

For me the best!
By , for WP 4.3.1

I'm using this plugin from a long time ago. Today also into my own websie and certainly for me it's the best plugin for SEO, very easy and flexible to configure. Also the Bad Bot Blocker tool is formidable.

this plugin helps me a lot
By , for WP 4.3.1

it´s easy to use and works really good.

Good seo solution
By , for WP 4.3

Good seo management.

Works
By , for WP 4.3

Simple to use

Horrible Script !!! Be Warned
By , for WP 4.3

I have installed it to my website.

1. It adds redirection files into index.php and when visitors come to your website they are redirected to several other websites automaticaly.

2. It corrupts Sql database & wp php theme files and loads a big lag on files during connection.

I definitely warn you to be double careful. It is not safe to install this. It took me to load the entire web portal from the back up files and I lost a huge time fixing these guys script.

WordPress must to remove it from the portal.

Sometimes Default OG:Image dissapears
By ,

Hi, as there isn´t any support if you do not pay for the PRO version, the only way to have admin noticed I think it´s thru here.

At the plugin section: SOCIAL META. There is a Default OG:Image. This image works some days, and some doesn´t. The image is there, we have checked dozens of times, even uploaded one and again, and this image is the one that shows beside the post at for ex: Facebook, Twitter, etc... when you share it. Well, the image works when it wants, some days it does, some days, it doesn´t...

Is there anyway for fixing this?

Thank you.

You must log in to submit a review. You can also log in or register using the form near the top of this page.