Title: wji's Replies | WordPress.org

---

# wji

  [  ](https://wordpress.org/support/users/wji/)

 *   [Profile](https://wordpress.org/support/users/wji/)
 *   [Topics Started](https://wordpress.org/support/users/wji/topics/)
 *   [Replies Created](https://wordpress.org/support/users/wji/replies/)
 *   [Reviews Written](https://wordpress.org/support/users/wji/reviews/)
 *   [Topics Replied To](https://wordpress.org/support/users/wji/replied-to/)
 *   [Engagements](https://wordpress.org/support/users/wji/engagements/)
 *   [Favorites](https://wordpress.org/support/users/wji/favorites/)

 Search replies:

## Forum Replies Created

Viewing 10 replies - 1 through 10 (of 10 total)

 *   Forum: [Plugins](https://wordpress.org/support/forum/plugins-and-hacks/)
    In
   reply to: [[Easy Updates Manager] change email](https://wordpress.org/support/topic/change-email-9/)
 *  Thread Starter [wji](https://wordpress.org/support/users/wji/)
 * (@wji)
 * [11 years ago](https://wordpress.org/support/topic/change-email-9/#post-6599469)
 * good tip! Keep up the good work.
 *   Forum: [Plugins](https://wordpress.org/support/forum/plugins-and-hacks/)
    In
   reply to: [[Quick Event Manager] 24 hours format](https://wordpress.org/support/topic/24-hours-format/)
 *  Thread Starter [wji](https://wordpress.org/support/users/wji/)
 * (@wji)
 * [12 years ago](https://wordpress.org/support/topic/24-hours-format/#post-5303544)
 * ah ok, did put ”hour” behind it, now without text addon, thank you!
 *   Forum: [Plugins](https://wordpress.org/support/forum/plugins-and-hacks/)
    In
   reply to: [[Members - Membership & User Role Editor Plugin] "Attempt to assign property of non-object" error](https://wordpress.org/support/topic/attempt-to-assign-property-of-non-object-error/)
 *  [wji](https://wordpress.org/support/users/wji/)
 * (@wji)
 * [12 years, 3 months ago](https://wordpress.org/support/topic/attempt-to-assign-property-of-non-object-error/#post-4829249)
 * same here, any updates on this?
 *   Forum: [Plugins](https://wordpress.org/support/forum/plugins-and-hacks/)
    In
   reply to: [[SI CAPTCHA Anti-Spam] CAPTCHA not showing on WooCommerce login or lost password page](https://wordpress.org/support/topic/captcha-not-showing-on-woocommerce-login-or-lost-password-page/)
 *  [wji](https://wordpress.org/support/users/wji/)
 * (@wji)
 * [12 years, 3 months ago](https://wordpress.org/support/topic/captcha-not-showing-on-woocommerce-login-or-lost-password-page/#post-4626932)
 * same issue here. Ithemes Security is not for Captcha fields I guess, but more
   for overall security.
    Anybody has Si cpatch anti-spam working with Woocommerce
   WITH captcha showing up in lost passwor? Any updates on this?
 * Thanks,
 *   Forum: [Plugins](https://wordpress.org/support/forum/plugins-and-hacks/)
    In
   reply to: [[Query Monitor] fatal error](https://wordpress.org/support/topic/fatal-error-1136/)
 *  Thread Starter [wji](https://wordpress.org/support/users/wji/)
 * (@wji)
 * [12 years, 4 months ago](https://wordpress.org/support/topic/fatal-error-1136/#post-4794818)
 * Hi John,
 * I got feedback from Ithemes (from the migration plugin Backupbuddy) about this
   problem.
    I think it is interesting information to address the issue.
 * I quote from Ithemes support:
 * >  The symlink _should_ be defined as relative rather than absolute – the _relationship_
   > between the source and target will not change when the site is moved (migrated)
   > so there is no problem. Currently the symlink is defined as an absolute path
   > and this is what causes the problem. This is the _best_ solution for _users_
   > of the plugin and would be very simply implemented by the plugin author.
 * …
 * > let’s suppose a scripts did search every file just to check for any symlink
   > that needed to be changed to something – not all hosts allow the use of the
   > symlink() function to define symlinks and so this simply wouldn’t be possible(
   > the qm plugin itself acknowledges this because it checks whether the symlink()
   > function is available and doesn’t provide this particular functionality if 
   > it is not). So if the migration couldn’t update the symlink() what does it 
   > do? It might tell you it finds an invalid symlink that cannot be updated
 * John, is it possible to adjust this in a future update? Especially for a debugging
   plugin like QM portability is very much appreciated for a great plugin like QM.
   
   Let me know what you think.
 * Regards,
 *   Forum: [Plugins](https://wordpress.org/support/forum/plugins-and-hacks/)
    In
   reply to: [[Query Monitor] fatal error](https://wordpress.org/support/topic/fatal-error-1136/)
 *  Thread Starter [wji](https://wordpress.org/support/users/wji/)
 * (@wji)
 * [12 years, 4 months ago](https://wordpress.org/support/topic/fatal-error-1136/#post-4794816)
 * hi John,
    it happens when backing up to windows box, Backupbuddy and also with
   provider-staging-testing environments , so it is not related to one special migrating
   script only. Are you sure that it is not a Query Monitor issue since problem 
   is only there with QM?
 * Thanks!
 *   Forum: [Plugins](https://wordpress.org/support/forum/plugins-and-hacks/)
    In
   reply to: [[Query Monitor] fatal error](https://wordpress.org/support/topic/fatal-error-1136/)
 *  Thread Starter [wji](https://wordpress.org/support/users/wji/)
 * (@wji)
 * [12 years, 4 months ago](https://wordpress.org/support/topic/fatal-error-1136/#post-4794814)
 * This is what was causing the issue,
    Ipstas’s brilliant remark:
 * > Then figured out – I was backing up to windows box, symlink was lost and for
   > some reason was not recreated while installing. So, I have just created symlink
   > manually
   >  wp-content# ln -s plugins/query-monitor/wp-content/db.php . Now it
   > works
 * The symlink path is copied with a migration, but not changed to the new path,
   plugins keeps using the old symlink path.
 * John, any way you can fix this in an upgrade?
 *   Forum: [Plugins](https://wordpress.org/support/forum/plugins-and-hacks/)
    In
   reply to: [[Query Monitor] fatal error](https://wordpress.org/support/topic/fatal-error-1136/)
 *  Thread Starter [wji](https://wordpress.org/support/users/wji/)
 * (@wji)
 * [12 years, 5 months ago](https://wordpress.org/support/topic/fatal-error-1136/#post-4794794)
 * Hi John,
    yes, this is it, error is there also when deinstalling etc.:
 * Fatal error: Cannot redeclare class QM_Backtrace in /…/wp-content/plugins/query-
   monitor/Backtrace.php on line 17
    Tried a lot to get it running again, but none.
 * Happened several times again with new (totally different site) migratings too
   in last weeks.
 * Is there a way to totally clean the plugin from the database maybe so we can 
   narrow things here?
 *   Forum: [Plugins](https://wordpress.org/support/forum/plugins-and-hacks/)
    In
   reply to: [[Query Monitor] fatal error](https://wordpress.org/support/topic/fatal-error-1136/)
 *  Thread Starter [wji](https://wordpress.org/support/users/wji/)
 * (@wji)
 * [12 years, 5 months ago](https://wordpress.org/support/topic/fatal-error-1136/#post-4794716)
 * Dear John,
    any updates on this? Error seems persistent with moving installs.
 * Regards,
 *   Forum: [Plugins](https://wordpress.org/support/forum/plugins-and-hacks/)
    In
   reply to: [[Query Monitor] fatal error](https://wordpress.org/support/topic/fatal-error-1136/)
 *  Thread Starter [wji](https://wordpress.org/support/users/wji/)
 * (@wji)
 * [12 years, 5 months ago](https://wordpress.org/support/topic/fatal-error-1136/#post-4794560)
 * Hi John,
    thank you for getting in touch. I am running 2.6.6, WordPress 3.8.2(
   also in 3.8.1 same error). w.
 * A clue could be that it is migration related. I I install your plugin on a fresh
   install it works fine. After a move it won’t work. Maybe a databse clean of your
   plugin after the movement would do the trick? Site is properly migrated and database
   urls are securly updated, only plugin that gives problems seems to be this one
   each time.
 * If you want more information about server, php versions etc, please let me know!

Viewing 10 replies - 1 through 10 (of 10 total)