Forum Replies Created

Viewing 15 replies - 1 through 15 (of 60 total)
  • I’m using the Image Store plugin, I’ve just run an update and it says

    Click to run Image Store’s updates

    When I click the link I get this:

    403 Error:
    Forbidden

    You don’t have permission to access /wp-content/plugins/image-store/admin/update.php on this server.

    Hey,
    I’ve just changed the permissions as above but still not working.

    ok, I’ve just checked the database and its showing the full code, so there must be something refusing to show the \

    preg_replace('/\s+/', '', $postcode);

    Hey, I’ve added [raw] and [/raw] but all thats done is actually write [raw] above the slider. Very odd lol. I’ll have a look at the code.

    I’m sure that I must be able to use css to force the button to stay in the same place no matter what the div shows 🙁

    Any ideas?

    oh man! thank you so much – I just couldn’t see it even though I was using various developer tools!!

    I’m having to add loads of additional code to this, so I can get it displaying properly and its been several years since I used css and php – so many changes, so I’d convinced myself it was something serious rather than something daft like a padding!!!

    Thank you again 🙂

    I’ve checked the code again and I changed the code to:

    <input type="radio" name="services" class="ab-formElement ab-select-mobile ab-select-service" value="<?php echo esc_html( __( get_option( 'ab_appearance_text_option_service' ), 'ab' ) ) ?>" />

    which now displays:

    <input type="radio" name="services" class="ab-formElement ab-select-mobile ab-select-service" value=>
    <option value="1">Service 1</option>
    <option value="2">Service 2</option>
    </input>

    I cannot find out how its generating the options so that it displays the info above.

    Can you help please?

    Hi,
    I’ve disabled every other plugin on my site and removed the other reference to JQuery.
    Any other ideas as to whats causing this?

    ah, actually 3 things….

    Number 2:
    When I get the order confirmation it just says the name of the service, not the start and end time (which is displayed on the checkout pages etc)

    Number 3:
    One of my services is free so in appointments its price is set as 0
    When I select the time and date and select book appointment it pops up an alert saying we have your booking (its only this one that does it). In the checkout pages etc, this doesnt show the time – just the product name…

    Any ideas?

    In MarketPress – General – Misc settings I’ve set Limit Digital Products Per-order to No, and In the product called appointments I have tried having Limit Per Order? unticked and then ticked but limiting to 10 (I only offer 6 different services for appointments).

    I know this is quite an odd thing to ask, but I’m struggling with making your dropdown be a set of radio buttons…

    the code currently says:

    <div class="app_services_dropdown_select">
      <select name="app_select_services" class="app_select_services">
      <option value="1" selected="selected">Class IV MOT (Up to 3,000KG)</option>
      <option value="2">Class VII MOT (3,000KG - 3,500KG)</option></select>
      <input type="button" class="app_services_button" value="Show available times">
    </div>

    However I’m trying to get it to change to radio buttons

    <div class="app_services_dropdown_select">
       <input type="radio" name="app_select_services" class="app_select_services" value="1" />Class IV MOT (Up to 3,000KG)
       <input type="radio" name="app_select_services" class="app_select_services" value="2" />Class VII MOT (3,000KG - 3,500KG)
       <input type="button" class="app_services_button" value="Show available times">
    </div>

    I found class_app_shortcodes.php and I’ve changed the PHP to this:

    $s .= '<div class="app_services_dropdown_select">';
    		//$s .= '<select name="app_select_services" class="app_select_services">';
    		if ( $services ) {
    			foreach ( $services as $service ) {
    				$service_description = '';
    				// Check if this is the first service, so it would be displayed by default
    				if ( $service->ID == $appointments->service ) {
    					$d = '';
    					$sel = ' checked="checked"';
    				}
    				else {
    					$d = ' style="display:none"';
    					$sel = '';
    				}
    				// Add options
    				//$s .= '<option value="'.$service->ID.'"'.$sel.'>'. stripslashes( $service->name ) . '</option>';
    				$s .= '<input type="radio" name="app_select_services" class="app_select_services" value="'.$service->ID.'"'.$sel.' />'. stripslashes( $service->name ).'<br />';
    
    				// Include excerpts
    				$e .= '<div '.$d.' class="app_service_excerpt" id="app_service_excerpt_'.$service->ID.'" >';
    				// Let addons modify service page
    				$page = apply_filters( 'app_service_page', $service->page, $service->ID );
    				switch ( $description ) {
    					case 'none'		:		break;
    					case 'excerpt'	:		$service_description .= $appointments->get_excerpt( $page, $thumb_size, $thumb_class, $service->ID ); break;
    					case 'content'	:		$service_description .= $appointments->get_content( $page, $thumb_size, $thumb_class, $service->ID ); break;
    					default			:		$service_description .= $appointments->get_excerpt( $page, $thumb_size, $thumb_class, $service->ID ); break;
    				}
    				$e .= apply_filters('app-services-service_description', $service_description, $service, $description) . '</div>';
    			}
    		}
    		//$s .= '</select>';
    		$s .= '<input type="button" class="app_services_button" value="'.$show.'">';
    		$s .= '</div>';

    but when I select one of the radio buttons my url changes to ?app_service_id=undefined and it doesnt work, however if I manually change the url to ?app_service_id=1 or ?app_service_id=2 then it works.

    Can you point me in the right direction please?

    Hey, I see what you’ve done thank you 🙂

    I’m actually trying to have two images side by side instead of the actual drop down.

    [Class IV MOT] [Class VII MOT]

    then you click either the Class IV or Class VII image and it displays the calender.

    I’m guessing I’m going to need to change the actual code to do this rather than an easy css job lol

    Hi David!

    Thats perfect, thank you 🙂

    Hey,

    I’ve done this as requested but I’ve not had the reset tool yet.
    Can you check this please?

    I’ve also got Custom Contact Forms installed,

    How can I allow a role to view the submitted form data?

Viewing 15 replies - 1 through 15 (of 60 total)