Forum Replies Created

Viewing 9 replies - 106 through 114 (of 114 total)
  • But there is still an issue with your plugin, as out-of-the-box it does not work. You need to fix your language file emplacements.

    Didier.

    I found the bug myself.

    When adding the french translation file via the plugin menu feature, there are no french translations. It is just a template ! This should have been mentioned. There is also no way to edit those language files.

    So I copied the french translations files from Loco Translate to the “uploads” folder (/wp-content/uploads/Languages_WD/faq-wd), overwrite both existing files.

    Now french translations are being picked up.

    • This reply was modified 2 years, 3 months ago by swissspaceboy.

    yip..worked for me as my full backup was blocked since weeks..

    Add this in your htaccess

    RewriteEngine on
    RewriteRule .* – [E=noabort:1]

    • This reply was modified 2 years, 4 months ago by swissspaceboy.

    Hi Jason,

    Using “Taylor” theme from templatemonster. I know that the plugin is adding the extra line in the content subject everywhere. But the excerpt seems fine to me. Will have a deeper look into this.

    Your plugin is compatible with version 4.7 or 4.8 ? Does it work for you ?

    Anyway, this is a problem that the content itself is modified. When you share for example to LinkedIn, the reading time gets shared too as part of the article. Not great.

    I think that I will use your plugin for the admin settings, css etc., but call the display code only for posts without modifying the content itself. Seems a more correct way to code this thing !

    Seems that another user was having the same problem of having the plugin displaying everywhere.

    But big thanks for the development of this plugin !

    Thanks.

    Didier.

    yip..fixed the same error too. I changed the first occurrence in the file only, not the second occurrence.

    Thanks for the fix !

    • This reply was modified 2 years, 6 months ago by swissspaceboy.

    Works fine with 3.7. 🙂

    There is a difference. I could find this :

    * readme : link changed, and tested with 3.8,
    == Changelog ==
    = 1.4 =
    * CSS issue fixed.
    * wp-pagenavi-style.php : copyright for v1.4
    * wp-pagenavi-style-admin.css : change for wp_pn_style_IMG_preview

    So 1.4 is an update and I will install it…

    @all : this is my fix. As I have moved the css of this plugin to my theme stylesheet, there is no need to register the stylesheet.
    So in file core.php, function add_scripts(), comment out this piece of code :

    if ( $add_css ) {
    			$css_dev = defined( 'SCRIPT_DEBUG' ) && SCRIPT_DEBUG ? '.dev' : '';
    
    			wp_register_style(
    				'smart-archives',
    				$plugin_url . "styles$css_dev.css",
    				array(),
    				SAR_VERSION
    			);
    			scbUtil::do_styles( 'smart-archives' );
    		}

    This will avoid having a W3C validator error. Not great as fix but it works.

    Hi Scribu,

    Thanks for answering. I’m using the official W3C validator of course.

    Here is the full output of the page check:

    Error Line 1313, Column 215: document type does not allow element "link" here
    
    …archives-reloaded/inc/styles.css?ver=2.0" type="text/css" media="all" />'); });
    
    The element named above was found in a context where it is not allowed. This could mean that you have incorrectly nested elements -- such as a "style" element in the "body" section instead of inside "head" -- or two elements that overlap (which is not allowed).
    
    One common cause for this error is the use of XHTML syntax in HTML documents. Due to HTML's rules of implicitly closed elements, this error can create cascading effects. For instance, using XHTML's "self-closing" tags for "meta" and "link" in the "head" section of a HTML document may cause the parser to infer the end of the "head" section and the beginning of the "body" section (where "link" and "meta" are not allowed; hence the reported error).

    They propose to escape the html code with //<![CDATA[ //]]>

    like in this example :

    <script type="text/javascript">
    //<![CDATA[
    var output = "<html><body><p>Hi!<\/p><\/body><\/html>";
    //]]>
    </script>

    Do you have some ideas how to change this in files util.php or core.php ?

    Thanks,

    D.

Viewing 9 replies - 106 through 114 (of 114 total)