Forum Replies Created

Viewing 15 replies - 16 through 30 (of 244 total)
  • aarrrggg..I searched for the error in this forum, and no results returned.

    I missed the sticky topic of course. Stick or pin it better/bolder/higher..-> UPPERCASE with a lot of emoticons.. LOL

    Many thanks for the reply !

    Didier.

    okay 🙂

    Thanks for the reply and explanation!

    Didier.

    Sure Bill. I was almost sure that it was a false alarm as with many of those lint messages.

    And I prefer to warn too much than not enough!

    Thanks for your continuous support.

    Didier.

    swissspaceboy

    (@swissspaceboy)

    Hi Frank !

    I am upgrading from PHP 7.2 to 7.4, and I tried this plugin “PHP compact checker”. It gave these warnings for the plugin. Please have a look. Many thanks !

    Version: 2.7.8

    Nom: Autoptimize

    FILE: /wp-content/plugins/autoptimize/classes/autoptimizeCriticalCSSEnqueue.php
    —————————————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————————————————
    16 | WARNING | Global with anything other than bare variables is discouraged since PHP 7.0. Found ${$_option}
    —————————————————————————————————————

    FILE: /wp-content/plugins/autoptimize/classes/autoptimizeCriticalCSSSettingsAjax.php
    —————————————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————————————————
    16 | WARNING | Global with anything other than bare variables is discouraged since PHP 7.0. Found ${$_option}
    —————————————————————————————————————

    FILE: /wp-content/plugins/autoptimize/classes/autoptimizeCriticalCSSCron.php
    —————————————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————————————————
    17 | WARNING | Global with anything other than bare variables is discouraged since PHP 7.0. Found ${$_option}
    —————————————————————————————————————

    FILE: /wp-content/plugins/autoptimize/classes/external/php/jsmin.php
    ——————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ——————————————————————————————–
    109 | WARNING | INI directive ‘mbstring.func_overload’ is deprecated since PHP 7.2
    ——————————————————————————————–

    FILE: /wp-content/plugins/autoptimize/classes/autoptimizeCriticalCSSSettings.php
    —————————————————————————————————————-
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————————————————-
    106 | WARNING | Global with anything other than bare variables is discouraged since PHP 7.0. Found ${$_option}
    —————————————————————————————————————-

    FILE: /wp-content/plugins/autoptimize/classes/autoptimizeCriticalCSSCore.php
    —————————————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————————————————
    17 | WARNING | Global with anything other than bare variables is discouraged since PHP 7.0. Found ${$_option}
    —————————————————————————————————————

    swissspaceboy

    (@swissspaceboy)

    Another person complained also about the new firewall rules that block Python. I have added a comment to the support ticket on the WP forum.

    This ticket can be closed as the problem is not with this plugin 🙂

    Many thanks Bill.

    Didier

    swissspaceboy

    (@swissspaceboy)

    Hi Jeff,

    Got 403 error too for the visits log of plugin “StopBadBots” of Bill. Not python but XHR request.
    https://www.mydomain.ch/wp-admin/admin-ajax.php?action=stopbadbots_get_ajax_data&pll_ajax_backend=1&draw=1&columns%5B0%5D%5Bdata%5D=&columns%5B0%5D%5Bname%5D=&columns%5B0%5D%5Bsearchable%5D=true&columns%5B0%5D%5Borderable%5D=true&columns%5B0%5D%5Bsearch%5D%5Bvalue%5D=&columns%5B0%5D%5Bsearch%5D%5Bregex%5D=false&columns%5B1%5D%5Bdata%5D=1&columns%5B1%5D%5Bname%5D=&columns%5B1%5D%5Bsearchable%5D=true&columns%5B1%5D%5Borderable%5D=true&columns%5B1%5D%5Bsearch%5D%5Bvalue%5D=&columns%5B1%5D%5Bsearch%5D%5Bregex%5D=false&columns%5B2%5D%5Bdata%5D=2&columns%5B2%5D%5Bname%5D=&columns%5B2%5D%5Bsearchable%5D=true&columns%5B2%5D%5Borderable%5D=true&columns%5B2%5D%5Bsearch%5D%5Bvalue%5D=&columns%5B2%5D%5Bsearch%5D%5Bregex%5D=false&columns%5B3%5D%5Bdata%5D=3&columns%5B3%5D%5Bname%5D=&columns%5B3%5D%5Bsearchable%5D=true&columns%5B3%5D%5Borderable%5D=true&columns%5B3%5D%5Bsearch%5D%5Bvalue%5D=&columns%5B3%5D%5Bsearch%5D%5Bregex%5D=false&columns%5B4%5D%5Bdata%5D=4&columns%5B4%5D%5Bname%5D=&columns%5B4%5D%5Bsearchable%5D=true&columns%5B4%5D%5Borderable%5D=true&columns%5B4%5D%5Bsearch%5D%5Bvalue%5D=&columns%5B4%5D%5Bsearch%5D%5Bregex%5D=false&columns%5B5%5D%5Bdata%5D=5&columns%5B5%5D%5Bname%5D=&columns%5B5%5D%5Bsearchable%5D=true&columns%5B5%5D%5Borderable%5D=true&columns%5B5%5D%5Bsearch%5D%5Bvalue%5D=&columns%5B5%5D%5Bsearch%5D%5Bregex%5D=false&columns%5B6%5D%5Bdata%5D=6&columns%5B6%5D%5Bname%5D=&columns%5B6%5D%5Bsearchable%5D=true&columns%5B6%5D%5Borderable%5D=true&columns%5B6%5D%5Bsearch%5D%5Bvalue%5D=&columns%5B6%5D%5Bsearch%5D%5Bregex%5D=false&columns%5B7%5D%5Bdata%5D=7&columns%5B7%5D%5Bname%5D=&columns%5B7%5D%5Bsearchable%5D=true&columns%5B7%5D%5Borderable%5D=true&columns%5B7%5D%5Bsearch%5D%5Bvalue%5D=&columns%5B7%5D%5Bsearch%5D%5Bregex%5D=false&columns%5B8%5D%5Bdata%5D=8&columns%5B8%5D%5Bname%5D=&columns%5B8%5D%5Bsearchable%5D=true&columns%5B8%5D%5Borderable%5D=true&columns%5B8%5D%5Bsearch%5D%5Bvalue%5D=&columns%5B8%5D%5Bsearch%5D%5Bregex%5D=false&columns%5B9%5D%5Bdata%5D=9&columns%5B9%5D%5Bname%5D=&columns%5B9%5D%5Bsearchable%5D=true&columns%5B9%5D%5Borderable%5D=true&columns%5B9%5D%5Bsearch%5D%5Bvalue%5D=&columns%5B9%5D%5Bsearch%5D%5Bregex%5D=false&order%5B0%5D%5Bcolumn%5D=0&order%5B0%5D%5Bdir%5D=desc&start=0&length=10&search%5Bvalue%5D=&search%5Bregex%5D=false&_=1606044208261

    swissspaceboy

    (@swissspaceboy)

    Hi Bill,

    ha..found the one..BBQ – Block bad queries. This firewall doesn’t like your query string 🙂

    What to do next? I write to Jeff the author, or you write to him?

    https://wordpress.org/support/plugin/block-bad-queries/

    I have version 20201116 installed of BBQ.

    Thanks,

    Didier.

    Thanks for the fix.

    You update very frequently, so I can wait for the next plugin update.

    Have a good day ahead !

    Didier.

    Hi Bill,

    With v6.19, I still have this missing file

    /wp-content/plugins/stopbadbots/assets/images/sort_both.png

    I cannot see in the list of files for that folder.

    Can you check please?

    Thanks,

    Didier.

    Hi Steven,

    But what about the 404 error that I get when clicking on chapter4 that is displayed on another page?
    Can you check if you have the same bug please?

    Thanks,

    Didier.

    Hello,

    Thanks for the fix. This is now under test. I report back if I see some issues with it.

    Bye,

    Didier.

    Hi Steven,

    Thanks for replying.

    You are right, my page 2 has not enough headings (4). When I change to 2 headings, I have another bug. Now page 1 shows

    – chapter1
    – chapter2
    – chapter3
    – chapter4.

    but when I click on “chapter4” I should go to the next page, but I get a 404 error. When I go to page 2, I can click on the “chapter4” link with no error.

    When I show 4 headings, I see nowhere my chapter4 in the TOC, not on page 1, nor on page 2. This is not correct no?

    I think that we should show the full TOC on all pages and ensure that the auto-pagination works. Don’t know if WP supports this.

    Thanks for the check.

    Didier.

    *bump*

    Hi,

    Tested after the plugin update for the book schema
    1. bookformat: perfect
    2. Inlanguage: works fine.

    Just one small remark cf. the Inlanguage: Per Google, Schema requires the 2-letter ISO code like “en”. You have put as placeholder “English” which does not match the requirement per Google. I don’t know if this is important for Schema compatibility, so I prefer to let you know. On the Schema webpage, you can put both syntax (en and English). Not clear if Google is right or Schema 🙁

    Here the extract from https://developers.google.com/search/docs/data-types/book

    inLanguage

    Text

    The main language of the content in the edition. Use one of the two-letter codes from the list of ISO 639-1 alpha-2 codes.

    Many thanks for the improvement ! The ticket can be closed.

    Didier.

    This is now fixed by a theme update.

    Didier.

Viewing 15 replies - 16 through 30 (of 244 total)