Forum Replies Created

Viewing 4 replies - 1 through 4 (of 4 total)
  • What I do to cleanup this malware (GD-LIB):
    – delete /wp-content/mu-plugins/gd-lib.php (it’s not really a must-use plugin)
    – edit wp-config.php and remove these entries:
    * REMOVE THIS LINE : require_once(ABSPATH . ‘wp-content/mu-plugins/gd-lib.php’);
    * REMOVE THIS WHOLE SECTION (otherwise it gives error 500)
    /*if (function_exists(‘wp_remote_request’)) {
    *wp_remote_request( “http://”.$_SERVER[‘HTTP_HOST’].”/gd-config.php”, array(
    * ‘method’ => ‘BAN’,
    * ‘headers’ => array(
    * ‘Host’ => $_SERVER[‘HTTP_HOST’]
    * )
    * ) );
    *}
    */

    found this commented code in your source, it hinted me where to edit and obtain my specific item:

    $report .= ‘<td>’.($value).'</td>’;//is_array(maybe_unserialize($value))?print_r(maybe_unserialize($value),1):

    It shows that you were already working on something along the idea of using ‘maybe_unserialize’, thanks a lot!

    I need only an item of the array for my personal purposes. Is there a hook or something that I can use to customize your plugin for my needs? Could you provide a minimal example in order to learn where to hook my custom code? thanks

    Hello Eliot, thanks for the quick update.
    With the syntax I provided it works wonderfully:

    [if field=dop]OK[else]KO[/if]

    But it doesn’t work with this simpler syntax as in:

    [if dop]OK[else]KO[/if]

    It would be wonderful to have it working even with this syntax in a future update!

    Thank you very much!!!

Viewing 4 replies - 1 through 4 (of 4 total)