Forum Replies Created

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hey,

    thanks for the reply. i’m using a completly clean installation without any plugins. so there is no caching and the debug log is empty.

    a) is there maybe another loop for the event calendar, which is called the “the_content()” function?

    b) how do i get the current event ID when i’m on a single event page? i’m always getting a “0”, wether i’m on the overview or on the single event page. i understand, that there is no “physical page” for the overview (like an archive), but i should get an id on the single page, right?

    there are some more informations for you.

    in the index.php:

    <!doctype html>
    <html lang="de">
        <head>
            [...]
            <?php wp_head(); ?>
        </head>
        <body>
            <header>
                <div class="title">
                    <?php
                        if( is_singular( 'tribe_events' ) ) {
                            // we are on a single event page
                            ?>
                               <h1>HELP! how to get the event name?</h1>
                            <?php
                        } else {
                            // we are not on an single event page
                            ?>
                               <h1>other headline - doesnt matter</h1>
                            <?php
                        }
                    ?>
                </div>
            </header>
    
            <?php
                if ( have_posts() ) {
                    // Load posts loop.
                    while ( have_posts() ) {
                        the_post();
                        the_content();
                    }
                }
            ?>
            <?php wp_footer(); ?>
        </body>
    </html>

    i display the content of the event overview and the single event details via “the_content()” .. so, technically i’m in the index.php without a page in the background. that’s the reason why i get a 0 when i var_dump the get_the_id() value. i think this might be the reason why i get a NULL for get_the_title(). but how do i get the information instead? when i use get_the_title() in the loop, im not getting the title either, so this must be an other issue. im clueless.

    • This reply was modified 10 months, 2 weeks ago by pixelfeinkost.

    Yeah, i checked all of it and i’m up to date.

    i checked the output from the plugin, and i just get events from the current month. i don’t know what to do.

    i just tried the default settings, doesn’t help.

    my fault. i noticed an error in my own calendar-class where i merged some entries from wordpress with my google-calendar entries. i’m sorry.

Viewing 4 replies - 1 through 4 (of 4 total)