Forum Replies Created

Viewing 15 replies - 1 through 15 (of 666 total)
  • Thread Starter Ov3rfly

    (@ov3rfly)

    The issue is not resolved, “likely need to trial and experimentation” is not an answer to a question for a version number.

    Thread Starter Ov3rfly

    (@ov3rfly)

    @pcosta88 Thanks for your response.

    .. we only support issues related to v5.5.4 or v5.6 of WordPress

    We were not aware that WordPress 5.5.4 is released, thanks for this information.

    Everything else you said has been posted already literally word by word by your support colleagues weeks ago and we already have carefully evaluated every link and communicated all the information to clients and already are in the process to drop Yoast SEO and switch to a competitor plugin that is able to support compatibility to further back WordPress branches.

    Our only desire was to know which Yoast SEO version is compatible to WordPress 5.4.x, and while we got no answer for this question, we still are glad we asked as the outcome was very helpful to adjust our selection of recommended plugins.

    Thread Starter Ov3rfly

    (@ov3rfly)

    @mikes41720 FYI, after communicating your support strategy to more clients, we now dropped Yoast SEO at a total of 38 sites, more coming.

    Thread Starter Ov3rfly

    (@ov3rfly)

    In fact I could not find any theme that reads array-options downloading random themes from the repo.

    • Airi in class-tgm-plugin-activation.php – get_option( ‘recently_activated’ )
    • probably more themes which use TGMPA
    • MH Magazine lite in functions.php and others (save customizer at least once) – get_option(‘mh_magazine_lite_options’)
    • MH NewsDesk lite in functions.php and others (save customizer at least once) – get_option(‘mh_newsdesk_lite_options’)
    • probably more MH Themes lite versions
    • MH Magazine (not in repo) – in functions.php and others
    • MH NewsDesk (not in repo) – in functions.php and others

    The author of the relevant plugin code was obviously aware that $line param also could be not a string, that’s why $line is always cast to string. Won’t argue about reasons why this has not been noticed or maybe has been noticed but not been tracked down before. It’s clearly a bug though. Thanks for supporting the plugin, I never used it before, just found it at two sites now in one week when being asked to fix issues of the sites.

    Thread Starter Ov3rfly

    (@ov3rfly)

    Thanks for quick feedback.

    wondering why it was never reported until now…

    My guess would be that many users simply install & activate this plugin and that’s it. They never start a scan or even open the configuration page. This renders the plugin pretty useless but users feel safe because they installed it and it is active. A similar feeling is generated when long outdated, incompatible and/or abandoned plugins show no updates in plugins list so users think everything would be up to date, a well known major flaw in WordPress plugin repository, but that’s a different story.

    My second guess would be insufficient testing before releases. Previous reports in forums and also directly to various plugin authors showed that many authors don’t bother to even once enable WP_DEBUG or otherwise allow notices and warnings on their testservers.

    Thread Starter Ov3rfly

    (@ov3rfly)

    Analyzed the array, it appears to be the result of a get_option() call.

    1. Put this as 1.php in any theme like twenty ninteen/twenty/twentyone:

    <?php
    $x = get_option('active_plugins');
    

    2. Add a check at beginning of _check_file_line() similar to this:

    if ( is_array( $line ) ) {
    	die( print_r( $line ) );
    }

    3. Start a manual scan.

    4. Watch ajax response in browser.

    Something is seriously broken in current plugin logic.

    • This reply was modified 3 months ago by Ov3rfly.

    Same file is detected with theme MH Magazine.

    Full content here, expires in 7 days.

    Thread Starter Ov3rfly

    (@ov3rfly)

    @mazedulislamkhan Thanks. After showing your information link to client, they decided to drop Yoast SEO in favour of a competitor who provides compatibility to WordPress 5.4.x and further back.

    @shazahm1hotmailcom Thanks for your insight.

    Thread Starter Ov3rfly

    (@ov3rfly)

    WordPress 5.4.4 was released only 6 weeks ago, that’s not outdated.

    And you might be aware of breaking changes in WordPress 5.5 which forced many sites with older plugins & themes staying in 5.4.x branch for now and some probably forever as their theme won’t be updated and they won’t change theme.

    Unfortunately can’t find 5.4.x support end date in the changelog.

    You might want to rethink your policy. With your current support policy your plugin is unusable for any WordPress older than 3.5 months.

    Thread Starter Ov3rfly

    (@ov3rfly)

    Error: Cookies are blocked due to unexpected output. For help, please see this documentation or try the support forums.

    That’s what people on impacted sites get when they try to login and update 1.4.0 manually, screenshot: https://imgur.com/ZM2tNrH

    Reason is described here.

    Thread Starter Ov3rfly

    (@ov3rfly)

    Stop marking this problem as resolved as long as there is even one site out there that is defaced or completely offline due to this bug..

    ..and currently there are many sites!

    It would be your responsibility to search for and fix all these sites, did you even try?

    Thread Starter Ov3rfly

    (@ov3rfly)

    .. find the Cache Enabler changelog in the Development section. ..

    It says 1.4.1 Fix minor bugs, that’s not a proper changelog. This is the wordpress.org plugin repository, no regular user reads a GitHub commit log.

    .. This would have only caused an issue with the advanced cache settings file, nothing else. ..

    This bug caused two different warnings:

    Warning: Use of undefined constant CE_SETTINGS_PATH - assumed 'CE_SETTINGS_PATH' (this will throw an Error in a future version of PHP) in .../wp-content/plugins/cache-enabler/inc/cache_enabler_disk.class.php on line 572

    Warning: Use of undefined constant CE_SETTINGS_PATH - assumed 'CE_SETTINGS_PATH' (this will throw an Error in a future version of PHP) in .../wp-content/advanced-cache.php on line 31

    These warnings are now shown in frontend of various sites.

    They also crashed a number of sites completely, those show gzip raw data now, screenshot: https://imgur.com/HOwXVDU

    Settings files have been written to root folder of WordPress.

    I have assisted some broken sites to get back up during the day but several are still down or defaced with the warnings. You can find examples via searches for the CE_SETTINGS_PATH constant name with optional additional keywords, a Google example has been given in my initial bug report.

    Thread Starter Ov3rfly

    (@ov3rfly)

    Rolled back to an earlier version, no time to keep up with this now…

    Please provide a proper changelog, thanks.

    Thread Starter Ov3rfly

    (@ov3rfly)

    Thanks for information, the update has been released only a few minutes ago.

    I will mark the problem as resolved after I have checked everything in detail to find out if the problem is really resolved for me.

    Thread Starter Ov3rfly

    (@ov3rfly)

    Please stop marking unresolved problems as resolved.

    The problem in this thread is not resolved yet, no correct update has been released.

    I will mark the problem as resolved after it has been actually resolved for me.

    Please also do not delete tags, thanks.

Viewing 15 replies - 1 through 15 (of 666 total)