Forum Replies Created

Viewing 15 replies - 1 through 15 (of 75 total)
  • Oh!! I just found this, Tobias already made it. Thank you Tobias!
    I had not searching the right terms before:

    https://tablepress.org/extensions/table-caption-html-tag/

    This should help you @pbossley

    I modified Tobias’ plugin to use an <h2> tag inside the <caption>

    
    function tablepress_table_caption_html_tag( $caption, $table ) {
      $caption = preg_replace( '/&(?![A-Za-z]{0,4}\w{2,3};|#[0-9]{2,4};)/', '&', $table['name'] );
      return '<h2 class="tablepress-table-name">' . $caption . '</h2>';
    }
    

    @tobiasbg maybe consider making this an option on the basic plugin? I feel like this is semantically a more correct use of the <caption> tag.

    • This reply was modified 10 months, 2 weeks ago by nimmolo.
    • This reply was modified 10 months, 2 weeks ago by nimmolo.
    • This reply was modified 10 months, 2 weeks ago by nimmolo.
    Plugin Author nimmolo

    (@nimmolo)

    @alfabetadigital,

    Well, this hasn’t been a quick reply, has it? Sorry. I’m going to have to revise this section of the code of the plugin.

    Check this out.
    http://johnnythetank.github.io/youtube-channel-name-converter/

    Your channel ID according to this lookup tool is “UCVx_-M7ByJy0EQXCyE7zunA”.
    Yes, that is not intuitively obvious.

    Plugin Author nimmolo

    (@nimmolo)

    Hi @chillestbro,

    It’s unfortunately YouTube that makes it hard to determine a channel name via their API. Here’s what i wrote in a support thread awhile back:

    With youtube it is very confusing to figure out the channel name, I spent an hour trying to figure out my own client’s channel name.

    It’s often NOT the hash after the /user/ in the youtube channel URL. Check out this channel here:

    https://www.youtube.com/user/thekiteboatproject/featured

    The channel name is actually “kiteboat”, the title that appears beside the logo, above the number of subscribers on that page. I don’t get it either!

    If you have multiple channels, switch to that channel to get the name. It’s very frustrating, I agree.

    On your other question, no, we aren’t harvesting anything. Silvia originally wrote the plugin years ago, and I rewrote it for a client who was paying me to make them a website with a lot of video content. The rewrite was so much work (almost 200 hours!) that I thought it might benefit others as a free plugin.

    APIs can seem obscure, but if you read through the plugin code you’ll realize the plugin is storing only the channel name and an encrypted key authenticating you as the owner of that channel. This key is generated by YouTube (or another service) itself, and it prevents you having to log back into your YouTube account every time you want to update a video from your channel.

    It surely will delete itself from your WP install, but if you want to delete the imported videos you have to use the plugin to do that before you delete the plugin. No plugin is going to go around deleting WP posts before it deactivates, you have to do something that serious manually.

    Plugin Author nimmolo

    (@nimmolo)

    Hi alfabetadigital,

    With youtube it is very confusing to figure out the channel name, I spent an hour trying to figure out my own client’s channel name.

    It’s often NOT the hash after the /user/ in the youtube channel URL. Check out this channel here:

    https://www.youtube.com/user/thekiteboatproject/featured

    The channel name is actually “kiteboat”, the title that appears beside the logo, above the number of subscribers on that page. I don’t get it either!

    If you have multiple channels, switch to that channel to get the name. It’s very frustrating, I agree. What can you expect from a company who changes their product name every 6 months!

    Plugin Author nimmolo

    (@nimmolo)

    Thank you @ianmacin!!!

    Everyone please update the plugin, i can’t see how it worked without these directories!!!

    Plugin Author nimmolo

    (@nimmolo)

    @ianmacin You’re right, and this means there are quite a few other assets missing from the WordPress Plugins SVN repo, compared to our GitHub version. Not sure how it happened, but will fix.

    The /*/ folders referenced in that line of the external-videos.php file should have other important files relating to the media explorer for each service.

    Will start the update process this weekend.

    Plugin Author nimmolo

    (@nimmolo)

    @asombroso,

    Please check your browser console log and let me know if you see any errors in the console when your browser is loading the WordPress Dashboard.

    You may have to enable the console in your browser:
    https://developer.mozilla.org/en-US/docs/Tools/Browser_Console
    https://developers.google.com/web/tools/chrome-devtools/console/
    https://msdn.microsoft.com/en-us/library/gg589530(v=vs.85).aspx
    https://developer.apple.com/safari/tools/

    Certainly there is a javascript error being thrown by your theme or one or more plugins. If you find the error I will research the solution for you. Please help, without some indication of the problem I don’t have time to look into it!

    Plugin Author nimmolo

    (@nimmolo)

    Hi Skymashitv,

    In all of my installs here, the plugin settings page still works fine with default theme twentyseventeen and no other plugins activated. It also works with all the plugins i use, but that’s not every plugin out there 🙂

    When testing with plugins/themes disabled, be sure to disable the cache in your browser, or you will definitely still get the script conflicts.

    If you can find the plugin that breaks the script, I will investigate, but I do need your help, since I have a lot of work to do to make a living.

    I just tested Visual Composer and Black Studio TinyMCE Widget, because they both use a lot of js, but it wasn’t either of them. Newstube is a paid theme, so if you want me to test it please send a copy. (also for any paid plugins)

    Please see what you can find with the cache disabled, and when you find it I will work to find a solution.

    • This reply was modified 2 years, 11 months ago by nimmolo.
    Plugin Author nimmolo

    (@nimmolo)

    If anyone else is having this problem, please post your theme and plugin configuration. The plugin itself doesn’t have errors, but if your theme or plugins are throwing javascript errors, the plugin admin won’t work correctly.

    Posting the theme info helps me notify and hopefully help the theme/plugin author fix their code!

    I’m marking this resolved…

    Plugin Author nimmolo

    (@nimmolo)

    Hi @foley2013!

    Thanks for reporting the issue and for trying the plugins deactivation.

    I want to get to the bottom of the issue, so please stick with me! I think it’s probably the theme, but to find out i’d need to set up my test site exactly as yours is set up.

    Can you let me know which theme and which plugins it requires?

    Thanks
    Nimmolo

    Thanks V, i get it now :).

    Plugin Author nimmolo

    (@nimmolo)

    Hi @weisbergweb

    I just tested it locally with WP 4.7.3 and the default theme “twentyseventeen”. Everything’s ok.

    The External Videos admin tabs are built with javascript. The most likely situation is that your theme, or another plugin you’re using, is throwing a javascript error on the admin side; the error is blocking subsequent javascript execution. (Another possibility is that you’ve disabled javascript in your browser, but you would probably know if this was the case).

    Let me know if you need help troubleshooting plugins. If you can use your browser’s developer console, you may be able to find the script causing the error directly. Otherwise, generally the procedure is to turn off all other plugins and switch to the default theme. Then, turn plugins back on a few at a time until the error appears.

    • This reply was modified 3 years, 4 months ago by nimmolo. Reason: Followed up with a test
    Plugin Author nimmolo

    (@nimmolo)

    Welcome – let us know how it’s working for you, and if there’s any other feature you’d like to have in the plugin.

    Plugin Author nimmolo

    (@nimmolo)

    Hi @wasanajones,

    No – the videos are not downloaded. It’s a bit tricky to describe – the videos are available to add to other posts via the media window AS IF they were in your media library, but:

    What’s going on is, a script looks through your external-videos posts to find each video’s playback info (URL, title, description and thumbnail). Then it puts together a grid of these videos for the Add Media window, similar to the grid of other kinds of attachment thumbnails. When you add a video to posts however (or anywhere you can use the media uploader), what gets added is always just the embed URL for playback, not the video file.

    Tobias thanks,

    why not just write up a quick page on your Tablepress site documenting the ways to use this feature? it looks like it’s been around 3 years now.

    The extra column is definitely workable, but… highlighting specific rows is pretty basic for layout control of tables. it doesn’t seem the documentation for this should be so obscure.

    Anyway – my question is how to pass the row-highlight arguments to the template tag tablepress_print_table function. I’ve read through the plugin code, but it’s still not clear. Does it go in an args array?

    • This reply was modified 3 years, 6 months ago by nimmolo.
Viewing 15 replies - 1 through 15 (of 75 total)