Forum Replies Created

Viewing 15 replies - 1 through 15 (of 18 total)
  • Thread Starter mrloco

    (@mrloco)

    It seems that it is all about custom product base permalink /shop/%product_cat%/. After default language changing something went wrong… But what? 😀

    Thread Starter mrloco

    (@mrloco)

    I talk to them(WPML) for a week or maybe two, but nothing. I thought, maybe woocommerce may have some settings or maybe reinstall woocommerce?

    Thread Starter mrloco

    (@mrloco)

    Hi!

    I have found the problem. The problem was, that i didn’t set categories.

    Thread Starter mrloco

    (@mrloco)

    Thread Starter mrloco

    (@mrloco)

    query

    Query Screenshot. Do you see something?

    Thread Starter mrloco

    (@mrloco)

    # BEGIN LSCACHE
    # END LSCACHE
    # BEGIN NON_LSCACHE
    # END NON_LSCACHE
    # BEGIN WordPress
    # The directives (lines) between “BEGIN WordPress” and “END WordPress” are
    # dynamically generated, and should only be modified via WordPress filters.
    # Any changes to the directives between these markers will be overwritten.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* – [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    # LBROWSERCSTART Browser Caching
    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresByType image/gif “access 1 year”
    ExpiresByType image/jpg “access 1 year”
    ExpiresByType image/jpeg “access 1 year”
    ExpiresByType image/png “access 1 year”
    ExpiresByType image/x-icon “access 1 year”
    ExpiresByType text/css “access 1 month”
    ExpiresByType text/javascript “access 1 month”
    ExpiresByType text/html “access 1 month”
    ExpiresByType application/javascript “access 1 month”
    ExpiresByType application/x-javascript “access 1 month”
    ExpiresByType application/xhtml-xml “access 1 month”
    ExpiresByType application/pdf “access 1 month”
    ExpiresByType application/x-shockwave-flash “access 1 month”
    ExpiresDefault “access 1 month”
    </IfModule>
    # END Caching LBROWSERCEND

    Thread Starter mrloco

    (@mrloco)

    Hi!

    500 error resolved with this: https://wpml.org/errata/htaccess-is-rewritten-with-language-folder/. I resolved the problem, but we did not recognize, why the problem was.

    An empty shop page not resolved. Some plugin/thing change the .htaccess file – maybe this is the clue. But i still do not know, what affects that.

    I tried to work with plugins( disabling all plugins except for WooCommerce and switch to the Storefront theme.). But nothing. I did not find anything.
    The empty shop page appears then i am doing something in the backend(save something or change something).

    Thread Starter mrloco

    (@mrloco)

    Today morning it was blank page as well. Today morning was YOAST update also.
    After update, the SHOP page appears well. I will watch the situation and hope this update fixes that blank page bug.

    update
    Sorry…I hoped that fixed but the blank page returned.

    • This reply was modified 2 months, 3 weeks ago by mrloco.
    Thread Starter mrloco

    (@mrloco)

    Hi,
    Products are available.

    Thread Starter mrloco

    (@mrloco)

    Hi,

    I did what you recommended some time ago and nothing…
    I would like to mention that “blank SHOP page” means, that there are no products, but categories and filters on the right and page name “shop” are visible.

    Thread Starter mrloco

    (@mrloco)

    I tried this ‘troubleshooting mode’ and all was good. But after 10 minutes SHOP page was blank again.

    Thread Starter mrloco

    (@mrloco)

    I did check with Health Check & Troubleshooting plugin and all was good.
    But the blank shop page still appears sometimes (few times per day) so i can not understand, what exactly cause this blank page…

    Thread Starter mrloco

    (@mrloco)

    There is one error:

    (index):22 GET https://connect.facebook.net/en_US/fbevents.js net::ERR_BLOCKED_BY_CLIENT
    (anonymous) @ (index):22
    (anonymous) @ (index):22

    Maybe some YAOST settings may call the shop blank page.
    (it is blank a few times per day and I need to update few times a day. Not very comfortable :))

    Thread Starter mrloco

    (@mrloco)

    Hi, sorry. Ofcourse SHOP. Yes, it works because i update the shop page few times a day.

    Ok, i will try to find javascript errors.

    Thread Starter mrloco

    (@mrloco)

    Ok. Old means urls, that are changed. For example product name was “egg” and now “eggs”.
    So now i see 404 for add to wishlist with “egg”. Product, that not exist any more. I do not know, where from are this urls now:)

Viewing 15 replies - 1 through 15 (of 18 total)