Forum Replies Created

Viewing 10 replies - 1 through 10 (of 10 total)
  • No, it was here on wordpress.org

    Hi,

    I disabled cookie consent from Facebook/Google and the testing page: https://dev.studierenplus.de/kasse is now available to access without htaccess.

    If you need access to this site, please write your email address into the form https://dev.studierenplus.de/kontakt and I’ll send you some login credentials.

    On my productive site, I’ve stopped updating WC, because of the issues…

    Greetings, Mathias

    Hi Mike,

    I’m still checking your Information and will give you access to my dev-environment, where the error is accessable…

    Greetings, Mathias

    @nixiack8 You are kidding me?

    I have not heared back from you a longer time.

    @jessepearson And the email-address isn’t incorrect. The issue is in the initial post. And with 3.7 the issue still persists.

    The error with the email-address appears, when I click “buy” and the payment method option is still blocked by “blockUI blockOverlay”.

    And I’m using the plugin woocommerce one page checkout, which is now part of automattic.

    So you’d made no really effort to check or solve the issue. But in closing tickets to cleanup your statistics, you’re great. Wow!

    How can I escalate the issue, that your answer took 2 month, and was fokused only on the last answer, but not the problem I described?, but when I’m not answering in 1 week, you’re closing the ticket?

    mathias

    (@mobiledigs)

    Thats all of your support? One quick check without any really debugging?

    I got this error report:

    FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught WC_Data_Exception: Bitte gib eine gültige E-Mail-Adresse an. in /.../wp-content/plugins/woocommerce/includes/data-stores/class-wc-customer-data-store.php:110
    Stack trace:
    #0 /.../wp-content/plugins/woocommerce/includes/class-wc-data-store.php(169): WC_Customer_Data_Store->create(Object(WC_Customer))
    #1 /.../wp-content/plugins/woocommerce/includes/abstracts/abstract-wc-data.php(210): WC_Data_Store->create(Object(WC_Customer))
    #2 /.../wp-content/plugins/woocommerce/includes/class-wc-ajax.php(351): WC_Data->save()
    #3 /.../wp-includes/class-wp-hook.php(286): WC_AJAX::update_order_review('')
    #4 /.../wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters('', Array)
    #5 /.../wp-includes/plugin.php(465): WP_Hook->do_action(Array)
    #6 /.../wp-content/plugins/woocommerce/includes/class-wc-ajax.php(87): do_action('wc_ajax_update_" while reading response header from upstream, client: 91.66.122.35, server: dev.studierenplus.de, request: "POST /?wc-ajax=update_order_review HTTP/2.0", upstream: "fastcgi://unix:/var/run/php/php7.3-fpm.sock:", host: "dev.studierenplus.de", referrer: "https://dev.studierenplus.de/kasse/"

    but the email-address is still correct

    mathias

    (@mobiledigs)

    Hi Con,

    no I have not such a Plugin. These Code is disabled via css, so I think this is the “normal” backup <noscript> Option for this form. On https://www.studierenplus.de/kasse you can see this, too.

    But this option does not show up, so this is not the issue. The issue is the disappearing of the payment methods, or as logged in user the loading-circle, which does not end.

    Greetings, Mathias

    Solution: https://wordpress.org/support/topic/inkompatibel-mit-woocommerce-3-4-0/#post-10315094

    change the file src/WC/PayPalPlusGateway.php
    Line 283 private function can_refund_order( \WC_Order $order ) {

    to public function can_refund_order( $order ) {

    Hi,

    ich habe folgenden Fehler erhalten

    Fatal error: Access level to WCPayPalPlus\WC\PayPalPlusGateway::can_refund_order() must be public (as in class WC_Payment_Gateway) in /wp-content/plugins/woo-paypalplus/src/WC/PayPalPlusGateway.php on line 648

    nach dem Ändern der Zeile 283 in src/WC/PayPalPlusGateway.php

    funktioniert alles wieder 🙂

    Gruß, Mathias

    mathias

    (@mobiledigs)

    Hallo Bernd,

    danke für die Info. Ich hatte die Server Logs durchgesehen und dann WP_DEBUG aktiviert, um zu sehen, wo die Meldungen auftreten.

    Gruß aus Berlin,

    Mathias

    Hi Takis,

    I tried this before with debug=true…

    But after your mention, I checked all location and found in my config this include /etc/nginx/expires.conf;

    There is a addition config for my images like:

    # Media: images, icons, video, audio, HTC
    	location ~* \.(?:jpg|jpeg|gif|png|ico|cur|gz|svg|svgz|mp4|ogg|ogv|webm|htc)$ {
      		expires 1M;
      		#access_log off;
      		add_header Cache-Control "public";
      		add_header Cache-Control "immutable";
      		rewrite \.(?:jpe?g|gif|png)$ /wp-content/plugins/adaptive-images/adaptive-images-script.php;
    	}

    After adding the rewrite rule, it works perfect.

    Thank you 🙏 for your help!

    Mat

Viewing 10 replies - 1 through 10 (of 10 total)