Forum Replies Created

Viewing 3 replies - 1 through 3 (of 3 total)
  • Also, I tried the plugin both on a live site and on a VM locally.

    Using this plugin was aggravating and I admit that after struggling with it for hours over several days I did not feel like going through everything I did in a review. So the review is out of frustration. I will say this, all I ever got out of the plugin while trying to authenticate was messages like, “Could not complete OAuth 2.0 login. Check Postman Console for more details.”

    I have authenticated with Oauth2 in Postman many times before. I am not unfamiliar with the process. Now I am spending more time looking for the stackoverflow solutions I tried over days to resolve this problem to answer this comment. I can authenticate with Basic Authentication without a problem. But I did reinstall it and got a console message I did not get before.

    <head/>
    <br/>
    <b>Fatal error</b>: Uncaught Error: Call to a member function get_client() on null in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/OAuth2-master/inc/authentication/namespace.php:120
    Stack trace:
    #0 /opt/bitnami/apps/wordpress/htdocs/wp-includes/class-wp-hook.php(286): WP\OAuth2\Authentication\attempt_authentication(false)
    #1 /opt/bitnami/apps/wordpress/htdocs/wp-includes/plugin.php(203): WP_Hook->apply_filters(false, Array)
    #2 /opt/bitnami/apps/wordpress/htdocs/wp-includes/user.php(2603): apply_filters(‘determine_curre…’, false)
    #3 /opt/bitnami/apps/wordpress/htdocs/wp-includes/pluggable.php(69): _wp_get_current_user()
    #4 /opt/bitnami/apps/wordpress/htdocs/wp-includes/capabilities.php(613): wp_get_current_user()
    #5 /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/all-in-one-seo-pack/admin/display/menu.php(14): current_user_can(‘manage_options’)
    #6 /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/all-in-one-seo-pack/admin/display/menu.php(38): AIOSEOPAdminMenus->__construct()
    #7 /opt/bitnami/apps/wordpress/ht in
    <b>/opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/OAuth2-master/inc/authentication/namespace.php</b> on line
    <b>120</b>
    <br/>

    I’m sure it used to work, but it’s not working now. I searched for answers and I’m not the only one saying it doesn’t. It loads with several warning errors. I followed several threads of people with the same problems I was having and nothing worked. Seems it’s not working for a few people.

Viewing 3 replies - 1 through 3 (of 3 total)