Forum Replies Created

Viewing 15 replies - 1 through 15 (of 16 total)
  • longtailrider

    (@longtailrider)

    So, after some digging I applied the core patch on this page:
    http://core.trac.wordpress.org/ticket/14730

    Basically it adds a buffer flush before rendering the image. This fixed my issue allowing me to revert back to my original .htaccess configuration.

    This is on a Media Temple DV that is being hammered on pretty heavily.

    Hope this helps someone.

    longtailrider

    (@longtailrider)

    I just upgraded to 3.1 and this broke all my attached files in a fashion similar to @makapu.

    The .htaccess workaround from @makapu works, but I’d like to find what is wrong/misconfigured because everything was fine before the upgrade. I’ve changed several AllowOverride’s to All and made some other permission changes to try to get things working as they were before with much fail. I’ve also deactivated plugins and switched to 2010 it’s no good. Taking a break now, but plan on checking out file ownership next.

    I also don’t like the 404 on ‘subscriber only content’. I did a work-around to get a login form on the 404 page.

    It’s a little silly but seems to work.

    Open up /plugins/tantan-flickr/flickr/class-admin.php

    line 16&17 should look like this:

    add_action('activate_tantan-flickr/flickr.php', array(&$this, 'activate'));
     add_action('deactivate_tantan-flickr/flickr.php', array(&$this, 'deactivate'));

    Change it to this:

    register_activation_hook(__FILE__, array(&$this, 'activate'));
    register_deactivation_hook(__FILE__, array(&$this, 'deactivate'));

    Hope this helps.

    Thread Starter longtailrider

    (@longtailrider)

    Should have done that before posting. *d’oh!*

    twentyten works like a champ. I guess I will have to dig deeper into this vendor’s theme 🙁

    Thanks for pointing me in the right direction Andrea!! You seem to be all places at once. Amazing!

    There’s a fix over on flickr.

    FILE: tantan-flickr/flickr/class-admin.php

    Change add_action to register_activation_hook function as follows.

    add_action('admin_menu', array(&$this, 'addhooks'));
    //add_action('activate_tantan-flickr/flickr.php', array(&$this, 'activate'));
    register_activation_hook(__FILE__, array(&$this, 'activate'));
    //add_action('deactivate_tantan-flickr/flickr.php', array(&$this, 'deactivate'));
    register_deactivation_hook(__FILE__, array(&$this, 'deactivate'));
    add_action('load-upload.php', array(&$this, 'addPhotosTab'));
    Thread Starter longtailrider

    (@longtailrider)

    Sorry I was not more specific before.
    In my case the pagination on the search results page adds the extra ‘/myblog/’ to the link.

    Thread Starter longtailrider

    (@longtailrider)

    3.0.3

    same problem here

    Same issue pulling audio:

    $audios =& get_children( 'post_type=attachment&post_mime_type=audio/mpeg&post_parent=null' );

    Works, but

    $audios =& get_children( 'post_type=attachment&post_mime_type=audio/mpeg&post_parent=null&post_status=publish');

    returns nothing 🙁

    For the record- I just reset my test environment and tried David’s fix and it seems to have worked as well. It also seems like the ‘right’ way to fix it 😉

    Thanks David and Andrea!

    @dsader – That is so much more elegant the my brute-force php database update.

    $new_value = 'a:5:{s:13:"administrator";a:2:{s:4:"name";s:13:"Administrator";s:12:"capabilities";a:56:{s:13:"switch_themes";b:1;s:11:"edit_themes";b:1;s:16:"activate_plugins";b:1;s:12:"edit_plugins";b:1;s:10:"edit_users";b:1;s:10:"edit_files";b:1;s:14:"manage_options";b:1;s:17:"moderate_comments";b:1;s:17:"manage_categories";b:1;s:12:"manage_links";b:1;s:12:"upload_files";b:1;s:6:"import";b:1;s:10:"edit_posts";b:1;s:17:"edit_others_posts";b:1;s:20:"edit_published_posts";b:1;s:13:"publish_posts";b:1;s:10:"edit_pages";b:1;s:4:"read";b:1;s:8:"level_10";b:1;s:7:"level_9";b:1;s:7:"level_8";b:1;s:7:"level_7";b:1;s:7:"level_6";b:1;s:7:"level_5";b:1;s:7:"level_4";b:1;s:7:"level_3";b:1;s:7:"level_2";b:1;s:7:"level_1";b:1;s:7:"level_0";b:1;s:17:"edit_others_pages";b:1;s:20:"edit_published_pages";b:1;s:13:"publish_pages";b:1;s:12:"delete_pages";b:1;s:19:"delete_others_pages";b:1;s:22:"delete_published_pages";b:1;s:12:"delete_posts";b:1;s:19:"delete_others_posts";b:1;s:22:"delete_published_posts";b:1;s:20:"delete_private_posts";b:1;s:18:"edit_private_posts";b:1;s:18:"read_private_posts";b:1;s:20:"delete_private_pages";b:1;s:18:"edit_private_pages";b:1;s:18:"read_private_pages";b:1;s:12:"delete_users";b:1;s:12:"create_users";b:1;s:14:"edit_dashboard";b:1;s:15:"unfiltered_html";b:1;s:11:"update_core";b:1;s:10:"list_users";b:1;s:12:"remove_users";b:1;s:9:"add_users";b:1;s:13:"promote_users";b:1;s:18:"edit_theme_options";b:1;s:13:"delete_themes";b:1;s:6:"export";b:1;}}s:6:"editor";a:2:{s:4:"name";s:6:"Editor";s:12:"capabilities";a:34:{s:17:"moderate_comments";b:1;s:17:"manage_categories";b:1;s:12:"manage_links";b:1;s:12:"upload_files";b:1;s:10:"edit_posts";b:1;s:17:"edit_others_posts";b:1;s:20:"edit_published_posts";b:1;s:13:"publish_posts";b:1;s:10:"edit_pages";b:1;s:4:"read";b:1;s:7:"level_7";b:1;s:7:"level_6";b:1;s:7:"level_5";b:1;s:7:"level_4";b:1;s:7:"level_3";b:1;s:7:"level_2";b:1;s:7:"level_1";b:1;s:7:"level_0";b:1;s:17:"edit_others_pages";b:1;s:20:"edit_published_pages";b:1;s:13:"publish_pages";b:1;s:12:"delete_pages";b:1;s:19:"delete_others_pages";b:1;s:22:"delete_published_pages";b:1;s:12:"delete_posts";b:1;s:19:"delete_others_posts";b:1;s:22:"delete_published_posts";b:1;s:20:"delete_private_posts";b:1;s:18:"edit_private_posts";b:1;s:18:"read_private_posts";b:1;s:20:"delete_private_pages";b:1;s:18:"edit_private_pages";b:1;s:18:"read_private_pages";b:1;s:15:"unfiltered_html";b:1;}}s:6:"author";a:2:{s:4:"name";s:6:"Author";s:12:"capabilities";a:10:{s:12:"upload_files";b:1;s:10:"edit_posts";b:1;s:20:"edit_published_posts";b:1;s:13:"publish_posts";b:1;s:4:"read";b:1;s:7:"level_2";b:1;s:7:"level_1";b:1;s:7:"level_0";b:1;s:12:"delete_posts";b:1;s:22:"delete_published_posts";b:1;}}s:11:"contributor";a:2:{s:4:"name";s:11:"Contributor";s:12:"capabilities";a:5:{s:10:"edit_posts";b:1;s:4:"read";b:1;s:7:"level_1";b:1;s:7:"level_0";b:1;s:12:"delete_posts";b:1;}}s:10:"subscriber";a:2:{s:4:"name";s:10:"Subscriber";s:12:"capabilities";a:2:{s:4:"read";b:1;s:7:"level_0";b:1;}}}';
    
    for ($i=1;$i<195;$i++) {
    	$query = "SELECT option_name FROM WORDPRESSDATABASE.wp_".$i."_options
    	WHERE EXISTS (SELECT * FROM WORDPRESSDATABASE.wp_".$i."_options WHERE option_name = 'wp_".$i."_user_roles')
    	AND option_name = 'wp_".$i."_user_roles';";
    	$result = mysql_query($query);
    	echo $i.': ';
    	if ($result) {
    		while ($row = mysql_fetch_assoc($result)) {
    			$query2 = "UPDATE WORDPRESSDATABASE.wp_".$i."_options SET option_value= '".$new_value."' WHERE option_name = '".$row['option_name']."'";
    			$result2 = mysql_query($query2);
    			if (!$result2) {
    			    echo 'Invalid query: ' . mysql_error() . "\n";
    			    //echo 'Whole query: ' . $query;
    			}
    			echo $row['option_name'];
    		}
    	} else {
    		echo "<font color=red>WORDPRESSDATABASE.wp_".$i."_options does not exist</font>";
    	}
    	echo ' <br />';
    }
    mysql_close($link);

    I have another fresh 3.0.1 install that does not have this issue as well. Maybe related to the upgrade path?

    I’ve found that wp_###_user_roles tuples in the wp_###_options tables are also missing some permission directives. Newly created sites have 56 while all site created pre-upgrade have 49

    a:5:{
    s:13:"administrator";a:2:{
    s:4:"name";
    s:13:"Administrator";
    s:12:"capabilities";
    a:49:{
    	s:13:"switch_themes";b:1;
    	s:11:"edit_themes";b:1;
    	s:16:"activate_plugins";b:1;
    	s:12:"edit_plugins";b:1;
    	s:10:"edit_users";b:1;
    	s:10:"edit_files";b:1;
    	s:14:"manage_options";b:1;
    	s:17:"moderate_comments";b:1;
    	s:17:"manage_categories";b:1;
    	s:12:"manage_links";b:1;
    	s:12:"upload_files";b:1;
    	s:6:"import";b:1;
    	s:10:"edit_posts";b:1;
    	s:17:"edit_others_posts";b:1;
    	s:20:"edit_published_posts";b:1;
    	s:13:"publish_posts";b:1;
    	s:10:"edit_pages";b:1;
    	s:4:"read";b:1;
    	s:8:"level_10";b:1;
    	s:7:"level_9";b:1;
    	s:7:"level_8";b:1;
    	s:7:"level_7";b:1;
    	s:7:"level_6";b:1;
    	s:7:"level_5";b:1;
    	s:7:"level_4";b:1;
    	s:7:"level_3";b:1;
    	s:7:"level_2";b:1;
    	s:7:"level_1";b:1;
    	s:7:"level_0";b:1;
    	s:17:"edit_others_pages";b:1;
    	s:20:"edit_published_pages";b:1;
    	s:13:"publish_pages";b:1;
    	s:12:"delete_pages";b:1;
    	s:19:"delete_others_pages";b:1;
    	s:22:"delete_published_pages";b:1;
    	s:12:"delete_posts";b:1;
    	s:19:"delete_others_posts";b:1;
    	s:22:"delete_published_posts";b:1;
    	s:20:"delete_private_posts";b:1;
    	s:18:"edit_private_posts";b:1;
    	s:18:"read_private_posts";b:1;
    	s:20:"delete_private_pages";b:1;
    	s:18:"edit_private_pages";b:1;
    	s:18:"read_private_pages";b:1;
    	s:12:"delete_users";b:1;
    	s:12:"create_users";b:1;
    	s:14:"edit_dashboard";b:1;
    	s:13:"manage_cforms";b:1;
    	s:12:"track_cforms";b:1;}
    }
    s:6:"editor";a:2:{
    s:4:"name";
    s:6:"Editor";
    s:12:"capabilities";
    a:33:{
    	s:17:"moderate_comments";b:1;
    	s:17:"manage_categories";b:1;
    	s:12:"manage_links";b:1;
    	s:12:"upload_files";b:1;
    ....

    Looks like I’ll end up doing what @sam_h1 did and copy wp_###_user_roles to all the old wp_###_options tables.

    Also, here’s a link to the thread he started on
    wptavern.

    @andrea_r I’ve tried activating twentyten but the widgets menu is still missing. I have not tried plugin deactivation yet but plan to on Monday when our serverhuggers can copy our VM somewhere.

Viewing 15 replies - 1 through 15 (of 16 total)