Title: lmacke's Replies | WordPress.org

---

# lmacke

  [  ](https://wordpress.org/support/users/lmacke/)

 *   [Profile](https://wordpress.org/support/users/lmacke/)
 *   [Topics Started](https://wordpress.org/support/users/lmacke/topics/)
 *   [Replies Created](https://wordpress.org/support/users/lmacke/replies/)
 *   [Reviews Written](https://wordpress.org/support/users/lmacke/reviews/)
 *   [Topics Replied To](https://wordpress.org/support/users/lmacke/replied-to/)
 *   [Engagements](https://wordpress.org/support/users/lmacke/engagements/)
 *   [Favorites](https://wordpress.org/support/users/lmacke/favorites/)

 Search replies:

## Forum Replies Created

Viewing 11 replies - 1 through 11 (of 11 total)

 *   Forum: [Plugins](https://wordpress.org/support/forum/plugins-and-hacks/)
    In
   reply to: [[Trackserver] Split and upload tracks](https://wordpress.org/support/topic/split-and-upload-tracks/)
 *  Thread Starter [lmacke](https://wordpress.org/support/users/lmacke/)
 * (@lmacke)
 * [1 year, 11 months ago](https://wordpress.org/support/topic/split-and-upload-tracks/#post-18091429)
 * Hi Martijn,
 * I just tried it. “Split track” works again.
 * Thank you for your help and your time.
   I mark the post as solved.Have a nice 
   week and best regardsLeo
 *   Forum: [Plugins](https://wordpress.org/support/forum/plugins-and-hacks/)
    In
   reply to: [[Trackserver] Split and upload tracks](https://wordpress.org/support/topic/split-and-upload-tracks/)
 *  Thread Starter [lmacke](https://wordpress.org/support/users/lmacke/)
 * (@lmacke)
 * [1 year, 11 months ago](https://wordpress.org/support/topic/split-and-upload-tracks/#post-18085298)
 * _This is an interesting error, as the code where it occurs hasn’t changed in 
   more than 5 years. Does this error occur every time you try to split a track?
   Does it occur for all tracks, or just specific ones?_
 * Yes, the error occurs every time and it occurs for all tracks.
 * _Do I understand it correctly that splitting tracks has never worked for you?
   I never tested Trackserver on MySQL 8. I’ll see if I can try to reproduce it._
 * On March 2023 i changed from Ubuntu 18.04 LTS to 22.04 LTS with a complete new
   installation. The data, including the data for track server, came from a backup.
 * Before that, Split Track definitely worked. But I’m not sure if it still worked
   with the default version of PHP (8.1) on Ubuntu 22 and only stopped running after
   the update to PHP 8.3, or if it depends on the cange from mysql 5 to 8.
 * Kind regards
 * Leo
 *   Forum: [Plugins](https://wordpress.org/support/forum/plugins-and-hacks/)
    In
   reply to: [[Trackserver] Split and upload tracks](https://wordpress.org/support/topic/split-and-upload-tracks/)
 *  Thread Starter [lmacke](https://wordpress.org/support/users/lmacke/)
 * (@lmacke)
 * [1 year, 11 months ago](https://wordpress.org/support/topic/split-and-upload-tracks/#post-18085227)
 * The second query produces an error:
 * mysql> SELECT c.* FROM ( SELECT [@row](https://wordpress.org/support/users/row/):
   = [@row](https://wordpress.org/support/users/row/) + 1 AS row, l.id FROM wp_ts_locations
   l CROSS JOIN (select [@row](https://wordpress.org/support/users/row/) := -1) 
   r WHERE l.trip_id=1199 ORDER BY occurred ) c WHERE c.row IN (1,2,3,4,5);
   ERROR
   1064 (42000): You have an error in your SQL syntax; check the manual that corresponds
   to your MySQL server version for the right syntax to use near ‘row, l.id FROM
   wp_ts_locations l CROSS JOIN (select [@row](https://wordpress.org/support/users/row/):
   = -1) r WHERE l.trip_i’ at line 1mysql>
 *   Forum: [Plugins](https://wordpress.org/support/forum/plugins-and-hacks/)
    In
   reply to: [[Trackserver] Split and upload tracks](https://wordpress.org/support/topic/split-and-upload-tracks/)
 *  Thread Starter [lmacke](https://wordpress.org/support/users/lmacke/)
 * (@lmacke)
 * [1 year, 11 months ago](https://wordpress.org/support/topic/split-and-upload-tracks/#post-18085214)
 * The first one:
 * SELECT t.id, t.name, t.source, t.comment, user_id, COALESCE(MIN(l.occurred), 
   t.created) AS tstart, COALESCE(MAX(l.occurred), t.created) AS tend, COALESCE(
   COUNT(l.occurred), 0) AS numpoints, t.distance FROM wp_ts_tracks t LEFT JOIN 
   wp_ts_locations l ON l.trip_id = t.id WHERE 1 GROUP BY t.id ORDER BY tstart DESC
   LIMIT 0,50
 * works fine. The sort order can be changed by ORDER BY tstart
 *   Forum: [Plugins](https://wordpress.org/support/forum/plugins-and-hacks/)
    In
   reply to: [[Trackserver] Split and upload tracks](https://wordpress.org/support/topic/split-and-upload-tracks/)
 *  Thread Starter [lmacke](https://wordpress.org/support/users/lmacke/)
 * (@lmacke)
 * [1 year, 11 months ago](https://wordpress.org/support/topic/split-and-upload-tracks/#post-18085210)
 * Hi Martijn,
 * i’m sorry for wasting your time. I oriented myself on the daily numbers and disregarded
   the month. No tracks disappear. I’m going to try my hand at the sql commands 
   now. Unfortunately, I can’t do php, I come from a time when BASIC and Pascal 
   were spoken 😉
 * Leo
 *   Forum: [Plugins](https://wordpress.org/support/forum/plugins-and-hacks/)
    In
   reply to: [[Trackserver] Split and upload tracks](https://wordpress.org/support/topic/split-and-upload-tracks/)
 *  Thread Starter [lmacke](https://wordpress.org/support/users/lmacke/)
 * (@lmacke)
 * [1 year, 11 months ago](https://wordpress.org/support/topic/split-and-upload-tracks/#post-18079968)
 * Regarding “missing tracks”: The start date ist the same. Because i downloaded
   the track and uploaded it again for this test.
 * Regarding “split track”: I found this error in …apache2/error.log
 * [Thu Oct 17 19:42:34.116873 2024] [php:notice] [pid 131719] [client 188.193.xxx.
   xxx:37402] WordPress database error You have an error in your SQL syntax; check
   the manual that corresponds to your MySQL server version for the right syntax
   to use near ‘row, l.id FROM wp_ts_locations l CROSS JOIN (select [@row](https://wordpress.org/support/users/row/):
   = -1) r WHERE l.trip_i’ at line 1 for query SELECT c.* FROM (SELECT [@row](https://wordpress.org/support/users/row/):
   = [@row](https://wordpress.org/support/users/row/) + 1 AS row, l.id FROM wp_ts_locations
   l CROSS JOIN (select [@row](https://wordpress.org/support/users/row/) := -1) 
   r WHERE l.trip_id=1211 ORDER BY occurred) c WHERE c.row IN (’74’) made by do_action(‘
   admin_post_trackserver_save_track’), WP_Hook->do_action, WP_Hook->apply_filters,
   Trackserver_Admin->admin_post_save_track, Trackserver_Admin->wpdb_split_track,
   Trackserver->get_location_ids_by_index, referer: [https://xxx.xxx.de/wp-admin/admin.php?page=trackserver-tracks&orderby=id&order=desc](https://xxx.xxx.de/wp-admin/admin.php?page=trackserver-tracks&orderby=id&order=desc)
 * Mysql version is: mysql Ver 8.0.39-0ubuntu0.22.04.1 for Linux on x86_64 ((Ubuntu))
    -  This reply was modified 1 year, 11 months ago by [lmacke](https://wordpress.org/support/users/lmacke/).
 *   Forum: [Plugins](https://wordpress.org/support/forum/plugins-and-hacks/)
    In
   reply to: [[Trackserver] Split and upload tracks](https://wordpress.org/support/topic/split-and-upload-tracks/)
 *  Thread Starter [lmacke](https://wordpress.org/support/users/lmacke/)
 * (@lmacke)
 * [1 year, 11 months ago](https://wordpress.org/support/topic/split-and-upload-tracks/#post-18076916)
 * Hi,
 * maybe it’s easier to show some screenshots:
 * ![](https://i0.wp.com/macke.spdns.de/wp-content/uploads/2024/10/Bild-1a.png?ssl
   =1)
 * The track with the ID 1199 seems to be the last one uploaded or created by Trackme.
 * I upload 2 gpx files (wich i downloaded before, but same behavior withnew tracks).
 * ![](https://i0.wp.com/macke.spdns.de/wp-content/uploads/2024/10/Bild-2.png?ssl
   =1)
 * Upload seems to be ok, but they are not in the filelist
 * ![](https://i0.wp.com/macke.spdns.de/wp-content/uploads/2024/10/Bild-3.png?ssl
   =1)
 * After that i made a new blog entry and incremented the ID by myself (here 2008,
   because i tried several times)
 * ![](https://i0.wp.com/macke.spdns.de/wp-content/uploads/2024/10/Bild-5.png?ssl
   =1)
 * after that i can see the right track in the preview (and also in my blog)
 * ![](https://i0.wp.com/macke.spdns.de/wp-content/uploads/2024/10/Bild-6.png?ssl
   =1)
 * When i sort all the tracks by numer (twice)…
 * ![](https://i0.wp.com/macke.spdns.de/wp-content/uploads/2024/10/Bild-7.png?ssl
   =1)
 * …the missing tracks are there. But when leaving “Manage tracks” and enter again
   they dissapear again. At first i thought, it depends on the missing “Source”.
   But as i tried that is not the reason. This workaround (sorting twice) is ok 
   for me but was a bit difficult to find 😉
 * My very first Question was this: I can not split tracks anymore. In earlier versions
   of trackserver i choosed split track and after that i had the original ID with
   one part of the track and the another part with a new id.
 * ![](https://i0.wp.com/macke.spdns.de/wp-content/uploads/2024/10/Bild-10.png?ssl
   =1)
 * Today nothing happens. The original track keeps its numer of points and no new
   track is generated. This is not an important thing for me, but some days i forget
   to stop tracking when i enter my car and then i get very long tracks with a high
   average speed 😉
 * I thank you verry much for your help and for the famous addon.
 * Leo
    -  This reply was modified 1 year, 11 months ago by [lmacke](https://wordpress.org/support/users/lmacke/).
    -  This reply was modified 1 year, 11 months ago by [lmacke](https://wordpress.org/support/users/lmacke/).
    -  This reply was modified 1 year, 11 months ago by [lmacke](https://wordpress.org/support/users/lmacke/).
 *   Forum: [Plugins](https://wordpress.org/support/forum/plugins-and-hacks/)
    In
   reply to: [[Trackserver] How to create Live Tracking Map](https://wordpress.org/support/topic/how-to-create-live-tracking-map/)
 *  [lmacke](https://wordpress.org/support/users/lmacke/)
 * (@lmacke)
 * [4 years, 2 months ago](https://wordpress.org/support/topic/how-to-create-live-tracking-map/#post-15876020)
 * Hi branx,
    i don’t know anything about sendlocation, because i’m using trackme.
 * But this is the code on a wordpress page i’m using for live tracking:
 * [tsmap user=knut maxage=2h infobar=true color=green markers=true zoom=15 ]
 * Kind regards
 * Leo
 *   Forum: [Plugins](https://wordpress.org/support/forum/plugins-and-hacks/)
    In
   reply to: [[WP 3D Thingviewer Lite] Complete Crash of WordPress and my Server](https://wordpress.org/support/topic/complete-crash-of-wordpress-and-my-server/)
 *  Thread Starter [lmacke](https://wordpress.org/support/users/lmacke/)
 * (@lmacke)
 * [4 years, 2 months ago](https://wordpress.org/support/topic/complete-crash-of-wordpress-and-my-server/#post-15874401)
 * Hallo Moritz,
    ich habe das ausprobiert. Läuft! Danke. Ich bin dabei über den
   3D-Viewer gestolpert. Der benötigt allerdings glb-Dateien, kann dafür aber auch
   Texturen darstellen. Die stl-Dateien habe ich mit Metashape konvertiert. Das 
   ging meistens problemlos.
 * Gruß Leo
 *   Forum: [Plugins](https://wordpress.org/support/forum/plugins-and-hacks/)
    In
   reply to: [[Trackserver] Error updating position](https://wordpress.org/support/topic/error-updating-position/)
 *  [lmacke](https://wordpress.org/support/users/lmacke/)
 * (@lmacke)
 * [7 years, 2 months ago](https://wordpress.org/support/topic/error-updating-position/#post-11768177)
 * Hi Michael,
    i’m using TrackMe with WordPress too. Livetracking works fine. I’m
   getting the same Error “Error updating position (cloud sharing is not supported
   by the server)” when i try to start tracking using the cloud symbol at the bottom
   of the screen. Did you try the red circle at the top of the screen to start tracking?
 * Kind regards
 * Leo
 *   Forum: [Plugins](https://wordpress.org/support/forum/plugins-and-hacks/)
    In
   reply to: [[Trackserver] Changing from http:// to https://](https://wordpress.org/support/topic/changing-from-http-to-https-4/)
 *  Thread Starter [lmacke](https://wordpress.org/support/users/lmacke/)
 * (@lmacke)
 * [8 years, 4 months ago](https://wordpress.org/support/topic/changing-from-http-to-https-4/#post-10381563)
 * Hello Martijn,
    i’m sorry. I didn’t look at the bottom of the settings page. 
   Thanks for your help. Everything works fine now.
 * Kind regards
 * Leo

Viewing 11 replies - 1 through 11 (of 11 total)