Forum Replies Created

Viewing 15 replies - 1 through 15 (of 16 total)
  • Thread Starter josenovo

    (@josenovo)

    Ahi encontre la modificación que dices, te pido disculpas, tenes razon.

    En el repositorio de wordpress figura sin modificación. Ahora funciona bien sin ningun erro.

    PD: El plugin es muy bueno, si fuera otro plugin que es casin inservible ni me molestaba en escribir, pero este la verdad funciona bien y tiene una dinamica correcta.

    Thread Starter josenovo

    (@josenovo)

    Tampoco encontre ninguna modificacion en la version que se encuentra en la tienda. Es un plugin que viene fallando hace bastante y en el momento que me dijo que lo pruebe nuevamente funciona, a algun lado se esta conectando, ¿como soluciono el problema?

    Thread Starter josenovo

    (@josenovo)

    Entonces ¿como hizo para solucionar el problema con el plugin?, porque no se subio ninguna versión nueva

    Thread Starter josenovo

    (@josenovo)

    Hola, ahora no genera error 404, no pone lenta la web, pero revise todo el plugin y no le realizaste ningún cambio, por ende, el error esta en que el plugin se esta comunicando po API o por otro sistema a un servidor externo ¿me equivoco?, en caso que me equivoque, le pido por favor me indique como soluciono el problema sin haber modificado el plugin.

    En caso que este plugin se este comunicando a otro servidor por API o por otro sistema, quisiera saber el porque realiza esa acción, primero porque no esta indicado en la descripcion del plugin y segundo porque no tiene motivo por el cual se deba comunicar con servidor externo un plugin que realiza una tarea sencilla.

    Aguardo comentarios

    Thread Starter josenovo

    (@josenovo)

    TOP 10 tiene una opcion para cache, el otro no, pero ambos dejan de funcionar cuando activo el cache, esto no me ocurre con otros plugin de cache

    Forum: Plugins
    In reply to: [Yoast SEO] Error 500
    Thread Starter josenovo

    (@josenovo)

    Gracias por el soporte, finalmente lo que me funciono es colocar 50 url en varias hojas, de esa forma no me devuelve error 500.

    function max_entries_per_sitemap() {
    return 50;
    }
    add_filter( ‘wpseo_sitemap_entries_per_page’, ‘max_entries_per_sitemap’ );

    Seguramente mi configuración de ini.php corta la carga de la hoja por tener mas de 514 url y tarda en cargar, ahí es donde devuelve el error 500.

    Al tener que cargar solo 50 url en varias paginas, la pagina carga rapido y no devuelve el error 500.

    Algo para probar en laboratorio:

    Copie el codigo del sitemap cuando tenia mas de 514 url por hoja y lo coloque en un archivo .xml, lo subi al servidor y me cargo inmediatamente sin errores.

    Me párese que cuando alguien ingresa al sitemap, Yoast SEO analiza el mismo para actualizarlo o algo hace y eso genera que tarde en cargar y devuelve el error 500 para algunos usuarios.

    Recomiendo que se analice eso, porque yo me di cuanta cuando ingrese al sitemap para revisarlo, si no hubiera hecho eso, esas url no se indexarian nunca.

    Yoast SEO no deberia demorar la carga del sitemap ya que los bot reportarían problemas en las URL (ya me habia pasado antes), tambien estaría bueno tener esta opción de elegir la cantidad de url por pagina desde el admin, yo prefiero cargar menos url por pagina para que cargue mejor y que demoren menos los bot.

    Nuevamente gracias

    Thanks for the support, finally what worked for me is to place 50 urls in several sheets, that way it doesn’t give me the 500 error.

    function max_entries_per_sitemap() {
    return 50;
    }
    add_filter(‘wpseo_sitemap_entries_per_page’, ‘max_entries_per_sitemap’);

    Surely my ini.php configuration cuts the loading of the sheet because it has more than 514 urls and it takes time to load, that’s where it returns the 500 error.

    By having to load only 50 urls in several pages, the page loads fast and does not return the 500 error.

    Something to test in the lab:

    Copy the code from the sitemap when I have more than 514 urls per page and put it in an .xml file, upload it to the server and it loads immediately without errors.

    It seems to me that when someone enters the sitemap, Yoast SEO analyzes it to update it or something does and that causes a delay in loading and returns the 500 error for some users.

    I recommend analyzing that, because I realized when I entered the sitemap to review it, if I hadn’t done that, those urls would never be indexed.

    Yoast SEO should not delay the loading of the sitemap since the bots would report problems in the URL (it had happened to me before), it would also be good to have this option to choose the amount of url per page from the admin, I prefer to load less url per page so that it loads better and that the bots take less time.

    Thank you again

    Thread Starter josenovo

    (@josenovo)

    o con el tema del reproductor colocarle un logo

    Thread Starter josenovo

    (@josenovo)

    Thanks for the answer but it still doesn’t work (perform all the steps). The only time that works well is when I deactivate the minification of the JS and HTML processes, which I cannot leave them deactivated because it makes the page slow.

    Gracias por la respuesta pero sigue sin funcionar (realice todos los pasos). En el unico momento que funciona bien es cuando desactivo la minificacion del JS y procesos HTML, los cuales no los puedo dejar desactivados porque me vuelve lenta la pagina.

    Thread Starter josenovo

    (@josenovo)

    Decidí cambiar el codigo para que lo entregue de la misma forma que lo entrega el resto de la web, lo curioso es que aparece como jpg, pero al descargarlo baja webp. Pero supuestamente funciona.

    <?php if(has_post_thumbnail($id)){?>
    <div class=”picture”>
    <?php loop_item_thumbnail($id, $post_format, $img_size, $post_data,);?>
    </div> <?php }?>

    Thread Starter josenovo

    (@josenovo)

    Hola, por supuesto que te colocare 5 estrellas, porque tu plugin funciona muy bien y esta diseñado perfectamente.

    Si en algun momento creas un plugin con la misma funcion para colocar en el post avisame por favor o si se te ocurre como podria adaptar este para que genere esa funcion, tambien te lo agradeceria.

    Saludos!!!!!

    Thread Starter josenovo

    (@josenovo)

    Una aclaracion por si sirve en el futuro para otros usuarios, en mi web hay mas de 2000 post. Cuando son menos, de 500 post, memory_limit a 100M funcionaba bien, pero a medida que comienzan a incrementarse la catidad de post memory_limit lo debo subir, para evitar el error critico al tratar de ingresar al mapa del post. No se si existe otra forma de solucionarlo.

    Thread Starter josenovo

    (@josenovo)

    Gracias por la respuesta. Encontre la causa de los dos problemas despues que envie el mensaje.

    Primer error: Un espacio al comienzo del archivo fuction.php
    Segundo error (generaba error critico en los mapas de post), aumente el limite de memory_limit que se encontraba en 100m a 200m y eso lo soluciono.

    Saludos y gracias!!!!

    Thread Starter josenovo

    (@josenovo)

    simplemente al instalarlo tras 10 segundo, ghostery comienza a reportar el rastreo por google. Desinstale el plugun, arme yo los botones de compartir y ghostery no reporto rastreo.

    Thread Starter josenovo

    (@josenovo)

    No se como trabaja bien learndash porque incluí todos los .js y no funciona y por parte de ellos no tuve respuesta. Pero inclui como carga diferencial /wp-includes/js/jquery/jquery.min.js eso soluciono el problema, ahora LD funciona y no afecta el reendimiento. No sugiero colocarlo como excluido porque si se nota que anda lento.

    Talvez colocar una aclaración para los usuarios de LD que deban de colocar /wp-includes/js/jquery/jquery.min.js como aplazado seria suficiente.
    Porlomenos hasta que LD responda y aclare como funcionan sus .js

    Ahora voy a realizar otro hilo por otra web que tiene varias URL y me genera algunos problemas.

    I don't know how learndash works well because I included all the .js and it doesn't work and I had no response from them. But I included as differential load /wp-includes/js/jquery/jquery.min.js that solved the problem, now LD works and does not affect performance. I do not suggest placing it as excluded because if you notice that it is slow.
    
    Maybe putting a clarification for LD users who must put /wp-includes/js/jquery/jquery.min.js as deferred would be enough.
    At least until LD responds and clarifies how his .js work
    
    Now I am going to make another thread for another website that has several URLs and it generates some problems.
    
    Thanks for the help, regards

    Gracias por la ayuda, saludos

    Thread Starter josenovo

    (@josenovo)

    Si, pero ninguna respuesta. Por ese motivo agregue todos los js de LearnDash y ninguno funciono, solo funciono el de wordpress wordpress /wp-includes/js/jquery/jquery.min.js

    Igualmente tras varias pruebas con diversos scan de seo y rendimiento, todos me marcan que la web no esta totalmente optimizada, me da como resultado de archivos que bloquean
    /wp-content/cache/wpo-minify/1620422751/assets/wpo-minify-header- y similares (4 en total).
    He desactivado LearnDash y ocurre lo mismo.

    Yes, but no answer. For that reason I added all the LearnDash js and none worked, only the wordpress wordpress /wp-includes/js/jquery/jquery.min.js worked
    
    Likewise, after several tests with various seo and performance scans, they all tell me that the web is not fully optimized, it gives me as a result of files that block
    / wp-content / cache / wpo-minify / 1620422751 / assets / wpo-minify-header- and the like (4 in total).
    I have disabled LearnDash and the same thing happens.
Viewing 15 replies - 1 through 15 (of 16 total)