Forum Replies Created

Viewing 15 replies - 1 through 15 (of 29 total)
  • Michael,
    Anyone that works hard on something, then shares if for free, has my ultimate respect.
    I’m in no hurry. Hope you enjoy your leave.

    Anyone having issues with Notely (or any other plugin or snippet) and the newer versions of PHP throwing notices should just turn off debugging or at the very least quit displaying the errors. It should work fine (it’s only a notice not a fatal error).

    Hi everyone,

    I am also having
    [06-Jul-2018 00:59:59 UTC] PHP Notice: Undefined index: mo_notely_nounce in .../wp-content/plugins/notely/notely.php on line 79
    in my log files when someone proceeds passed my checkout page.

    From my research, this is caused by some changes in how PHP 7.1+ or somewhere around there decides to throw notices. I have recently upgraded to PHP 7.2 and am having quite a few plugins causing these notices in my log file somewhat seemingly random.

    First off, no one should be using define( ‘WP_DEBUG_DISPLAY’, true ); on a live site. This should only be used in the development stage. It can cause layout/flow issues and more importantly, serious security issues letting end users see your errors. The following can be used in the wp-config.php on a live site temporarily to log errors and warnings but the log file can grow quite large if left unattended:

    define( ‘WP_DEBUG’, true ); // turns on debuggin
    define( ‘WP_DEBUG_LOG’, true ); // will log any errors in debug.log in your wp-content folder.
    define( ‘WP_DEBUG_DISPLAY’, false ); // will not show errors on your site.

    Second, correct me if I am wrong, but PHP Notices are not that serious, just a note to pay attention, this could cause a problem down the road or maybe you are doing something unnecessary. Undefined index’s seem to be caused by null values trying to be passed. Another words, if there is no data for the notely meta being saved for that particular page being ran, then it throws a undefined index notice. Apparently this used to be no big deal before PHP 7 was introduced, but someone decided that a notice should be generated letting the developer know that they are trying to save empty data or something like that?

    Unfortunately, my scripting skills are very lacking, and google doesn’t seem to provide a lot of answers or examples how to correct this notice since PHP 7.1 + is fairly new. At least not in a way I can understand. That is why I am here, I am hoping that Michael Ott can find the answer and fix it. Then I can learn how to fix other plugins that are generating the same notices.

    Michael,

    I just want to give a big thanks for your time in developing, maintaining, and sharing this awesome little plugin. Simple, lightweight, and very useful on the back end of our product pages.

    Perhaps use PHP 7.2, go through a checkout page and cancel the order. Check logs, this notice should be there. Seems to be triggered when woocommerce tries to update the addresses from the checkout page.

    Notely 1.4
    Woo 1.3.6
    WP 4.9.6

    Hi there, I do believe that the color select only changes the color of the icon in admin columns. And that is only if you set the admin column notes to be hidden (that is when it displays the icon color of your choice). This is handy when the notes are really long and cause the admin rows to grow too tall. The notes can be hidden (icon only), then you can click the icon on a certain row to expand and see the whole note.

    Thread Starter joeistoybox

    (@joeistoybox)

    Excellent, I look forward to the upcoming patch.

    I followed Gary’s advice and links provided and came up with the following code to paste into my functions.php file. I commented out the email parts as I did not want it, I only wanted shipping phone number. So far works great.

    
    /* Add additional shipping fields (email, phone) in FRONT END (i.e. My Account and Order Checkout) */
    /* Note:  $fields keys (i.e. field names) must be in format: "shipping_" */
    add_filter( 'woocommerce_shipping_fields' , 'my_additional_shipping_fields' );
    function my_additional_shipping_fields( $fields ) {
     /*    $fields['shipping_email'] = array(
            'label'         => __( 'Ship Email', 'woocommerce' ),
            'required'      => false,
            'class'         => array( 'form-row-last' ),
            'validate'      => array( 'email' ),
        ); */
        $fields['shipping_phone'] = array(
            'label'         => __( 'Ship Phone', 'woocommerce' ),
            'required'      => false, /* change to true if needs to be required*/
    //        'class'         => array( 'form-row-first' ),  // This will split the area in two columns, works good if email is turned on but with just phone, layout screws up on some screens
            'clear'         => true,
            'validate'      => array( 'phone' ),
        );
        return $fields;
    }
    /* Display additional shipping fields (email, phone) in ADMIN area (i.e. Order display ) */
    /* Note:  $fields keys (i.e. field names) must be in format:  WITHOUT the "shipping_" prefix (it's added by the code) */
    add_filter( 'woocommerce_admin_shipping_fields' , 'my_additional_admin_shipping_fields' );
    function my_additional_admin_shipping_fields( $fields ) {
    /*         $fields['email'] = array(
                'label' => __( 'Order Ship Email', 'woocommerce' ),
            ); */
            $fields['phone'] = array(
                'label' => __( 'Order Ship Phone', 'woocommerce' ),
            );
            return $fields;
    }
    /* Display additional shipping fields (email, phone) in USER area (i.e. Admin User/Customer display ) */
    /* Note:  $fields keys (i.e. field names) must be in format: shipping_ */
    add_filter( 'woocommerce_customer_meta_fields' , 'my_additional_customer_meta_fields' );
    function my_additional_customer_meta_fields( $fields ) {
            $fields['shipping']['fields']['shipping_phone'] = array(
                'label' => __( 'Telephone', 'woocommerce' ),
                'description' => '',
            ); /*
            $fields['shipping']['fields']['shipping_email'] = array(
                'label' => __( 'Email', 'woocommerce' ),
                'description' => '',
            ); */
            return $fields; 
    }
    /* Add CSS for ADMIN area so that the additional shipping fields (email, phone) display on left and right side of edit shipping details */
    add_action('admin_head', 'my_custom_admin_css');
    function my_custom_admin_css() {
      echo '<style>
        #order_data .order_data_column ._shipping_phone_field {
            clear: left;
            float: left;
        }
         #order_data .order_data_column ._shipping_email_field {
            float: right;
        } 
      </style>';
    }
    /* END additional shipping fields (email, phone)  */
    Thread Starter joeistoybox

    (@joeistoybox)

    Hi Veeresh,

    I understand these things can happen. It’s just about impossible nowadays to write a completely bug free code for every possible user usage.

    Thank you for the lighten fast support. Amazing. I installed the update, and tested it. All works correctly now. Once again, wow, the Team XA’s level of support is fantastic, even for the free version.

    Have a wonderful day,
    Matthew

    I also am having a similar problem. I only have a little under 200 products so far and my product ids are in order starting at 100 to 291 at the moment. What is strange, the 200th product id would not export. I thought there might be something like a special character in the description so i copied the product and now it’s id is 4455 (since woocommerce assigned the id for me.) I deleted the old one with the 200 id. Now, the 4455 id product exports just fine, and the 200 id is still gone (as it should be now since it no longer exist), but wait, now product id 201 is missing from the export and it exported fine before deleting the 200 id. It should be on line 102 of the exported csv.

    My thought is, the plugin has a glitch between the 101 and 102 lines of the export. Perhaps this repeats every 100 lines, so people with more products end up missing one product per 100. I am about 6 items short of testing this theory, as my export has not reached 200 lines yet.

    Thread Starter joeistoybox

    (@joeistoybox)

    No, I gave up on it.

    Thread Starter joeistoybox

    (@joeistoybox)

    Hi Musilda,

    Thanks so much for your quick support.

    I just tried it again by changing a single product qty from 3 to 2 and hit save all. It spins for a few secs and refreshes page. When I scroll back to the line I changed, still shows 3. If I check the live product, it still shows 3. The only way it will change to 2 is if I hit the save button on the same line.

    I thought it might have to do with variations, but seems to not work for either.

    Update: I tried it with IE 11 and Chrome, no save all with either one. I tried changing other fields as well, but none save

    • This reply was modified 4 years, 1 month ago by joeistoybox. Reason: Update
    • This reply was modified 4 years, 1 month ago by joeistoybox. Reason: spelling error

    I too tried the plugin. Did not work for me the way I had hoped. So I deactivated it. Tried to delete it, but that failed. So I used an FTP client to delete the whole folder: wp-content/plugins/woocommerce-molds from my wordpress directory and that seemed to work. I no longer have it in my admin plugins page and no longer see it in the admin products tab. Maybe that can work for you too?

    I too tried the plugin. Did not work for me the way I had hoped. So I deactivated it. Tried to delete it, but that failed. So I used an FTP client to delete the whole folder: wp-content/plugins/woocommerce-molds from my wordpress directory and that seemed to work. I no longer have it in my admin plugins page and no longer see it in the admin products tab. Maybe that can work for you too?

    Has this been fixed, cause I am using latest version and am having same problem.

    Thread Starter joeistoybox

    (@joeistoybox)

    +1 @delicado on that solution.

    Thread Starter joeistoybox

    (@joeistoybox)

    That snippet worked beautifully. Thank you so much for the quick response and fix. I am not sure if most people would want it to display the per page or not for the All products choice. I could see the argument to leave it the long version as well. Maybe just include this snippet in the text file and FAQ section and remind them to paste it at the end of their theme / child theme functions.php file so that it won’t get overridden during an update.
    Whichever way you go, I am happy. Thanks a million.

    Bye the way, I love your other plugin: WP Dashboard Notes.

    You both are welcome. I am just glad to help. Thanks again @littlepackage for making this plugin free.

Viewing 15 replies - 1 through 15 (of 29 total)