Forum Replies Created

Viewing 15 replies - 1 through 15 (of 1,716 total)
  • Plugin Support Jesse Pearson

    (@jessepearson)

    Automattic Happiness Engineer

    @thiagoqf There may be an issue with another one of the plugins that is installed, or there could be a data or database issue somewhere. Tracking down the actual cause may take some time. The steps to take would be:

    • Create a copy of the site on the same server to test with. Deactivate all plugins but WooCommerce. Can you replicate the issue? I know you mentioned a moderate level of traffic causes it, but this is the best route.
    • Check to see if you have a large number of categories, tags, or product attributes. A large amount of taxonomies or terms can cause database slowdowns.
    • Can you copy the site to a local environment or another server to see if the issue persists?
    • More about conflict troubleshooting can be found here: https://docs.woocommerce.com/document/how-to-test-for-conflicts/

    Plugin Support Jesse Pearson

    (@jessepearson)

    Automattic Happiness Engineer

    @svlieger The theme itself would control how the site looks, including the text size of the widgets on mobile devices. We would suggest reaching out to the developer of the theme that you are using for assistance with getting the desired look you would like.

    Plugin Support Jesse Pearson

    (@jessepearson)

    Automattic Happiness Engineer

    @allegrojane That does seem to be troublesome. Typically you can go to the Screen Options tab at the top right and disable columns that are viewed in the admin tables. The columns should change in real time, so you should be able to determine which one it is as you disable them.

    Plugin Support Jesse Pearson

    (@jessepearson)

    Automattic Happiness Engineer

    @fgmwp If you have purchased Bookings and Product Add-Ons through WooCommerce.com, you can submit a request for support here: https://woocommerce.com/my-account/create-a-ticket/ . We are not able to support those extensions here due to they are premium products.

    I can say that Bookable products are not able to be included in Grouped products and vice versa.

    Plugin Support Jesse Pearson

    (@jessepearson)

    Automattic Happiness Engineer

    @crystalbasicsorg I took a look at your site, and I believe the best solution would be to add a link to the shop in the primary navigation a the top. Not only would this allow customers to go back to the shop from the checkout page, it would allow them to access the shop from all pages.

    Plugin Support Jesse Pearson

    (@jessepearson)

    Automattic Happiness Engineer

    @jpc2020 I am not seeing anything standing out in the System Status Report. Can you confirm if this is still an issue? When I go to the /services/ page that is set as the shop base, it seems to work, there are just no products listed.

    Also, by any chance, is there a directory/folder on the server named services? this could cause an issue because the redirects wouldn’t work if the directory was found.

    Plugin Support Jesse Pearson

    (@jessepearson)

    Automattic Happiness Engineer

    @ciberg It seems like this is an issue with the server being able to get the image for some reason. It may be timing out, or the url for the image is not accessible for some other reason? Are you able to ssh into the server to try to ping the url for the image to see if there’s a response? Maybe a small script on the server that tries to read the url could be another test.

    I just tested the API myself without any issues:


    Link to image: https://d.pr/i/QTQ6cZ

    This is my request:

    
    {
      "name": "API Test",
      "image": 
        {
          "src": "https://local.test/wp-content/uploads/2020/01/tron-2.jpg"
        }
    }
    

    Any my response:

    
    {
        "id": 298,
        "name": "API Test",
        "slug": "api-test",
        "parent": 0,
        "description": "",
        "display": "default",
        "image": {
            "id": 135486,
            "date_created": "2020-10-08T08:59:08",
            "date_created_gmt": "2020-10-08T11:59:08",
            "date_modified": "2020-10-08T08:59:08",
            "date_modified_gmt": "2020-10-08T11:59:08",
            "src": "https://local.test/wp-content/uploads/2020/10/tron-2-1.jpg",
            "name": "tron-2-1.jpg",
            "alt": ""
        },
        "menu_order": 0,
        "count": 0,
        "_links": {
            "self": [
                {
                    "href": "https://local.test/wp-json/wc/v3/products/categories/298"
                }
            ],
            "collection": [
                {
                    "href": "https://local.test/wp-json/wc/v3/products/categories"
                }
            ]
        }
    }
    

    And the category in the admin:


    Link to image: https://d.pr/i/8mijqm

    Plugin Support Jesse Pearson

    (@jessepearson)

    Automattic Happiness Engineer

    @hosseinshe You may want to try to disable image regeneration in WooCommerce to see if that corrects the issue. This can be done by adding this snippet to your theme’s functions.php file or with a plugin like Code Snippets:

    https://gist.github.com/lukecav/904cc76e5ce89e9d62fcf6ec22f44495

    If this does solve the issue, then you will need a different plugin to regenerate thumbnails like: https://wordpress.org/plugins/regenerate-thumbnails/

    Plugin Support Jesse Pearson

    (@jessepearson)

    Automattic Happiness Engineer

    @jmccrone I just double checked and if I view a parent category, the sub-category’s products are then displayed under it. The next steps here would be:

    – Go to WooCommerce > Status > Tools, and then use the Recount Terms tool to see if that corrects the issue.
    – Switch to either Twenty Twenty or Storefront to see if the issue remains with one of these two themes.
    – If neither of those work, then full conflict troubleshooting is recommended: https://docs.woocommerce.com/document/how-to-test-for-conflicts/

    If you’re unable to do some of these tests on your live site and do not have a staging option at your host, please try the WP Staging plugin to create a copy to test with: https://wordpress.org/plugins/wp-staging/

    Plugin Support Jesse Pearson

    (@jessepearson)

    Automattic Happiness Engineer

    @adscouk You stated the error is happening when trying to check out with a bundle or composite in the cart, are you using the extensions sold at WooCommerce.com, or an extension from elsewhere? If the purchases were made through WooCommerce.com, you can submit a ticket through your account there in order to get the developers to take a look.

    If the extension is not from WooCommerce.com, it’s likely there are template modifications done in the extension that’s causing the error you’re seeing. If you check out with just a simple product in the cart, does the same issue happen? If not, then we would suggest reaching out to the developer of the extension you’re using for further assistance.

    Plugin Support Jesse Pearson

    (@jessepearson)

    Automattic Happiness Engineer

    @jpc2020 If I am reading this correctly, you are seeing products in the admin, but when you try to view them on the front end you get a 404 error? If so, can you go to Settings > Permalinks and save that page. Once that’s done, does that fix the error?

    If not, would you mind going to WooCommerce > Status, then using the button near the top left to copy the System Status Report then paste it here for us?

    Plugin Support Jesse Pearson

    (@jessepearson)

    Automattic Happiness Engineer

    @logicrays I am not sure what you mean by clicking preview order in the admin side. Would you be able to take a screenshot of what you’re referring to?

    If you are referring to when you’re creating an order in the admin, then the address will only be populated if the customer has that information under their user account/profile in WordPress.

    Plugin Support Jesse Pearson

    (@jessepearson)

    Automattic Happiness Engineer

    @massimilianofrm From what I can see, the prices are in the cart, however, the background and text are both white, making it so the text cannot be read:


    Link to image: https://d.pr/i/RvPZEz

    There may be settings in the theme to modify the background or text color, which would need to be done in order to get this working correctly. If you run into issues with the theme, please reach out to the theme developer for assistance.

    Plugin Support Jesse Pearson

    (@jessepearson)

    Automattic Happiness Engineer

    @coach-henk This sounds like it may be an issue with the payment gateway itself not sending the proper amounts to the provider. Are you seeing the shipping costs in the order in the admin? If so, then the costs are being passed to the order and the gateway is just not sending them.

    If you enable the Check payment method and place an order, do the shipping costs make it to the order? If not, can you add a Flat Rate shipping method to your zone to test, then check out with that Flat Rate chosen to see if that amount makes it to the order? If Flat Rate goes through and not your other method, it may be the shipping extension.

    If none of the above makes a difference, would you mind going to WooCommerce > Status, then using the button near the top left to copy the System Status Report then paste it here for us?

    Plugin Support Jesse Pearson

    (@jessepearson)

    Automattic Happiness Engineer

    @tyde1510 The css in your snippet specifically targets only the title. What you will want to do is use this part as the beginning point to the rule for each item: .woocommerce ul.products li.product . From there, you can right click on each item in the browser and choose to Inspect in order to get the class of that element for the rest of the rules. This would turn out to look something like this:

    
    .woocommerce ul.products li.product .woocommerce-loop-product__title,
    .woocommerce ul.products li.product .woocommerce-loop-product__link,
    .woocommerce ul.products li.product .price {
    color: #ffffff;
    }
    


    Link to image: https://d.pr/i/9J8WJX

Viewing 15 replies - 1 through 15 (of 1,716 total)