Forum Replies Created

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thanks for your reply. It works almost as expected, except that font-size: 0; overrules the entire content (when using !important, otherwise it doesn’t do anything).

    I still managed to get the desired result by using this code, which removes the <span> which contains the “Blog” text:

    .blog h1 span {
      display: none;
    }
    
    .blog h1.page-title:before {
      content: "Custom text...";
      font-size: 24px;
    }

    Thanks for your help!

    Thank you! This was exactly the guideline I needed. I ended up using
    echo do_shortcode( '[product_category per_page="20" columns="4" category="extras" orderby="rand"]' );
    to output the category items, and this css:

    .woocommerce.columns-4 .products .product {
    position: relative;
    width: 25%;
      padding: 2%;
      min-width: 250px;
    }

    to place them in 4 columns. Because the colums also appeared om mobile screens I added a min-width, so the products appear almost screen-width-sized in 1 column on a handheld device.

    The problem was indeed with the ID. When I changed the ID’s I didn’t notice that all the checkboxes in the edit-post-page were empty again. Therefore, I didn’t get any results.
    I ticked some boxes after changing the ID, and now it works 🙂 Thanks for your help!

    Sorry for bumping this old threat, but my problem is the same (I guess). The solutions posted here don’t work.

    This is my array:

    // CHECKBOX LIST
    			array(
    				'name'    => __( 'Genres', 'your-prefix' ),
    				'id'      => "{$prefix}checkbox_list",
    				'type'    => 'checkbox_list',
    				// Options of checkboxes, in format 'value' => 'Label'
    				'options' => array(
    					'value1' => __( 'Actie', 'your-prefix' ),
    					'value2' => __( 'Animatie', 'your-prefix' ),
    					'value3' => __( 'Avontuur', 'your-prefix' ),
    					'value4' => __( 'Comedy', 'your-prefix' ),
    					'value5' => __( 'Crime', 'your-prefix' ),
    					'value6' => __( 'Detective', 'your-prefix' ),
    					'value7' => __( 'Drama', 'your-prefix' ),
    					'value8' => __( 'Fantasy', 'your-prefix' ),
    					'value9' => __( 'Horror', 'your-prefix' ),
    					'value10' => __( 'Musical', 'your-prefix' ),
    					'value11' => __( 'Sci-fi', 'your-prefix' ),
    					'value12' => __( 'Thriller', 'your-prefix' ),
    					'value13' => __( 'Western', 'your-prefix' ),
    				),

    I’m using this to output the selected checkboxes:

    $values = rwmb_get_field( 'your_prefix_checkbox_list' ); // rwmb_get_value is new function added in 4.5
    foreach ( $values as $value )
    {
        echo $value;
    }

    Unfortunately, this outputs something like this: “value6value7value12”. What am I doing wrong?
    Many thanks!

Viewing 4 replies - 1 through 4 (of 4 total)