Forum Replies Created

Viewing 15 replies - 1 through 15 (of 24 total)
  • Thank you so much for the response!

    Is it available on Plugin settings or I need to manually set it off on Amazon S3? If so, can you guide me a bit so I can do that. That would be much appreciated!

    Talk soon,
    Bunty

    • This reply was modified 1 year, 1 month ago by Bunty Pundir.

    Nope, it is not working. I tried it. Any other way you can suggest!

    What if I add a noindex tag to each page using Yoast meta box manually instead of just enabling noindex tag under title/metas? Will Sitemap modify the date?

    Let me know what you think!

    So I didn’t added noindex by going thorough to each of the post, instead of that I just added noindex by choosing options to noindex media attachment pages under the Titles/metas under the yoast settings.

    I confirm that it didn’t updated the last modified that even after adding noindex to all attachment pages.

    Here is the status:
    Last modified date
    http://www.mydomain.com/attachment-sitemap1.xml 2015-10-15 18:58 +05:00

    If I change the last modified of all attachment pages in mysql database with this query:
    UPDATE mydatabase_name.wp_posts SET post_modified = ‘2017-10-24 06:15:03’, post_modified_gmt = ‘2017-10-24 06:15:03’ WHERE wp_posts.post_content = “”

    Will it reflect on the sitemap?

    • This reply was modified 2 years, 4 months ago by Bunty Pundir.
    • This reply was modified 2 years, 4 months ago by Bunty Pundir.

    Original issue isn’t resolved. As far as I understand I think that there is need coding knowledge to add these meta tags on the attachment pages (I surrender here). So because these meta tags are not available on the attachment pages that is why the sitemap is not updating the last modified date? If so, then is there any way to remove last modify instances from the sitemap of attachment pages?

    I

    Hey,

    I tested by updating a post on my website and as soon as I updated the post, the sitemap instantly updated the modify time in the sitemap.

    One more thing, I don’t see these meta tags for media attachment page:
    <meta property=”article:published_time” content=”2017-03-24T15:48:37+00:00″ />
    <meta property=”article:modified_time” content=”2017-10-24T17:12:37+00:00″ />

    I only see this mete properly on the posts of my website not in attachment pages. Is there anyway to add it? Right now the method you mentioned doesn’t seems to be working.

    • This reply was modified 2 years, 4 months ago by Bunty Pundir.

    Thanks for help but buddy, there are more than 300 pages and it is going take too long if I update them one by one. Is there any way to update them all in once? Just try to update the page without making any changes but no luck sitemap date didn’t update. Sitemap will take time to update the last modify date or it should be updated instantly as soon as I click on the update button.

    • This reply was modified 2 years, 4 months ago by Bunty Pundir.

    How did you do it? Can explain it and I’m not able to do that.

    I tried putting this with commas “no-lazy, lazy-ignore, attachment-colormag-featured-image” but it didn’t work. But then I removed the comma and now it is working fine. The skip image class is working like a magic and now happy with the plugin.

    Regards,
    Bunty

    Thanks for reply Steve, the colormag-featured-image class is in the content-page.php of my wordpress theme (I am using Colormag theme).

    Here goes code for content single page:

    <article id=”post-<?php the_ID(); ?>” <?php post_class(); ?>>
    <?php do_action( ‘colormag_before_post_content’ ); ?>

    <?php
    $image_popup_id = get_post_thumbnail_id();
    $image_popup_url = wp_get_attachment_url( $image_popup_id );
    ?>

    <?php if ( has_post_thumbnail() ) { ?>
    <div class=”featured-image”>
    <?php if (get_theme_mod(‘colormag_featured_image_popup’, 0) == 1) { ?>
    ” class=”image-popup”><?php the_post_thumbnail( ‘colormag-featured-image’ ); ?>
    <?php } else { ?>
    <?php the_post_thumbnail( ‘colormag-featured-image’ ); ?> //notice this
    <?php } ?>
    </div>
    <?php } ?>

    <div class=”article-content clearfix”>

    <?php if( get_post_format() ) { get_template_part( ‘inc/post-formats’ ); } ?>

    <?php colormag_colored_category(); ?>

    <header class=”entry-header”>
    <h1 class=”entry-title”>
    <?php the_title(); ?>
    </h1>
    </header>

    <?php colormag_entry_meta(); ?>

    <div class=”entry-content clearfix”>
    <?php
    the_content();

    wp_link_pages( array(
    ‘before’ => ‘<div style=”clear: both;”></div><div class=”pagination clearfix”>’.__( ‘Pages:’, ‘colormag’ ),
    ‘after’ => ‘</div>’,
    ‘link_before’ => ‘<span>’,
    ‘link_after’ => ‘</span>’
    ) );
    ?>
    </div>

    </div>

    <?php do_action( ‘colormag_after_post_content’ ); ?>
    </article>

    You can visit my website http://www.psdstack.com or any page to inspect the code. But if you check the code for featured image in your browser it won’t show you directly the “colormag-featured-image” class instead of that you’ll see “attachment-colormag-featured-image size-colormag-featured-image wp-post-image” and you know as it is already lazy load then it adds lazy-hidden before it. Also, I’m not showing the featured image using any custom code, it is default by the theme which I am using.

    • This reply was modified 2 years, 8 months ago by Bunty Pundir.
    • This reply was modified 2 years, 8 months ago by Bunty Pundir.

    Yeah, it’s fixed the issue. Earlier when I checked off ‘POST thumbnails’ button the plugin started to ignore lazy load for post featured image (what I want) but after upgrading, it is lazy loading the feature post image as well even the button is checked off.

    You also said that now skipping image class option should work now but still it is not working at all. My post thumbnail post has a class colormag-featured-image, so tried to put this “no-lazy, lazy-ignore, colormag-featured-image” in Skip Images class box but no luck at all man. After adding this, it is still showing “lazy-hidden attachment-colormag-featured-image size-colormag-featured-image wp-post-image” on the featured image

    Am I putting the class properly for lazy load ignore?

    Hey Buddy,

    Just updated as soon as I saw the new version. Now it’s giving the fatal error it’s says “fatal error: using $this when not in object context wp-content/plugins/a3-lazy-load/classes/class-a3-lazy-load.php on line 279”

    You dealt with the issue or just introduced new one? Any solution right now I just deactivated it to keep the website running.

    • This reply was modified 2 years, 8 months ago by Bunty Pundir.
    • This reply was modified 2 years, 8 months ago by Bunty Pundir.
    • This reply was modified 2 years, 8 months ago by Bunty Pundir.
    • This reply was modified 2 years, 8 months ago by Bunty Pundir.

    Thanks for heads up Steve. I’m using this plugin, I managed to ignore lazy load for post thumbnail but still homepage other images being lazy load. Since you said that you dealt with this issue with the update, then let’s see whether it works or not!!

Viewing 15 replies - 1 through 15 (of 24 total)