Forum Replies Created

Viewing 15 replies - 1 through 15 (of 846 total)
  • Plugin Author Ari Stathopoulos

    (@aristath)

    If there is an “admin” user and it’s not you, then that user will be kept and not yours. Have you tried logging-in with the admin user?

    Plugin Author Ari Stathopoulos

    (@aristath)

    I assume your site is using FTP to access the filesystem instead of using the PHp direct method, and I also assume you haven’t added your FTP credentials in your wp-config.php file.

    Check your wp-config.php file. If you see an entry for FS_METHOD, change it from ftp to direct. If you don’t have a line for FS_METHOD, add this:
    define( 'FS_METHOD', 'direct' );

    As a sidenote for future reference, please avoid posting screenshots of errors. Images are slow to load, they are on external sites that don’t necessarily respect the visitors privacy and they may not even exist in a few weeks or years.
    If instead of posting a screenshot you copy-paste the actual text error, then that text will be searchable, stored and we’ll be able to reference it in the future. The next person to have a similar issue will be able to find this ticket and hopefully a solution to their issues. There is no reason to post a screenshot when you can just copy-paste the error text here.

    Plugin Author Ari Stathopoulos

    (@aristath)

    Try adding this PHP somewhere…

    add_filter( 'kirki_output_inline_styles', '__return_true', 9999 );

    That _should_ override any previously set filters that force-load CSS using the old and slower method.

    Plugin Author Ari Stathopoulos

    (@aristath)

    Hmmm I just noticed you’re using maxstore-pro and not the free version. Have you tried contacting your theme-author and ask them about this? Maybe they tweak the CSS printing method there. Unfortunately I don’t have access to the premium version of the theme, but with the latest version of the free theme everything works as expected

    Plugin Author Ari Stathopoulos

    (@aristath)

    I tried installing your theme locally and I can’t replicate the issue… Have you checked your server’s error log to see if there’s something going on there?
    I also see you’re using an older version of the plugin, v3.1.3. Currently Kirki is on version 3.1.5 and a lot of things have been fixed and improved in those last 2 versions.
    On my localhost it doesn’t even load styles using action = kirki-styles, styles are added inline with improved performance. If after you update the plugin you still have an issue please check to see if there’s any custom code somewhere on your site that changes the default behavior of Kirki’s loading and instead of adding them inline they get added as an external reference (perhaps you have a filter?)

    Plugin Author Ari Stathopoulos

    (@aristath)

    That doesn’t sound right… Usually it’s no more than a few milliseconds! Could you post a link to your website so that I may see what goes on there?
    Thanks ๐Ÿ™‚

    Plugin Author Ari Stathopoulos

    (@aristath)

    Actually the filter works fine and it is correct. The empty value it passes is correct, by default there is no fallback image (no image = empty string)/
    The fallback image will only be used if for some reason the gravatar image can’t be locally downloaded.
    But I’d suggest you try with a non-SVG image ๐Ÿ™‚

    Forum: Fixing WordPress
    In reply to: REST API ERRORS

    @jasonsahli The Neve theme has a class called Pagination. Inside that class, they have a method called register_endpoints. Inside the Pagination->register_endpoints() method they are calling the register_rest_route function, and in the arguments they pass to it they don’t include a permission_callback as the error you’re getting mentions.
    Judging from their code, the callback they are performing doesn’t get any private data so they can simply add this line in their arguments to make it work properly:
    'permission_callback' => '__return_true',
    So the end code on that method would look like this:

    public function register_endpoints() {
    	register_rest_route(
    		'nv/v1/posts',
    		'/page/(?P<page_number>\d+)/',
    		array(
    			'methods'             => \WP_REST_Server::CREATABLE,
    			'callback'            => array( $this, 'get_posts' ),
    			'permission_callback' => '__return_true'
    		)
    	);
    }

    You can contact your theme theme-author with that information so they can fix it. ๐Ÿ™‚

    Plugin Author Ari Stathopoulos

    (@aristath)

    Thank you for the feedback!

    1. Is the โ€œpurchase offsetโ€ a one time transaction? (getting an error message here if I try to purchase. I have entered the correct Cloverly Public API

    Yes, it’s one-time transactions. Good point, I’ll need to add extra descriptions.

    2. Carbon Footprint Settings: what unit do I enter here? grams, kilograms?

    Grams.

    3. It would be a really neat feature to display a badge on the website to show visitors that I am offsetting carbon footprint with my website

    Great idea!

    I’ll start working on these and release an update as soon as possible. ๐Ÿ™‚

    Forum: Plugins
    In reply to: [Carbon Offset] Fatal error
    Plugin Author Ari Stathopoulos

    (@aristath)

    @ygirod I’m afraid I can’t replicate the issue…
    I just released v1.0.4 which has a potential fix for this.
    If that doesn’t fix your issue, could you please tell me what PHP version your site uses? It might be related to that so if I have more information I may be able to reproduce the issue and fix it ASAP.

    Plugin Author Ari Stathopoulos

    (@aristath)

    Hello @sebfck

    The @font-face calls may include all languages, but they also include unicode-ranges.
    As a result, only the characters used by your website are loaded. Even though the styles contain references to files for all languages, the browser only loads the ones it actually needs.
    That is because we have carefully chosen the user-agent we use (you can see it here: https://github.com/kirki-framework/kirki/blob/0e0a09cdae56971d1dacdb778b109343594c92f0/modules/webfonts/class-kirki-fonts-downloader.php#L184) so it’s the only user-agent that supports unicode-ranges (to improve performance) and woff files (for IE11 compatibility).
    Removing references to other languages will not save you any data.

    I hope that helps!

    Plugin Author Ari Stathopoulos

    (@aristath)

    Yes, it is.
    I always forget to update the “Tested up to” plugin header…
    Thanks for the update, I’ll pass it on to the right person ๐Ÿ™‚

    Plugin Author Ari Stathopoulos

    (@aristath)

    I suspect you will have to contact your theme author.

    Kirki outputs the styles defined by your theme, and they styles it outputs by default are valid. If your theme does something to invalidate them by using a filter or other means then you should contact their support.

    Plugin Author Ari Stathopoulos

    (@aristath)

    The new solution is a lot faster and there is no way to go back to the previous method, unless of course you just use an old version of the plugin.
    It may look a bit uglier when you view the source of the page, but it actually generates a lot less CSS, it’s a lot more private since fonts are on your own server instead of google. It’s faster for your server to compute, it’s faster for clients to render. Why would you ever want to go back to an older and far worse method?

    Plugin Author Ari Stathopoulos

    (@aristath)

    Fixed in v3.1.2, will be available in a few minutes.

    Thank you for reporting this, I would have missed it otherwise ๐Ÿ™‚

Viewing 15 replies - 1 through 15 (of 846 total)