Forum Replies Created

Viewing 15 replies - 61 through 75 (of 77 total)
  • NicheLabs

    (@allennichelabs)

    I found what the issue was. There was some code in the footer from MailChimp. As popup newsletter signup form that was generating several JavaScript errors and apparently causing issue with Woocommerce.

    Once I deleted the code the add to cart button showed again and is now functioning.

    I had tried deactivating all the plugins to see if there was a conflict, never thought of external coding being the problem.

    NicheLabs

    (@allennichelabs)

    Here is some updated information.

    It appears that the add to cart button is there but it is hidden, the style is set to “display: none”

    Other support threads I’ve read show that this is due to javascript errors. So I’m assuming it’s related to the error “TypeError: a.cookie is not a function”

    I’ve tried to force the display to “display: block” but when I click on the add to cart button I get the following:
    “Please choose product options…”

    So I guess my question becomes, how to I fix the javascript error and why did the upgrade to WordPress break this?

    NicheLabs

    (@allennichelabs)

    Some additional information:

    I spoke with my hosting company (HostGator) and they looked at it and said that it looks to be an issue with the plugin. Before they can help me any further they need to know what server requirements are needed for this to function properly (PHP Version, PHP Settings, Server Settings, etc..)

    NicheLabs

    (@allennichelabs)

    Love this plugin, so simple and easy to use. I love the way it automatically maps the data. This makes the process extremely easy for my clients to use.

    However, the requirement of a comma before the category is really a issue. My client isn’t going to remember to put a comma in that field. Heck I’ve already forgotten twice causing me to have to restore my backup.

    If that could be changed this would be a 5 star plugin as far as my application is concerned.

    NicheLabs

    (@allennichelabs)

    Same here.

    I’m using
    Wordpress 3.9.1
    TML 6.3.10

    I have the following enable for THM:
    Custom Emails
    Custom Passwords
    Custom Redirection
    reCaptcha
    Security
    Themed Profiles

    NicheLabs

    (@allennichelabs)

    I downloaded the beta version of the company fields editor and it seems to work ok except when using a field type of wp-editor. The editor will show up in the job submission form but does not show up in the backend when editing/adding a job.

    Forum: Reviews
    In reply to: [Debug Bar] Doesn't Work
    NicheLabs

    (@allennichelabs)

    I left a post in the sub-forum along with two others who had left a response for the same problem 4 months ago and 2 months ago.

    If you read through the support forum for this plugin there are plenty of unanswered posts with questions and problems regarding this plugin.

    Since two others who experienced the same issue as I did received no response in 4 months I figured the chance of me getting one was slim to none.

    I see you closed the topic, chastising me for tagging onto someone else’s thread when the problem was exactly the same thing, just with a newer version of WordPress.

    No updates have been made to the plugin in a year so I assumed the issue wasn’t resolved. So I guess the question is why did it take a bad review to get you to address the problem? Why didn’t you respond to the other two requests on this issue?

    Even now you don’t address the issue or give helpful suggestions for me to maybe track down where the problem might be. Rather you attack me and ask how I know the problem isn’t me.

    NicheLabs

    (@allennichelabs)

    Same here, just installed on 3.9.1 and nothing. There are no settings, nothing in the admin bar. This doesn’t work.

    From what I’ve seen in these forums I don’t expect any kind of answer either. To many posts without response.

    NicheLabs

    (@allennichelabs)

    Nevermind, you can mark this as resolved.

    I changed it to use the following instead of WP_Query and it works now.

    $footerPg = get_page_by_title( 'Footer', OBJECT, 'page' );
    echo $footerPg->post_content;
    NicheLabs

    (@allennichelabs)

    I’m having this same problem. If I use the default profile-loop.php file it works but if I used either xprofile_get_field_data(‘Description’) or bp_profile_field_data( ‘field=Description’ ) then I loose the <p> tags.

    There has to be a filter somewhere that is stripping these.

    NicheLabs

    (@allennichelabs)

    Okay I finally managed to get this. It’s quite involved so if you need to know please ask and I explain it further.

    It involves using wp_list_cagegories to build the list of groups and then creating a taxonomy-sfaff-member-group.php file that queries the post type and the staff-member-group for the current term, obtained by using $wp_query->query_vars[‘staff-member-group’]

    NicheLabs

    (@allennichelabs)

    Just discovered one issue with this method.

    If I have subpages setup under People and try to display different groups (like Managers) I get a 404 error.

    The link shows up as http://domainname.com/people/managers.
    I have a page setup called Managers with the parent set for People.
    I have the shortcode [simple-staff-list group=”managers”] on the Managers page.

    I know this has to do with a conflict with the plugin using the same permalink as the page People. But that was the only way I could get pagination to work.

    If anyone has any idea how to fix this I would appreciate some help.

    I’ll keep looking into it to see if I can find another workaround.

    NicheLabs

    (@allennichelabs)

    Okay I found a round-about way to resolve this.

    I’m not exactly clear on why this works but it does for me at least.

    In the file simple-staff-list.php I changed the following:
    ‘rewrite’ => array(‘slug’=>’staff-member’,’with_front’=>false),

    To this:
    ‘rewrite’ => array(‘slug’=>’people’,’with_front’=>false),

    Where ‘people’ is an actual page on my site.

    For whatever reason by doing this it now allows me to use my theme for custom post types, so I now am using archive-staff-member.php and single-staff-member.php to control the display of staff members.

    This bypasses the “template” settings in the plugin’s setups.

    I had to make some adjustments to these files in order to pull the information from the custom post type as I described here:
    http://wordpress.org/support/topic/custom-post-template-for-single-staff-member?replies=3

    I also had to incorporate the following code:

    $page = (get_query_var('paged')) ? get_query_var('paged') : 1;
    					$temp = $wp_query;
    					$wp_query = null;
    					$wp_query = new WP_Query();
    					$wp_query -> query('post_type=staff-member&showposts=10'.'&paged='.$paged.'&orderby=title&order=ASC');
    					if ($wp_query->have_posts()) :
    					while ($wp_query->have_posts()) : $wp_query->the_post(); ?>

    Which now allows me to use any pagination method I choose, whether it’s WordPress’s default or any pagination plugin.

    I hope this helps someone and I especially hope that it is clear.

    NicheLabs

    (@allennichelabs)

    Any plans on getting this added sometime soon. I love this plugin and have been able to get it to do just about everything I need it to, except for this and this is a very important aspect.

    I’m working on a project that has over 70 staff members and the client doesn’t want them all listed on one page.

    It wasn’t until now that I was able to add all the staff members and discovered that there was no pagination support.

    Any suggestions would be greatly appreciated.

    NicheLabs

    (@allennichelabs)

    Try changing this:

    div.staff-member {
        border: medium none;
        display: inline-block !important;
        position: relative;
    }

    To this:

    div.staff-member {
        border: medium none;
        display: inline-block !important;
        float: left;
        padding: 0 18px;
        position: relative;
    }

Viewing 15 replies - 61 through 75 (of 77 total)