Forum Replies Created

Viewing 15 replies - 1 through 15 (of 309 total)
  • Plugin Author 99robots

    (@99robots)

    @chcw – Thanks for inquiring. This free plugin does a lot but it doesn’t handle PHP code.

    Luckily, we’ve just introduced a PRO version of the plugin that does support PHP snippets. You can get it here and it’s currently on a one-time lifetime deal (which will go away soon).
    https://draftpress.com/products/header-footer-code-manager-pro/

    Thanks.

    Plugin Author 99robots

    (@99robots)

    No worries @garrydufresne! Let us know if you have any other questions. I’m closing this ticket and marked it as resolved.

    Plugin Author 99robots

    (@99robots)

    Hi @garrydufresne – If you choose sitewide, then there is no “top of content” or “bottom of content” because most of the site’s pages do not have the WP hook/function for the_content. Only single posts / pages and single posts of custom post types would have a the_content hook for the plugin to actually identify and place the snippet. Otherwise, it would fail on almost all of your site’s pages as most themes do not have this function on non-single posts/pages. Therefore, this is expected.

    Hope that makes sense.

    Thank you.

    Plugin Author 99robots

    (@99robots)

    Not sure why you a detailed answer to your comments is being viewed as combative. I re-read everything written and I’m just not clear about where we’re combative.

    Regardless, please keep in mind that now that you’ve clarified that you’re not referring to what this resolved thread is about, that clarifies more that you’re just asking what we mean by the word “placement hook”. For that, a new thread would be warranted as this thread is for entirely different topic by OP and the 2nd person both of whom did not reply back even though we’re quick to reply here and support our users.

    Thank you.

    Plugin Author 99robots

    (@99robots)

    @caomicc – Are you on latest version of the plugin? No feature has ever been removed. In fact, more features have been ADDED.

    I think that it is very unclear now how to access the before content/after content as it only shows up when selecting individual pages.

    Regarding before/after, nothing has changed from previous versions. Works the same way as always.

    To clarify, the BEFORE/AFTER CONTENT placement option would ONLY be applicable on a single post / page / or single cpt assuming it exists in your theme’s template.

    What is your site or page that you are trying to display? Can you please check your theme’s template code for that speicific page template and confirm that it truly has “the_content” hook used? If it doesn’t, then it’s your theme. If it does, and the code snippet does not appear, please upload a screenshot with your setting to help investigate.

    Also, it does not display before/after content without a placement hook… that is not included in installation / or anywhere in documentation. Can you please make this an update?

    To clarify, that note is there as reference meaning that if your site’s THEME does NOT properly use WP hooks such as the_content for your posts/pages/etc template you’re referring to, then there’s no way for the HFCM plugin to know where to place the snippet. Functinoally, this has always been the same since day 1. Nothing has changed in this regard only a note added for more clarity. It is not HFCM’s purpose to modify your theme. Properly coded themes should use WP hooks correctly.

    Let us know if this clarifies your question.

    Plugin Author 99robots

    (@99robots)

    As we have not received a reply for almost 3 weeks, we’ll assume our troubleshooting steps above helped resolve the issue or it as not an issue. We have not gotten similar reports from other users.

    Therefore, this ticker will now be closed. Thank you.

    Plugin Author 99robots

    (@99robots)

    Hey @samedwards – Yup. In fact, developer reviewing and working on it as we speak. You’ll see it come through in the next release.

    Plugin Author 99robots

    (@99robots)

    @andrei0luca – we looked into this but since it does work in all browsers and not in Chrome, our thought is that it is definitely due to how Chrome handles preloading of fonts. It’s unrelated to our plugin.

    Some web searching found this gem:
    a) https://stackoverflow.com/questions/42616709/preloading-fonts-in-chrome-with-preload-link-directive
    b) https://www.freecodecamp.org/news/web-fonts-in-2018-f191a48367e8/
    c) https://developer.mozilla.org/en-US/docs/Web/HTML/Link_types/preload
    d) https://drafts.csswg.org/css-fonts/#font-fetching-requirements

    Notice that there are 2 points discussed in that thread:
    1) font-face
    2) crossorigin attribution

    See if variations of including that change your result for Chrome. For now, I will mark this as resolved since it’s not really a plugin related question. Though, feel free to reply back if you find otherwise after attempting to solve based on the findings in that threads above.

    Thank you.

    • This reply was modified 1 month, 1 week ago by 99robots.
    Plugin Author 99robots

    (@99robots)

    hi @bragamatta – this is an old/resolved thread. It’s the only other person that ever reported this issue so there’s not many people with this same problem. So far, 2 people (including you) have reported this out of 250,000+ which likely means it has something to do with either your site configuration or it’s a very extreme edge case that’s not easily reproducible as all sites are different and therefore will require some digging to help resolve.

    To assist, we have to ask you to provide more info and help us help you since we have not been able to replicate this issue:

    1) Let’s try something super simple. Can you please ensure you have done a HARD REFRESH. Clear your browser cache. Sometimes old js files get cached and that could cause such behavior.

    Alternatively, try checking if snippets are visible in another browser (incognito mode) – Firefox, Safari or whatever else.

    2) Can you confirm if you used the standard WordPress upgrade method. Plugins > Update. Or did you update manually by uploading the latest version?

    3) The last resort would be to check your site as any time there is a field (like code editor) missing, it’s usually due to a third-party plugin or theme conflict. Simply deactivate all other plugins except HFCM, and then check whether the snippet is visible? If YES, HFCM plugin is working fine and it’s due to one of your other plugins. Identify that culprit by turning each plugin on one-at-a-time, check the snippet if still there, and then continue. Remove whatever is causing the issue.

    The very last thing is to give our support team access to see if we can identify anything quirky going on. Though, we’d like to avoid requesting access credentials if one of the above remedies helps resolve this.

    Will await your response and keep this ticket unresolved until you reply. If no response received, we’ll close it after a few days.

    Thank you.

    Plugin Author 99robots

    (@99robots)

    @rainbow15 – apologies for the delayed response.

    For Pinterest claim domain, that is just a one-time verification that Pinterest requires. So you can add the snippet sitewide and after Pinterest verifies the domain, you can actually remove it if you want.

    For email subscription form code, it depends on the code and where you actually want to insert it on your site. Typically, the major email service providers have their own plugins where you can insert a form anywhere. Assuming it’s HTML/JS snippet, you can use HFCM too.

    Hope that helps.

    Plugin Author 99robots

    (@99robots)

    @dougcastro – We didn’t get a response so I’m guessing this is resolved and no longer an issue anymore. Feel free to reply if it is. For now, I’ll mark this ticket resolved.

    Also, the PRO version is out and on a lifetime deal for a limited time. Check it out:
    https://draftpress.com/products/header-footer-code-manager-pro/

    Thanks.

    Plugin Author 99robots

    (@99robots)

    @tripflex – checked what you wrote and the minimum version will be updated to reflect accordingly in the next release going out this week. Thanks for bringing this to our attention – much appreciated.

    Will close this ticket.

    Plugin Author 99robots

    (@99robots)

    @wolframio74 – we’d appreciate a response and adjustment of your review when you get a minute.

    Plugin Author 99robots

    (@99robots)

    @jhartvickson – can you please share the snippet here? Alternatively, please send the snippet and link to this thread to our premium plugin support team over at support@draftpress.com and they’ll investigate today.

    Also, please make sure you’ve tried the steps suggested above. Without that troubleshooting, we’ll be unnecessarily reviewing.

    • This reply was modified 1 month, 3 weeks ago by 99robots.
    Plugin Author 99robots

    (@99robots)

    @wolframio74 – We did not get a response to our troubleshooting steps above.

    The feature was NOT removed. If it was, you’d see 250,000 other folks mentioning it as well. Since that is not true, can you please update your 1-star review which is clearly not warranted.

    Thank you.

Viewing 15 replies - 1 through 15 (of 309 total)