WordPress.org

Forums

YITH WooCommerce Zoom Magnifier
Zoomed image is tiled (18 posts)

  1. Ninjini
    Member
    Posted 1 year ago #

    Hi, I've just installed and configured this and when you use the mouse-over in the front end of the site, the zoomed image is tiled. How can I prevent that happening?

    https://wordpress.org/plugins/yith-woocommerce-zoom-magnifier/

  2. Pete-st
    Member
    Posted 1 year ago #

    Same here. This just started happening for me, while some of the images I uploaded a while ago work just fine. Could anyone help?

  3. PagePlusCA
    Member
    Posted 1 year ago #

    Same issue. Please update.

  4. izzat_adv
    Member
    Posted 11 months ago #

    I have the same issue. Doesn't seem to work with Blaszok theme from MPC. Please need reply and update.

  5. andrejopra
    Member
    Posted 11 months ago #

    same problem here.. my pic all tiled

  6. acbmedia
    Member
    Posted 10 months ago #

    I have same issue, highly appreciate if someone can help

  7. larsactionhero
    Member
    Posted 9 months ago #

    hello,

    i'm having the same issue. please help!

  8. pat7047
    Member
    Posted 9 months ago #

    Same here. I've tried reuploading the same exact images from previous WooCommerce products I have (and the zoom works just fine). The zoom works just fine with old images I uploaded a few months ago, but any new images I uploaded, they appear tiled.

  9. larsactionhero
    Member
    Posted 9 months ago #

    I just found out that the plugin works wenn if you install and activate it after having all the images uploaded.
    I've deactivated it, uploaded the new images, activated it, and than the zoom appears correct.
    so something seems to go wrong while uploading images when the plugin is active.

    but anyway, it is no workaround for a running online shop to disable, upload, enable the plugin each time.

    we still need a solution.

  10. pat7047
    Member
    Posted 9 months ago #

    @larsactionhero That works! Thank you so much! Definitely agree that the developer should fix this, or at the very least make this "work around" known. Thanks again!

  11. larsactionhero
    Member
    Posted 9 months ago #

    @pat7047 you're welcome. ;)
    By the way, I also found out that the developers do not read or offer support in this forum:

    ...
    Register on http://yithemes.com
    Go to Support > Get Support

    Here we provide support, not on wordpress.org were, usually we do not read topics. It's better to follow us or write on our forum!

    Anyway, I've opened a thread in the forum. We'll see if they're going to take care about fixing this issue.
    http://support.yithemes.com/entries/104250896-Yith-Zoom-uploaded-large-images-do-not-appear-in-Zoom

  12. larsactionhero
    Member
    Posted 9 months ago #

    As I can't wait for lazy support dudes, I finally found a workaround that works with activated plugin.

    1. In Plugin folder, go to /templates/single-product.
    2. Copy files to your woocommerce theme folder to
    /YOURTHEME/woocommerce/single-product/.
    3. Open product-image-magnifier.php
    4. In line 31, look for $magnifier_url and replace it with $image_link.
    This full size image appears in the zoom box.

    Save, upload, and open a beer. :)

    Original code:

    echo apply_filters( 'woocommerce_single_product_image_html', sprintf( '<a href="%s" itemprop="image" class="yith_magnifier_zoom woocommerce-main-image" title="%s">%s</a>', $magnifier_url, $image_title, $image ), $post->ID );

    Modified code:

    echo apply_filters( 'woocommerce_single_product_image_html', sprintf( '<a href="%s" itemprop="image" class="yith_magnifier_zoom woocommerce-main-image" title="%s">%s</a>', $image_link, $image_title, $image ), $post->ID );

    Here's a screenshot: Link

  13. sumonshekhbp
    Member
    Posted 8 months ago #

    larsactionhero I found your reply useful but still its not working properly. After modifying the code as you stated above it works only with the product featured image, but I have some product gallery image. The gallery images are not magnifying. Please help me.

  14. larsactionhero
    Member
    Posted 8 months ago #

    @sumonshekhbp:
    Anyone who should help you will ask for more information about your installation. Links to your site, code snippets, screenshots, your installed versions, whatever...
    Just asking for a solution is way too easy, dude ;)

    The "product gallery images" - do you mean the thumbs showing up below the large image?
    In my installation they're working properly.

  15. sumonshekhbp
    Member
    Posted 8 months ago #

    @larsactionhero:
    Yes, you are right. I was talking about the thumbnails pictures. Magnifying zoom for those thumbnail image when click them to view is not working.

  16. YITHEMES
    Member
    Plugin Author

    Posted 5 months ago #

    hi all,
    please provide some additional information like zoom area size and catalog zoom images size and a link to a page where the issue occurs.

  17. larsactionhero
    Member
    Posted 5 months ago #

    @YITHEMES:

    first, thanks for the reply.

    second, this thread about the issue started 7 months ago (!), and beside that i've also posted this in your support forum about 3 months ago and it is still waiting for any replies.
    we're all thankful for any help. but don't get me wrong, but this is just a little bit lazy.

  18. YITHEMES
    Member
    Plugin Author

    Posted 5 months ago #

    @larsactionhero,
    Sorry for the delay, we are going to release an update soon, so we have started to check these support tickets for issue and bugs some days ago.
    If there is some issues that we can reproduce, we are willing to fix them before the update, but we need to know not only the front end issue, but even the plugin options used, like zoom area size, catalog zoom images, the size of the image used and so on.
    The more the request is detailed, the better we can work on and fix it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.