Support » Plugin: WP Image Zoom » Zoom Window shows wrong image

  • Resolved abachechi3

    (@abachechi3)


    I just started using this plugin, and for the most part it has been working well. I ran into an issue on the specified page though where the zoom window is showing the wrong picture.

    About halfway down the page, the zoom window starts showing the next image instead of the one the mouse is hovering over, and then some images it does not show up at all. I think it may be that the area for the zoom is somehow offset, as at the bottom of the page it appear over text rather than an image. What I don’t know is how this happened or how to correct it. It also works correctly if I am logged into WordPress, but doesn’t work when not logged in.

    My only current hypothesis is that the very long image in the middle of the page might be messing things up somehow. I originally tried to have the zoom feature on this image as well, but it proved to be too long. I removed the class from that image, but the others are still messed up. Any help is appreciated!

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Diana Burduja

    (@diana_burduja)

    Every image has an animation effect as if coming from below. Would you please deactivate the animation effect and see if the issue persists?

    I disabled the animations on the images, but it still seems to be happening. Each zoom seems to be about one full image size (depending on size of image) above where it should be, after a certain point. The pictures before the red section (and the extra long image) still seem to be fine.

    Plugin Author Diana Burduja

    (@diana_burduja)

    Would you turn off the sticky header for a moment to see if that is causing the zoom window offset?

    I turned off the sticky header and tested it, but was still having the same problem. The sticky header has been returned to the way it was now that it has been eliminated as the problem. Thank you for helping me work through this.

    Plugin Author Diana Burduja

    (@diana_burduja)

    Ok, let’s test the next thing on the list. Would you uncheck the “Enable Lazy Loading for images” option on the “WP Admin -> Jetpack -> Settings -> Performance” page for a moment?

    That actually appears to have fixed the issue! I do worry about it slowing down the rest of the site, but I will discuss it with the rest of the team. Thank you!

    Plugin Author Diana Burduja

    (@diana_burduja)

    You can keep the Lazy Load functionality enabled and deactivate it only on specific images by adding the “skip-lazy” CSS class to the image.

    Thank you. I think we will be able to figure it out from here now that I know where the problem is coming from.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.