Support » Plugin: Stellar Places » Zoom option being ignored by maps API

  • Resolved Mark Waterous

    (@delayedinsanity)


    I’m trying to swap Stellar Places in as a replacement for a client using another google maps plugin and everything is great… except that the zoom won’t set.

    No matter what I set the shortcode zoom attribute to, the map displays initially at maximum allowed zoom (this doesn’t work well for the intended use).

    When I set a maxZoom (by itself) it displays immediately at whatever the maxZoom is set to, but ignores the internally set default zoom of 14.

    I have tried this same address and shortcode on a clean install of WordPress to ensure there were no conflicts with other plugins or the theme.

    I have debugged both the PHP and JS to make sure that the zoom level I set was being passed all the way down the line, and it is. It’s just ignoring it for a reason I can’t yet figure out.

    Example: http://www.lynnwoodtourism.com/lynnwood-hotels/best-lynnwood-inn/ You can see the mapOptions object in the console, it’s sent there immediately after parsing the json.

    Shortcode looks like: [stellar_places_map post_id="8054" height="300" width="500" maxzoom="18"]

    https://wordpress.org/plugins/stellar-places/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Micah Wood

    (@woodent)

    @delayedinsanity,

    Thanks for pointing this out. I’ve just released version 1.0.3 of the plugin, which resolves this issue. Now, if you set ‘zoom’ it will properly set the zoom level on the map. If you don’t explicitly set the zoom, then the auto zoom feature will take over.

    Amazing; if there wasn’t enough reason to use Stellar before (which there was), that just sealed the deal. Thank you, I tested it and everything is working great.

    Plugin Author Micah Wood

    (@woodent)

    @delayedinsanity,

    Glad to hear! Just let us know if you run into any other issues. Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Zoom option being ignored by maps API’ is closed to new replies.