Support » Plugin: WP Google Maps » Zoom, Fullscreen Buttons Not Clickable

  • Resolved sdagency

    (@sdagency)



    Nick, I sent you the page password via email.

    The zoom and fullscreen buttons appear but aren’t clickable or don’t respond.

    The i (information) button seems to work.

    I’ve tried different browsers and lightened or opened up all the browser settings for things like scripting and security temporarily to see if there was a conflict. So far nothing seems to impact getting them to work.

    Thanks.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author perryrylance

    (@perryrylance)

    Hi there

    Thank you for bringing this to our attention, my apologies for any inconvenience caused.

    Can you please e-mail the password to perry@codecabin.co.za ?

    I’m afraid I don’t have access to Nick’s mail and he’s not in the office at the moment.

    Kind regards
    – Perry

    Thanks Perry. I sent all that info to Nick (or his email says Dylan K). Hopefully you two have connected. He has access to my site. So far no fix.

    PARTIAL “FIX”

    So playing around int he CSS if I change all the default .5em values to 2.5em or 3.5em for these classes I can activate the buttons.

    .ol-zoom {
    top: 2.5em;
    left: 2.5em;
    }

    .ol-full-screen {
    right: 3.5em;
    top: 3.5em;
    }

    Of course it looks horrible with the buttons floating out on the map, but something must be interfering with the mouse activation in the default position. Hope this helps. Please let me know.

    Plugin Author perryrylance

    (@perryrylance)

    Hi there

    I just corresponded with Dylan on this and he identified the issue and applied a fix to the your site.

    It appears there was some 3rd party CSS causing pointer-events to be set to none for these buttons.

    Dylan has added some CSS to force this to pointer-events: all; and we can confirm the problem is solved.

    Please confirm that’s solved at your end?

    Kind regards
    – Perry

    Yes, I can click the buttons now. THANKS!

    So the only problem that remains is I can’t add a marker UNLESS I use a Google API despite using Open Maps as the engine.

    I’ve written Dylan about that a few times. If we can get that worked out I’m definitely signing up for the pro level so I can complete this project and recommend it to our other clients as a fix for what’s coming in the Google Maps transition.

    Plugin Author perryrylance

    (@perryrylance)

    Hi there

    We’ve reproduced this locally and are going to be issuing a patch as soon as humanely possible.

    If you’re happy with your workaround for the time being that’s great, if not then one of us can issue a quick fix.

    Thanks again for bringing this to our attention!

    Kind regards
    – Perry

    Hi im having the same problem, i have made a map but when i preview it on my website, i cant zoom in and i cant click anything on it even though its showing.
    I have the pro version and i have made other maps about 8 months ago which work fine but whatever maps i make now dont have active screens on my site. Please help.

    Plugin Author perryrylance

    (@perryrylance)

    Hi there

    Thank you for getting in touch, my apologies for the delay in responding.

    Can you please link us to the page in question?

    If you need to do so in confidence, can you please open a ticket through our support portal?

    Kind regards
    – Perry

    Hi Dylan,
    My website is https://www.theluvgift.com/honeymoon-registry/ .
    There is only one map on this page and although it shows, it does not respond to movement inside the box or to button pressed inside the box.
    I have made around 25 other maps throughout my site about 8 months ago and they all work fine.
    Here is an example page of another map that works fine.

    https://www.theluvgift.com/honeymoon-packages/europe/italy/

    I had opened a topic about 20 hours ago and dylan has just responded but i would like to get this done asap please.

    Thank you
    Chris

    Plugin Author perryrylance

    (@perryrylance)

    Hi Chris

    I’ve identified this issue as a problem caused by Revolution Slider creating transparent elements over the top of the panel in question.

    Please see my reply through our support desk – I’ll definitely try to disable pointer events on these elements so that the underlying map (and text, images etc.) can be interacted with through pointer events, however please be advised that you may need to contact Revolution Slider’s author if I’m unable to circumvent this – they’d be in a far better position to tell you about this as they’ll be more familiar with the code.

    I hope that helps?

    Kind regards
    – Perry

    Hi Perry,

    There is a small problem. Ever since the map became active on the home page that i requested for…..4 buttons do not work anymore….”start your registry” which is next to the bride….. “e-vite” and “e-vite+giftlist” which are in the the “make it” section and finally “start your registry” which is in the “send it” section.

    Oddly enough the “honeymoon gifts” button works….BUT not on the mobile version….none of the buttons work on the mobile version.

    I took off the map to see if that was the problem and it was. Once the map was off….all buttons worked on the computer and mobile version.

    I have put the map back so that you can work on it.

    FYI ….all buttons are part of slider revolution…..even the “honeymoon gifts” button which works. The fact that only this button works gives me hope that the others can work as well once you’ve adjusted.

    Can you please help? Having your map active on my front page is huge for me.

    Sorry for the trouble.

    Thank you

    Plugin Author perryrylance

    (@perryrylance)

    Hi Chris

    I responded to your support ticket approximately half an hour ago, please refer to my response there.

    I’d like to try tweaking the CSS a little to see if we can get that working for you, I’ve sent a message on your ticket requesting login details if that’s permissible.

    I hope that helps?

    Kind regards
    – Perry

    Plugin Contributor NickDuncan

    (@nickduncan)

    @xrobins, @sdagency have your issues been resolved? May I close this ticket?

    xrobins

    (@xrobins)

    no they havent resolved it as yet or even responded to my last question, i really need their help, i will post the question again below.

    Hi Perry,

    There is a small problem. Ever since the map became active on the home page that i requested for…..other buttons do not work anymore….”start your registry” which is next to the bride….. “e-vite” and “e-vite+giftlist” which are in the the “make it” section and finally “start your registry” which is in the “send it” section and all the little buttons on “top destinations” and “usefull resources”.

    Oddly enough the “honeymoon gifts” button works….BUT not on the mobile version….none of the buttons work on the mobile version.

    I took off the map to see if that was the problem and it was. Once the map was off….all buttons worked on the computer and mobile version.

    I have put the map back so that you can work on it.

    FYI ….all buttons are part of slider revolution…..even the “honeymoon gifts” button which works. The fact that only this button works gives me hope that the others can work as well once you’ve adjusted.

    Can you please help? Having your map active on my front page is huge for me.

    Plugin Author perryrylance

    (@perryrylance)

    Hi Chris,

    I replied to this through our ticketing system a few days ago, I’ll take a look for your ticket now and respond through there.

    The problem lies with Revolution Slider obscuring pointer events on this page.

    With that said, I’m quite happy to continue looking into this, I can contact them on your behalf if you would like?

    Can you please check your inbox, I’ve just re-sent my last reply to your ticket, please confirm receipt?

    Kind regards
    – Perry

Viewing 15 replies - 1 through 15 (of 19 total)
  • You must be logged in to reply to this topic.