Support » Plugin: WP Ad Guru - Banner ad, Responsive popup, Popup maker, Ad rotator & More » Zone problem between mobile and desktop

  • I just want to show some ad zone to desktop users but I have problem.

    I set zone using visibility condition min width 481px but my mobile users still can view the ad zone.

    how to set this thing done?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author oneTarek

    (@onetarek)

    I just tested this feature. It is working perfectly with min width 481px. If screen width is less than 481px then user can not see that zone. If user hold his mobile in landscape mode then screen width will be bigger than 480px, in that case he will see the ad. Can you share your website link where you are showing that particular zone.

    Thanks
    Jahidul Islam

    Thread Starter Istanto Adi Nugroho

    (@istantoo)

    Hello, you can try on one of my projects https://www.tantobox.com I set min width 481 but desktop and mobile can see modal popup. I also try using mobile detect snippet http://mobiledetect.net it’s still not working, every version desktop/mobile can see modal popup.

    Thanks,
    Istanto

    Plugin Author oneTarek

    (@onetarek)

    Hi,
    You are doing the setup in wrong place. You set min width to a zone. There is no relation between a zone and a modal popup. A zone is used to show banner ad.

    Right now there is no option to show/hide modal popup for certain type of screen size. But you can do some tricks below.

    1. Make the modal popup responsive from sizing option. Now popup will be shown perfectly in mobile screen.
    2. Put the close (X) button at left-top corner of the popup. If it fails to show popup perfectly for any screen, user will see the close button to close the popup.
    3. If you really don’t want to show popup for mobile user then try adding following CSS code in your page.

    @media screen and (max-width: 480px) {
    	body .adguru-modal-popup {
    		display: none !important;
    	}
    }
    Thread Starter Istanto Adi Nugroho

    (@istantoo)

    Thank you for solution, I will try to apply it and report if it works 🙂

    Plugin Author oneTarek

    (@onetarek)

    I hope your problem has been solved.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.