WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Zombaio plugin Problem

[Resolved] Zombaio plugin Problem

Viewing 15 replies - 1 through 15 (of 51 total)
  • Plugin Author Barry Carlyon
    Member

    @barrycarlyon

    For starters, are you reporting that you can no longer access WordPress Admin?

    When you say you are logging in and getting a wrong username/password, are you trying to login as a WordPress admin, or a Paid member?

    WP Zombaio, essentially listens to Responses and Notifications from Zombaio, much the same way as ZScript does. Except rather than updating a .htpasswd file like ZScript, WP Zombaio creates and deletes WordPress users (and blocks content access to non-logged in users, of course).

    If you were running with ZScript and have switched to WP Zombaio, then you will need to create/import the paid members from Zombaio into WordPress, which I can advise upon having constructed something similar for another user, who contacted me (the author) thru my contact (as suggested in WP Zombaio readme and the Guide included with the plugin)

    The reason you are finding that .htpasswd and ZScript breaks, is that WordPress will have overwritten .htaccess removing the references to ZScript’s protection.

    I am a little at odds why you turned to a freelancer, rather than myself, since I have a fair few notices about the plugin, it’s guide, the readme, and my own site, but that’s life! 😀

    Normal usage of the plugin is to have Anyone Can Register disabled, and a page created with the WP Zombaio Join Form URL shortcode on, to facilitate redirection to Zombaio for payment/membership selection.

    I hope this helps!

    crh1982
    Participant

    @crh1982

    ok yes i had them zombaio installed i did message you from your website b4 freelancer and no reponse so i need to get this done as i am having this site going undone for 3 months now waiting on zombaio and all i was using a test login as :user: like zombaio has a rest card to see if things are working i made test transation made username and password then went to login and it wants my admin login details or it does not work

    i think that i unistalled all the zscript zombaio put in b4 i used the plugin but i feel like i might need to just unistall wordpress make a copy of the style.css and just start over idk want to pull my hair out at thispoint lol

    i can usually figure things out myself and dont need to resort to freelancer but i have search high and low how to use this and no sucess

    Plugin Author Barry Carlyon
    Member

    @barrycarlyon

    Hmmm, I wonder if my contact form dropped you into Spam, I normally pick up everything that comes thru the contact form. When did you contact me. I’ll see if I can find your email!

    Are you saying that your Admin details do work?
    But a paid user does not?

    Did the user make a payment, or is the user manually added in Zombaio?

    Did the Wizard Setup complete successfully?

    Do you have any security plugins installed, or use something like CloudFlare?
    These can be known to block notifications from Zombaio.

    I have tried to include everything relevant in the Plugin Guide, so once this is resolved I’ll see about adding suitable notes to the next guide release.

    crh1982
    Participant

    @crh1982

    yes admin works has always worked

    i made test payment with zombaios test visa card
    they then make me set up user name and password
    i put login widget for zombaio in widgets
    signed in usering the username and password i created thru zombaio payment

    it doesnt work i have not security that i know of i have basically started from scratch as i was using pid membership pro b4 this i do not have any members currently so all is tet members crdentials

    The wizard was successful and successfully validated in my zomaio account
    and was test payment not added manually

    crh1982
    Participant

    @crh1982

    oh i contacted you last night thru christinah*****@ymail.com

    crh1982
    Participant

    @crh1982

    I believe the email i sent though was about allow all users wasnt going away at top when i had it set to no but during the process the freelancer somehow made it go away i tryed to change it to yes and and it didnt show the message so i dont know if she really fixed it or just took the code for that ut or something

    crh1982
    Participant

    @crh1982

    ????

    crh1982
    Participant

    @crh1982

    ok i am just going to uninstall wordpress and create a new database and start all over idk what else to do at this point no one seems able to help and there are no details anywhere on the web about this happening to others so it must just be me and starting over will hopefuly solve the issue idk

    Plugin Author Barry Carlyon
    Member

    @barrycarlyon

    Sorry for causing a ???? I stepped away to eat dinner (I’m not long home from my day job)

    I recieved your message at 3:50AM GMT and responded at 8:50AM GMT

    In response I emailed:

    Hello Christina,

    Sounds like what you need to do, is turn off the Anyone Can Register under General options inside WordPress and then create a join page which has the something like the following on it:

    [zombaio_join align=”left” width=”300″ join_url=”JOINURL” buttonalign=”center”]PRICING[/zombaio_join]
    [zombaio_seal align=”right”]

    Replacing JOINURL with your Join URL (something like https://secure.zombaio.com/?xxxxxxxxx.yyyyyy.ZOM)
    And PRICING with some notes/information about your pricing structures.

    WP Zombaio doesn’t hook into the “normal” WordPress registration, so the “normal” WordPress registration bypasses the need to Pay to Join.

    Hope this helps

    In response to this thread:

    i made test payment with zombaios test visa card
    they then make me set up user name and password
    i put login widget for zombaio in widgets
    signed in usering the username and password i created thru zombaio payment

    Is Zombaio Running in LIVE MODE with Test Cards, or TEST MODE with Test Cards?
    In TEST MODE with test cards it might not work, as IPN Verification may fail, but the test interface should notify about this.

    When you went to Zombaio and “paid”, you entered a password to use. And clicked complete. This should of triggered a notification back to WP Zombaio.

    When you login as admin, can you see that a user of the given email address and username has been created?

    Additionally, can you check the Server Access logs for hits on the Endpoint mentioned in WP Zombaio settings.

    And check the Zombaio Dashboard, it’s home page should list the notifications sent and what the result and ping time was (left hand widget/box on the dashboard)

    Is the “paid up member” using a different email address to the admin user account? As if it’s the same the user won’t create.

    Plugin Author Barry Carlyon
    Member

    @barrycarlyon

    ok i am just going to uninstall wordpress and create a new database and start all over idk what else to do at this point no one seems able to help and there are no details anywhere on the web about this happening to others so it must just be me and starting over will hopefuly solve the issue idk

    I don’t think a New WordPress install will solve your issue. But it will at least give a clean basis to work from

    crh1982
    Participant

    @crh1982

    ok i have unistalled nd will reistall everything yes i had it in test mode as that is the only way to test it i will let you know if the new installation has fixed the issue and if not will also let you know i am at the point that i didnt know what else to do being as i have tryed t all and no success but cross my fingers new everything will help thank you and didnt mean to be impatient but this is driving me crazy 🙁

    Plugin Author Barry Carlyon
    Member

    @barrycarlyon

    No problem on the impatient-ness.

    For testing in Test Mode, I suggest turning off the IPN Verification, which should allow the tests to go thru correctly.

    The IPN Verification, ensures that when a notification is received it comes from Zombaio and not someone pretending to be Zombaio.

    Test Mode may not come from a IP Address on the list of Notification IP’s.

    crh1982
    Participant

    @crh1982

    hi are you still around

    Plugin Author Barry Carlyon
    Member

    @barrycarlyon

    I am floating about, generally around all the time unless I’m a sleep.

    crh1982
    Participant

    @crh1982

    ok so i think i got it to work only thing is the members area is not locked idk is there a way i can give you site url and the test username and password

Viewing 15 replies - 1 through 15 (of 51 total)
  • The topic ‘[Resolved] Zombaio plugin Problem’ is closed to new replies.