Support » Plugin: Lead Form Data Collection to CRM » Zoho CRM EU account

  • Resolved wime

    (@wime)


    Hi,

    I’ve been trying to get CRM WordPress Leads to connect with my Zoho CRM account (Professional Edition). I keep getting the same error “Warning verify your username and password”.

    In the plugin file /lib/SmackZohoApi.php I changed the zohocrmurl from “https://crm.zoho.com/crm/private/xml/” to “https://crm.zoho.eu/crm/private/xml/” in order to accomodate the server changes. I am generating the Auth Token with the .eu domain.

    However I still keep getting that error. Any ideas?

    • This topic was modified 3 years, 2 months ago by wime.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Got it, apparently the variable $zohocrmurl is not used globally and in the same php file there are some more hardcoded urls who need changing too.

    Now I get a success message after saving the CRM settings. Since the OK button is not clickable, after pressing Enter and changing to WP Users Sync tab I get “Please configure your CRM in the CRM Configuration to configure WP User Sync”. Even though I succeeded in the login.

    Any ideas?

    • This reply was modified 3 years, 2 months ago by wime.
    Plugin Contributor Smackcoders Support

    (@smacksupport)

    Hi wime,

    I believe you also made the URL changes on the templates/SaveConfigHelper.php too. Have you got the Success message of Leads synced and Users module synced. It may took some time to check for the credentials. These messages will appear on the top right corner of the page. Just wait after clicking on Save CRM Configuration till the message shows and then try the other pages.

    I have made the changes in templates/SaveConfigHelper.php. I still get the “Success Settings saved successfully” message after saving. I did not get the Contacts/Leads sync success message.

    But when I try to access the other tabs I get this message: “Please configure your CRM in the CRM Configuration to configure WP User Sync”.

    • This reply was modified 3 years, 2 months ago by wime.

    Hi there,

    Has anyone had success solving this? I am having the same problem.

    It seems to be linked with Zoho properly however when I click on ‘CRM Forms’ it displays ‘Please configure your CRM in the CRM Configuration to create Forms’

    Regards
    Ross

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Zoho CRM EU account’ is closed to new replies.