• Resolved petervdeynde

    (@petervdeynde)


    Hello,

    I’m trying to install a wordpress website from a Duplicator package on XAMPP 8.2.0

    When I run the installer.php script the resulting install window gives an error:

    ZipArchive and Shell Exec are not enabled on this server please talk to your host or server admin about enabling ZipArchive or Shell Exec on this server or manually extract archive then choose Advanced > Manual Extract in installer.

    Indicating SHELL EXEC is not enabled in the PHP running with this version of XAMPP.

    However, when I inspect the php.ini file the variable disabled_functions is empty, meaning that shell_exec is not disabled. Still the installer can’t find it.

    Any clue on how to resolve this issue?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support mohammedeisa

    (@mohammedeisa)

    Hi @petervdeynde ,

    Please check this Stackoverflow post:
    https://stackoverflow.com/questions/12757891/enable-shell-exec-in-wamp-server

    Besides disable_functions , please check the value in safe_mode_exec_dir and make sure that you run XAMPP as an administrator.

    Did you give the DupArchive option a try?

    Thread Starter petervdeynde

    (@petervdeynde)

    Thank you for your response.

    I had already tried the solution in that Stackoverflow article, but it didn’t work.

    No functions were disabled at disable_functions either.

    But the Dup-archive option did work, so thanks for that.

    Only pity I can’t use this for a large website. Or I have to buy the premium version of course.

    But in any case thanks for the solution.

    Plugin Support mohammedeisa

    (@mohammedeisa)

    @petervdeynde

    I’m glad you are able to resolve the issue.

    If your website is larger than 512MB, you need to user Duplicator Pro.

    Hi @petervdeynde,

    You don’t need to buy the Pro version.
    You can do everything with the Free version.
    Support doesn’t want to tell you this (guess why)!

    Enable ZIP in XAMPP

    XAMPP v8.2.00
    Source: https://stackoverflow.com/questions/30558950/ziparchive-not-installed-in-xampp
    C:\xampp\php\php.ini

    Stop the xampp and then kindly remove the starting semicolon ( ; ) before ;extension=zip from your xampp/php/php.ini the following code, and start xammp again. Detailed:

    Find (line 952, v8.2.00):
    ;extension=zip

    replace with:
    extension=zip

    Duplicator / Settings

    Duplicator > Settings > Packages

    SQL Mode: Mysqldump
    Archive Engine: ZipArchive

    Backup / Export with Duplicator

    Packages
    Archive
    [X] Enable File Filters

    Folders: (check checkbox)
    [wp-uploads] (click at)
    C:/xampp/htdocs/YOURWEBSITE/wp-content; (shorten to this)

    Restore Backup with Duplicator

    1. upload to server: Archive file (.zip), Installer file (.php)
    2. unpack “wp-content” zip content
    3. run installer
    4. follow the instructions

    That’s all. Let me know the result.

    I first used XAMPP v7.4.29. I then upgraded to v8.2.00. I faced the same problem as you now. I solved it this way.

    MY ADVICE: go back to XAMPP v7.4.XX. It’s not time for v8.2.00 yet. You will face a lot of problems – not all Themes and Plugins are compatible with v8.2.00, with v7.4.XX they all work without problems. ZIP is included by default in older XAMPP versions. Give up on time. Be smart.

    Have a nice day. Regards,

    Thread Starter petervdeynde

    (@petervdeynde)

    Hello @vipteam,

    Thank you very much mate. This was very helpful. This method totally fixed my problem.

    Have a good day!

    • This reply was modified 1 year, 2 months ago by petervdeynde.
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘ZipArchive and Shell Exec are not enabled on this server’ is closed to new replies.