DB Toolkit
[resolved] Zeros for text-fields (4 posts)

  1. --Ever--
    Posted 2 years ago #


    I created form with single text fields and I get zeros in database.
    Tried another form with integer and date and it works fine.
    Why I get zeros in database for single text fields?


  2. heineko
    Posted 2 years ago #


    I ran into the same issue when I was using DB Toolkit for the first time.

    If you INITIALLY create the fields wrong (e.g. create a text field as an integer) DB Toolkit cannot fix it for you, even if you change it and save again.

    To correct this you need to have database access - MySQL, phpMyAdmin, something like that. Then you can open the database and correct the field types.

    I hope that helps!!

  3. --Ever--
    Posted 2 years ago #

    Works now.
    Thank you.

  4. David Cramer
    Plugin Author

    Posted 2 years ago #

    @heineko thanks for the help.

    Glad you got it sorted.
    The reason for not allowing the field to change the data type is in the event of changing a field on a table with entries could loose data.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic


No tags yet.