Support » Plugin: Comet Cache » Zend OPcache API is restricted

  • Hi,

    recently I get a lot of errors like this in php_error.log:

    PHP Warning: Zend OPcache API is restricted by “restrict_api” configuration directive in /data/web/e48437/html/mywebsite/wp-content/plugins/comet-cache/src/includes/closures/Shared/SysUtils.php on line 85

    how can I get rid of this?

    https://wordpress.org/plugins/comet-cache/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Raam Dev

    (@raamdev)

    @ak71 Thank you for the report. I’ve opened a GitHub issue here so that we can improve this: https://github.com/websharks/comet-cache/issues/733

    Hi Raam,

    in php_slow.log are a lot of these entries as well:

    13-Apr-2016 23:12:12]  [pool e48437] pid 2015
    script_filename = /data/web/e48437/html/my-website/index.php
    [0x00007feffaaf5468] flock() /data/web/e48437/html/my-website/wp-content/plugins/comet-cache/src/includes/closures/Shared/CacheLockUtils.php:47
    [0x00007ffdf07198e0] WebSharks\CometCache\{closure}() unknown:0
    [0x00007feffaaf52e0] call_user_func_array() /data/web/e48437/html/my-website/wp-content/plugins/comet-cache/src/includes/classes/AbsBaseAp.php:55
    [0x00007ffdf0719e30] __call() unknown:0
    [0x00007feffaaf50c8] cacheLock() /data/web/e48437/html/my-website/wp-content/plugins/comet-cache/src/includes/closures/Plugin/InstallUtils.php:341
    [0x00007ffdf071a470] WebSharks\CometCache\{closure}() unknown:0
    [0x00007feffaaf4f00] call_user_func_array() /data/web/e48437/html/my-website/wp-content/plugins/comet-cache/src/includes/classes/AbsBaseAp.php:55
    [0x00007ffdf071a9c0] __call() unknown:0
    [0x00007feffaaf4db8] addAdvancedCache() /data/web/e48437/html/my-website/wp-content/plugins/comet-cache/src/includes/closures/Plugin/InstallUtils.php:247
    [0x00007ffdf071b000] WebSharks\CometCache\{closure}() unknown:0
    [0x00007feffaaf4c28] call_user_func_array() /data/web/e48437/html/my-website/wp-content/plugins/comet-cache/src/includes/classes/AbsBaseAp.php:55
    [0x00007ffdf071b550] __call() unknown:0
    [0x00007ffdf071b900] checkAdvancedCache() unknown:0
    [0x00007feffaaf4a50] call_user_func_array() /data/web/e48437/html/my-website/wp-includes/plugin.php:525
    [0x00007feffaaf48a0] do_action() /data/web/e48437/html/my-website/wp-settings.php:393
    [0x00007feffaaf4770] +++ dump failed
    Plugin Author Raam Dev

    (@raamdev)

    @ak71 I’m not sure what those are about (the log entries don’t really provide enough information), but it looks like those are all related to PHP Closures.

    We just migrated the Comet Cache codebase to PHP Traits (which are a bit newer, faster, and easier to maintain) and the next release of Comet Cache (coming out tomorrow most likely) will have the newer PHP Traits in the codebase.

    If you’d like to download the release candidate that was released a few days ago and includes PHP Traits and start using that now, see https://cometcache.com/blog/comet-cache-v160412-rc-release-candidate/

    I’m using Stable tag: 160417 with WP core all up to date and still get this:

    [27-Apr-2016 06:25:16 UTC] PHP Warning: Zend OPcache API is restricted by "restrict_api" configuration directive in /data/web/e48437/html/my-website/wp-content/plugins/comet-cache/src/includes/traits/Shared/SysUtils.php on line 92

    Plugin Author Raam Dev

    (@raamdev)

    @ak71 We have a GitHub issue open for the restrict_api issue; please see https://github.com/websharks/comet-cache/issues/733

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Zend OPcache API is restricted’ is closed to new replies.