Support » Fixing WordPress » Zend Gdata Fatal Error Uncaught Exception

  • A short while ago I was manually editing a group of just under one hundred blog entries on my WordPress blog, by adding a stylized horizontal rule to all of the posts.

    About two thirds the way through the job, after hitting the update button on the post page, I was suddenly presented with the following error. I’ve removed the exact URL’s for obvious reasons:

    Fatal error: Uncaught exception ‘Zend_Gdata_App_HttpException’ with message ‘Expected response code 200, got 400 Blog has exceeded rate limit or otherwise requires word verification for new posts’ in /path-to-php/lib/php/Zend/Gdata/App.php:709 Stack trace: #0 /path-to-php/lib/php/Zend/Gdata.php(219): Zend_Gdata_App->performHttpRequest(‘POST’, ‘…’, Array, ‘<atom:entry xml…’, ‘application/ato…’, NULL) #1 /path-to-php/lib/php/Zend/Gdata/App.php(900): Zend_Gdata->performHttpRequest(‘POST’, ‘…’, Array, ‘<atom:entry xml…’, ‘application/ato…’) #2 /path-to-php/lib/php/Zend/Gdata/App.php(975): Zend_Gdata_App->post(Object(Zend_Gdata_Entry), ‘…’, NULL, NULL, Array) #3 /path-to-blog/Blog/wp-content/plugins/gdatablogger.php(128): Zend_Gdata_App->insertEntry(Object(Zend_Gdata_Entry), ‘…’) #4 /path-to-blog/Blog/wp-content/plugins/gdatablogger.php(81): gdata->gdatacreatePost(‘ in /path-to-php/lib/php/Zend/Gdata/App.php on line 709

    I am not a PHP guru, and I have absolutely no idea what this means, or what I need to do in order to fix it. It just suddenly happened out of the blue.

    I tried editing the same post several times, and kept getting the very same error message upon hitting the update button.

    After that, I tried two other posts, and the very same thing occurred.

    Thinking that it might just be a temporary freakish occurrence, I shut down the server and rebooted the machine that it is hosted on. I also shut down Firefox 4.0 and rebooted it as well.

    Despite the above actions, the very same problem continues to occur.

    In fact, when I tried to make a new post, the very same error message appeared as well.

    I assumed that as a result of this error, the changes were not being saved, and the new post was not being posted.

    However, to my surprise, I just discovered that the changes were being saved, and the new blog entry was posted as well.

    Obviously, I cannot keep operating with this error message occurring; so if someone more knowledgeable than myself can inform me what this error means, and what I must do in order to correct it, I would be most appreciative.

    I am running WP 3.1.1 under Mac OS X Tiger 10.4.11 on an old Macintosh G4 mini-tower.

    Thanks in advance.

  • The topic ‘Zend Gdata Fatal Error Uncaught Exception’ is closed to new replies.