Support » Plugins » Zemanta slows down or /stops posts saving

  • I find that having Zemanta installed always slows down the save of a post, and sometimes delays it indefinitely. It gets to around 95% saved, then hangs there for anything from a minute to ten.

    This has been going on ever since I starting using Zemanta, and occurs on multiple blogs of mine. The current blog it is still; bluelining on as I write has hardly any other plugins installed and has only 4 posts – and there is the blue line.

    If I disable Zemanta, it all saves fine again.

    Anyone come across this – or any ideas please.

    Many thanks.


Viewing 7 replies - 1 through 7 (of 7 total)
  • Hey there!

    This sounds like a nightmare. The last thing we want to do is slow your blogging down. Sorry for that. There’s obviously a bug somewhere.

    Could you let us know which browser this is happening in? (Firefox, Chrome, Internet Explorer, …) Have you tried any other browsers besides your primary one? Does the same thing happen?
    Also, which version of are you using?

    This really helps us a lot. Thanks!


    Hey Rok

    Thanks for your concern, empathy, and fast comment. UR right – it is a real pain, as I am full time in IM, and I might edit dozens of posts in a day. Anyway, your response made me do a bit of testing, which revealed a few things.

    First, yes, Zemanta does slow down browsers – for me, FF and IE. Second, there appears to be a plugin conflict on FF which slows it down even more – almost to a halt sometimes.

    FYI, here are my plugins:

    On to my testing. With plugins enabled I noticed that Z often stumbles when looking for the editor. It displays: “Finding editor…”, then quite often, “Gave up on finding editor. Retry.” This could still be hanging 3 or more minutes later. The FF bottom bar is reading “read” all this time. This happens frequently to me.

    So, step 1 was to disable all FF addons. I did this.

    The remaining tests were done:

    1. FF (no addons) with Z
    2. FF (no addons) w/o Z
    3. FF with addons and w/o Z
    4. IE with Z
    5. IE w/o Z

    Results, in seconds until either Z displayed images, or (w/o Z) blue bar completed:

    1. 21,12,20,18,14,18
    2. 10,8,10,12,9
    3. 10,9,8,7,11
    4. 28,16,30,15,16
    5. 8,6,6,7,7

    It is pretty clear to me that Z slows down IE and FF at least for me – FF takes nearly twice as long to save, IE 3 times as long. In addition, it conflicts with one or more of my addons to compound the issue. I will have to find out which one.

    **My Computer** – I am running:
    Pentium quad core
    4 x SDDs in parallel with RAID 1
    8 meg RAM
    Windows 7 64 bit
    FF 3.6.16
    IE 8.0.7600.16385

    In summary: thanks for making me check this – as I will now hunt down the offending addon! Once found, it will mean that I will at least be able to function with Zemanta. However, it is clear that it slows down browsing for me quite considerably.

    Hope this is constructive, and if I can help further, let me know here or, probably better, at malc (at)

    I think Zemanta is a great idea and I do recommend it to my students as well as using it myself. I hope you can resolve the reduction in browser performance, in which case I could recommend it even more heartily.



    Hey Malc!

    Sorry for being away.
    Thanks so much for this extensive test.

    I will contact you by email for follow ups on this.



    Hello Gents. I noted the messages in this forum thread after suspecting the Zamanta plugin of causing race conditions on my server. We had the Zamanta plugin enabled on our blogs for about 2 months. The race condition is defined as all memory resources, RAM and Swap are consumed. The load averages on my server jump to 32.0+ from a normal load of 0.4
    The issue appears to look like a potential infinite loop in PHP. The Linux server kernel will self-correct the problem, or perhaps the Apache server is automatically correcting it. The race seems to occur on the Post-Edit pages, on the 1st edit/save for the day. We have seen this issue occur sometimes 3 to 4 times in a 24 hour period. We have disabled the plugin for now. If the race condition occurs again, this will help identify and clear the suspicion of Zamanta being the cause. I will feedback in this case. Let me know if I can help provide other details that might be helpful to locate the problem.

    Update: Since disabling the Zamanta plug, our sites have still experienced resource consumption and system races. It is looking less like the culprit of our speed issues are related to the Zamanta plugin.
    We are considering now a potential loop in mod_rewrites in our Apache server as the source of our race issues. I apologize for the noise. We have no reason to believe the Zamanta plugin was the problem.

    Hi Rok – if you are still there. I have heard nothing further from you. And Zemanta is still make Save on the edit screen take forever on my blogs – 5 different blogs on 3 different hosts.

    Any progress on this?

    It does not take forever EVERY time. But when it does, I go off an do something for ten minutes, then when I come back it’s either finally saved, or I have to abandon my edit, diable Zemanta, then come back at which point it all saves fine. Or I open up a second login screen on the plugins page so I can disable Z without leavingt the edit screen.

    Nice plugin – but this aspect of it is a real pain.



    Hey malcsimm!

    Sorry that I couldn’t get to this faster.
    Would you be interested in having a short Skype call where you would show us how this happens, and we can maybe find the issue together. We can’t seem to replicate the issues on our own machines.

    Let me know. You can just add me on Skype, my handle is rok.pregelj


Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Zemanta slows down or /stops posts saving’ is closed to new replies.