Support » Plugin: Editorial Assistant by Sovrn » Zemanta not working

  • Resolved Rajat Sinha


    I am using zemanta now for a long time for my website. But suddenly today I realized its not working. On a Create-new-post page, the content recommendation sidebar doesn’t open. I don’t see any error messages either.
    Please help. I really love this plugin.

    P.s- I have been installing a few plugins previously, I am not sure if that maybe the case.

    My website: The Insight

Viewing 13 replies - 1 through 13 (of 13 total)
  • Hey, thanks for reaching out, I’ll gladly help!

    Are you sure you still have your ‘Editorial Assistant by Zemanta’ plugin installed and activated? If yes, go to your create-new-post page and look for the widget called “Content Recommendations” and see if it’s collapsed, by any chance. If it is, simply click on it to expand it back. Here’s a screenshot I made, for easier navigation:

    If this still doesn’t help, do send me a screenshot of your create-new-post page, so that I can have a closer look at it. Also — your list of installed plugins would also help me out a lot.

    Let me know how it goes, I’m eager to hear about the results! Take care & have a nice day!


    Thanks for the reply. Yes, I am sure to have Editorial Assistant by Zemanta installed. I went to the add new post page, and tried expanding the content recommendation tab, but it didn’t open at all.

    Here are the screen shots,
    Add new post:

    Hey, thanks for the screenshots, much appreciated!

    Before we proceed, may I ask you to try accessing your create-new-post page with another browser (Chrome, Safari, Firefox, etc.)? Which one are you using right now?

    Sorry for all these extra questions, but I’m suspecting that there’s an ad-blocker or some sort or a 3rd party script blocker that’s preventing our widget to fully load. If you would switch to a browser with no add-ons/extensions, I somehow hope the Zemanta widget should appear. That would confirm my suspicions, but I cannot be sure, to be honest.

    Do let me know how it goes, though, I’m eager to hear the results! Take care!


    Thank you for the reply once again.

    I fixed the problem. I was using Google Chrome. I stopped all the extensions to see if any of those were causing the problem, but no they were not causing the problem.

    Then I noticed a TRIANGULAR (defense) like sign just on the left side of the bookmark button. After I clicked on it, it said that the page contains scripts which are unsafe. Then I just checked on, show scripts and reloaded the page. Now its working fine.

    Much appreciate the work you people are doing. Thanks a lot for such an useful plugin. 🙂

    Hey, sorry for the late reply but I’m very glad you found your way around the problem, really! 🙂

    Also — you are always welcome to leave a vote or a review about us on our plugin page on the WordPress website, if you find the time. It shouldn’t take you more than a minute (two, if you write something nice)! 🙂

    Here’s the link:
    [ Short link deleted and replaced with actual link. Again please do not use short links in these forums if you can avoid it. ]

    As always — if you have any questions or if you stumble upon any problems, do not hesitate to let us know! We’ll gladly help!

    Take care & have a nice day!


    Hi, I have the same problem. The Content Recommendation widget is not appearing. It was working for at least 2 years on our site but just disappeared. I tried on another browser and same thing. The plugin is activated and I can see the Zemanta dahsboard. But not the widget. Any suggestions?

    Hey davegrun,

    I assume you have already tried all of the above suggestions and none worked? You have not installed any new plugins/software what-so-ever? Would you be so kind and try to clear the browser data (cache). If this doesn’t help, please try reinstalling the plugin. Also, if you find the time, please send me a screenshot of your create-new-post page and your list of installed plugins.

    Take care & have a nice weekend!


    I have a similar problem, I see the widget it loads fine but when I click any of the content to link to nothing happens. I have used Chrome and Firefox, I don’t get any pop up blockers, it just doesn’t work.

    Are there any help pages on how this was finally solved? I have tried the recommendations listed above.

    Also when I click the preference button, it takes me to a page which “claims” to have mentioned me, on clicking through I am confronted with articles that have nothing to do with me or mention of me, am I missing something ???

    Hey, no worries, I’m sure together we’ll make it work, but in order to do so, we are going to need a bit more information on what’s going on — any chance you could send us the link to the blog in question, so we could have a closer look?

    We really need to know what we are dealing with in order to help you out. Any additional information will be more than appreciated!

    Let us know!

    Take care & have a nice day!


    I am facing styling issue with Zemanta.

    Suddenly the “Related Posts” recommendation styles stopped working.


    Article view:


    thanks for reaching out, I’ll gladly help. If I am not mistaken you are using a really outdated version of our plugin (2.6). Also, do you have more than one of our plugins installed? Whatever the case, please update the plugin to the latest version and the styling issue should be fixed. Also, don’t forget to save/remember your plugin settings just in case they get lost with an upgrade. It shouldn’t happen, but there have been issues with older versions – better to be safe than sorry!

    Let me know how it goes, take care and have a nice day,

    Thank you so much Petra!

    All the issues resolved after plugin update, thanks! 🙂

    You are welcome – glad to hear it works 🙂

    Happy blogging,


Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Zemanta not working’ is closed to new replies.