WordPress.org

Support

Support » Themes and Templates » z-index not working

z-index not working

  • Does anyone know why z-index does’nt work with the slider. I need to put something over the slider but it stays under no matter what.

Viewing 6 replies - 1 through 6 (of 6 total)
  • z-index will only effect elements that have a position attribute defined, i.e. relative, absolute, etc.

    The div id that I have associated to my shortcode has a relative position. Should that work? [promoslider id=”slider_01_pics” category=”slider-01″]

    WPyogi

    @wpyogi

    Forum Moderator

    Can you post a link to your site? It’s hard to help with CSS issues without seeing the site.

    Sure! The site is still under construction but here is the link : http://www.calvs.ca/index.php

    I want to place invisible images over the slider to act as links kind of like an image map would do. The image is a transparent png called invisible_link_btn.png. May not be the best way to do it but it is simple and it should work.

    WPyogi

    @wpyogi

    Forum Moderator

    Hmm, that’s kind of a strange set-up, but I looked at it and it may be that you need to assign the z-index to the images in the slider — not just the enclosing div.

    I know this is strange but as long as it works I am happy with it. I am not sure if I can assign css definitions to featured images. I will take a look but if you have any cue please let me know.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘z-index not working’ is closed to new replies.