Support » Plugin: Nimble Page Builder » z-index issue

  • Resolved saynom

    (@saynom)


    Hi!

    So, I don’t know if it’s related to customizr theme or not, but when I add a nimble menu I can’t go down in submenus dropdown, even if customizr menus are disable. The only way I found is to increase the padding/marging bottom of the header so that the submenus fit in (but it’s not a real solution). After some research I’m sure that’s a z-index issue so I tried to change header z-index value in customizr but it doesn’t seem to do anything. So it might be related to nimble.

    Is it a bug or am I bugging ?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Contributor Rocco Aliberti

    (@d4z_c0nf)

    Hi there,
    thanks for reporting this.

    I think we need some more info, e.g.
    where did you place this nimble menu?
    Are you using the Nimble page template?

    Can you share a screenshot which would allow us to recreate the structure of your page?

    Thank you!

    Hi Rocco,

    Thanks for your reply.

    So, it doesn’t matter if I use Nimble page template or customizr default template, the problem remains the same.
    Even if I set it to default template and enable remove menus in customizr it’s the same. Even if I keep the customizr template and change the z-index value in the general design settings of the header nothing changes.
    The menu is in my header.
    I don’t think there is a lot more to say. It’s pretty basic.
    The submenus dropdown looks like this after published but when I hover down, beyond the border of my header, the dropdown menu disappears. And we can see why if I put an image just below and go to Nimble’s editor. Hence the z-index issue assuption.
    It even goes under the social sharing icons of my footer when there is nothing on the page and the footer is therefore very close to the header.
    Thank you for your help. I really don’t know how to solve this.

    Oh and I almost forget to mention an other issue I encounter with the Nimble menu module. When I switch to mobile devices view, the module becomes blank, all my menu entries disappear. And I’ve tried the same tests and troubleshooting that I’ve done for the z-index issue with no luck.

    Plugin Contributor Rocco Aliberti

    (@d4z_c0nf)

    Hi there,
    I’m honestly unable to reproduce any of your issues on my local website :/
    https://imgur.com/a/V7YNkHT

    I guess you’ve already tried the troubleshooting steps also for these issues, right?
    Does the issue happen also switching to the parent theme or to a default WordPress theme like Twentynineteen?

    Hi Rocco,

    Thank you for your reply.

    That’s very strange…
    Yes, like I said I’ve done all the troubleshooting steps.
    The issue also happens in parent theme and default wordpress theme.

    I really don’t understand what is happening. :/

    Plugin Contributor Rocco Aliberti

    (@d4z_c0nf)

    Hi saynom,
    unfortunately without looking at your website I’m not able to understand what’s happening there either :/
    I’ve tried to reproduce the issue on my test website with no luck.
    I can only suggest you to inspect your page in order to find a solution:
    https://docs.presscustomizr.com/article/272-inspect-your-webpages-in-your-browser-with-the-development-tools

    Best

    Hi Rocco,

    That’s exactly what I was trying to inspect. I’ve checked/unchecked every boxes and I’ve eventually found the culprit . Submenus work as intended when these are unchecked (I still don’t know for the blank menus issue in mobile view though).
    So it seems to be related to the hover.css. However, if I try to remove it from css classes in appearance>menus and go back to the parent theme while emptying my browser cache, the issue remains…
    So I can’t fix this and I’m a bit lost… :/

    And again, thanks a lot for your help !

    EDIT: To be more specific, it only needs these 4 boxes unchecked to work properly.

    EDIT 2: FIXED! By setting this 2 lines like that in additional css:

    -webkit-transform: none;
      transform: none;

    Yay! But the mobile view of the menus is still blank
    (Sorry for the multiple edits and for these newbie issues…)

    • This reply was modified 4 months, 2 weeks ago by saynom.
    • This reply was modified 4 months, 2 weeks ago by saynom.
    • This reply was modified 4 months, 2 weeks ago by saynom.

    I’m making some progress about the mobile menu issue.

    I think I can’t see the hamburger icon due to its color.

    Before I changed its color.

    After I changed its color.

    I tried to modify this color value in theme’s custom css with no luck. And also, I don’t know how to add a “MENU” text to this hamburger button…

    Plugin Contributor Rocco Aliberti

    (@d4z_c0nf)

    Mobile menu issue:
    1) So basically you couldn’t see the hamburger button because the colors of the “lines” is black and you have a black background?!
    Thanks for reporting this, it must be addressed.
    2) “MENU” text next to the hamburger button: there’s currently no option to achieve that at the moment.

    Thanks!

    Hi Rocco,

    1) That’s it.
    Is there a way to change the hamburger button color?
    I guess not since you told that it must be addressed.
    2) Ok.

    Thanks for your replies, as always! 🙂

    Plugin Contributor Rocco Aliberti

    (@d4z_c0nf)

    Hi saynom,
    1) There’s no option in nimble to achieve that, so you need to write your custom CSS at the moment. :/

    Hi Rocco,

    ok, thank you!

    I think I can close this topic now.

    Keep up the good work ! 🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.