Support » Plugin: Yet Another Related Posts Plugin (YARPP) » YYarp not pulling in correctly

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author jeffparker

    (@jeffparker)

    I would recommend turning off YARPP from displaying on the home page, so that “Home” doesn’t show up as a related post.

    Also, turn on “Display results from all post types” in the “Relatedness” panel so that you don’t get only Pages listed on your non-post entries.

    That should give you a better mix.

    ok, thanks. I kind of got it going better by taking it off the homepage. but its pulling in pages when I only want it to pull posts.

    is there a way to have it only pull posts?

    Plugin Author jeffparker

    (@jeffparker)

    If that’s the case, I would recommend unchecking “Pages” from the “Display Options.” This will stop displaying related posts on Pages, but it will also not include Pages in any related posts.

    This might be your best solution.

    I have it checked to only show on posts. but it pull in pages on posts.

    I’m using YARPP Basic though. maybe thats causing issues.

    Plugin Author jeffparker

    (@jeffparker)

    Ok,then, contrary to what I recommended in my first response, please uncheck “Display results from all post types” in the “Relatedness” panel. This will only show Posts on Posts and nothing on Pages.

    I hope that is what you want.

    Have the same problem. Related posts will show only one at most, and not even the one I expect.

    I’m using the basic version.
    I only have “posts” checked.
    Only have a few posts on my demo site, but I gave them all two tags, all the same, and placed them all in 1 category as well.
    I want it to consider ‘at least 1 tag’, ‘consider category’ as well, and title and body are ‘don’t consider’.

    Played with the settings and I finally manageto get the widget to show a different post (still 1), it wouldn’t go away after I deleted all tags and categories form it.

    I’m lost. Any clues?

    Thanks!

    Plugin Author jeffparker

    (@jeffparker)

    Hi barbarbox. In the future, please create a new thread for a new question.

    If all your posts have the same tags and category, and titles and bodies are not being considered, then there’s no reason to expect one post should display more than any other.

    Make sure your match threshold is turned down to “1” until you see more results. Also, you can delete YARPP (not just deactivate), which will clear out database records, and then try reinstalling again. This might produce more results if something is not quite right with the data.

    Hi Jeff,
    Thanks for your reply!
    Treshold was set to 1 indeed. Sorry I didn’ tmention that or create a new topic.
    I have found another plugin that works for my and my site, so deactivated like you suggested.
    Thanks again.
    gr Bar

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘YYarp not pulling in correctly’ is closed to new replies.