Support » Plugin: W3 Total Cache » Yui compressor and Google closure compiler (Java) dont work with W3 total cache

  • Resolved kobby_w

    (@kobby_w)


    Hello,

    we have installed java and Yui compressor and Google closure compiler, but it does not work, we get errors.

    First we tried with Open Java 1.8
    Then we tested with Oracle Java 10.0.2

    The tests with Google closure compiler:
    Path:
    JAVA path: /usr/bin/java
    JAR path1: /usr/share/java/closure-compiler-v20180716.jar
    JAR path2: /usr/share/java/closure-compiler-v20171203.jar
    JAR path3: /usr/share/java/closure-compiler-v20161201.jar
    Testing result: Empty JAVA executable path.
    Dashboard message: JAVA executable path was not found. The default minifier JSMin will be used instead.

    The tests with YUI compressor:
    Path:
    JAVA path: /usr/bin/java
    JAR path1: /usr/share/java/yuicompressor-2.4.8.jar
    JAR path2: /usr/share/java/yuicompressor.jar
    Testing result:
    Minify_YUICompressor : $jarFile(/usr/share/java/yuicompressor-2.4.8.jar) is not a valid file.
    Minify_YUICompressor : $jarFile(/usr/share/java/yuicompressor.jar) is not a valid file.
    Dashboard message: YUI Compressor (JS): JAVA executable path was not found. The default minifier JSMin will be used instead.

    Can someone please help?

    Regards, Andreas

Viewing 12 replies - 1 through 12 (of 12 total)
  • I forgot:

    Server Centos 7.5. with PLESK

    bgdstr

    (@bogdanstratulat)

    The code checks if the executable file could be found, but that might fail if the permissions are not correct. If you are running safe mode, you might want to turn it off or include the path using safe_mode_include_dir. For more details check this page: http://www.php.net/manual/en/ini.sect.safe-mode.php

    The executable might also have incorrect permissions, which means that the user running PHP is not allowed to find that directory or file.

    Also, you may want to ping your server administrator and double check the installation of java and also, I tend to believe that the user running PHP doesn’t have the correct rights to execute the JAVA/YUI Compressor

    kobby_w

    (@kobby_w)

    We tried now again with another admin and we found out that there is a bug in W3 total cache plugin:
    We entered the path correct:
    Google Closure compiler:
    Path to JAVA executable: /usr/local/jdk-10/bin/java
    Path to JAR file: /usr/local/jdk-10/bin/compiler.jar
    and it does save the paths into:
    w3tc-config/master.php
    but does not work. W3 total cache cannot find the files.
    If we hardcode the paths in those files:
    plugins/w3-total-cache/Generic_AdminActions_Test.php
    plugins/w3-total-cache/Minify_Environment.php
    minify.yuijs.path.java
    minify.ccjs.path.java
    minify.yuijs.path.jar
    minify.ccjs.path.jar
    it works fine.
    SO IT IS A BUG IN W3 TOTAL CACHE.

    ->> Please correct the problem and provide an update for the plugin FAST, as we have paid for the plugin!

    Regards
    Andreas

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @kobby_w,

    Thank you for your update. We always encourage our users to provide us with any possible bug or an issue they are having as this can lead to improvement of the plugin.
    It is good to know that you have found the workaround for your issue.
    We need time to test it and look into it, and if we confirm the bug, it will be fixed in next releases.

    Plugin Contributor gidomanders

    (@gidomanders)

    Hello @kobby_w,

    Sorry for the inconvenience. We found an issue with the “Test YUI Compressor” button in the JS block on the Minify settings page. This issue will be fixed in the upcoming release.

    I tested the YUI Compressor and Google Closure Compiler with different versions of JAVA and it turns out, in my case, the JAVA executable path was not found. message came up when using JAVA 8, but not with JAVA 6. So your issue might be an incompatibility with the JAVA version. Could you please check if you still see the message when using another version?

    I also see some people having issues when there are multiple versions of JAVA installed on their system: https://github.com/yui/yuicompressor/issues/191
    Maybe you could search for other JAVA executables and remove all but the one you need.

    I have YUICOMPRESSOR 248 and JAVA 191 64.
    http://yui.github.io/yuicompressor/

    WordPress 5.0.1 :
    Errors will occur in the following files!
    —–
    wp-content\plugins\classic-editor\js\block-editor-plugin.js
    wp-content\plugins\css-javascript-toolbox\framework\js\ace\worker-javascript.js
    wp-content\plugins\css-javascript-toolbox\framework\js\ajax\cjt-server\cjt-server.js
    wp-includes\js\codemirror\jshint.js
    wp-includes\js\tinymce\plugins\link\plugin.js
    wp-includes\js\tinymce\plugins\media\plugin.js
    wp-includes\js\tinymce\plugins\media\plugin.js

    Plugin Contributor gidomanders

    (@gidomanders)

    @ujikioo You only list the files, but you could help us improve the compatibility with 5.0.1 a lot if you specify what errors occur. Thanks in advance!

    I am using the YUICOMPRESSOR JAVA JAR to check JavaScript syntax errors.
    This time I checked over 400 extensions JS and CSS files. (CSS does not do grammar check)
    I checked all extension JS files in WordPress.

    java -d64 -jar YUICOMPRESSOR.jar SAMPLE.js -o SAMPLE.min.js %CHARSET%

    When it executes processing, the grammar error is displayed in JavaScript reported as above, and the desired .min.js file was not output.
    I do not examine JavaScript source files with extension other than .Js.

    Plugin Contributor gidomanders

    (@gidomanders)

    @ujikioo Because those files are WordPress core and plugins we don’t control, you should contact the WordPress team and the plugin contributors to ask them to fix it. This is not related to our plugin.

    I made a content “By linking the JS and CSS and HTACCESS will Yumemiyo the world’s fastest!”
    and “WordPress 5.0.1 Syntax check result in YUICOMPRESSOR”.
    http://votre.space/htaccess/?#SyntaxError

    The plug-in notifies its developers,
    Do you know which forum to speak about the core part of WordPress?

    Plugin Contributor gidomanders

    (@gidomanders)

    @ujikioo I think this one would be where you can complain about the JavaScript grammar issues: https://wordpress.org/support/forum/requests-and-feedback/

    Thank you !!
    I made a comment at the “Syntax check result in YUICOMPRESSOR”
    https://wordpress.org/support/topic/syntax-check-result-in-yuicompressor/

    Thank you !

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Yui compressor and Google closure compiler (Java) dont work with W3 total cache’ is closed to new replies.