Support » Plugin: Two-Factor » Yubikey & Codes not working at specific domain

  • Resolved doublefile23

    (@doublefile23)


    This plugin worked like a dream until I migrated my site from a development site at a different domain to the current site. I have used the plugin for four months with no problems on several sites.

    Neither the Yubikey nor the back-up codes work at the current site. When prompted to touch the Yubikey (it is always inserted in my desktop), there is no response and I have to rename the plugin in cPanel’s File Manager to access the WordPress dashboard.

    I have deactivated and tested other plugins for conflicts at the development site. There was no problem accessing the site during the test at the development site. I then migrated the files to the current domain and no access.

    Are there known conflicts with themes? I’m using the Astra theme with a home page created with Elementor page builder.

    There are not many options for integrating Yubikey with WordPress. I found this plugin after experiencing problems with other plugins that were abandoned or very dysfunctional.

    I don’t want my login page unprotected. 2FA through Yubikey has worked for me for several years.

    Any suggestions?

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Kaspars

    (@kasparsd)

    U2F keys such as Yubikey are associated with the appId of each site, which is the hostname of your site. So after moving from a local development domain to a production domain all keys have to be registered again.

    The backup codes should work, though.

    Kaspars,

    Thanks so much! I failed to register the Yubikey in the Security Keys / register new keys section after I migrated the site.

    Lesson learned: skip a step and you are toast!

    • This reply was modified 5 months, 1 week ago by doublefile23.
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.