Support » Plugin: Easy FancyBox » Youtubelinks problem

  • Resolved Agramonis

    (@agramonis)


    Hi,

    I have a strange problem on my page Rafting.

    There are 3 Youtubevideos under Videos in the vertical navigation bar, that should open in a Fancybox.

    If I am on the main/homesite, it doesn’t work, but if you navigate to subpages and click on the vids, it works perfect.

    Can you give me an advice, what I could do?

    ty

    https://wordpress.org/plugins/easy-fancybox/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author RavanH

    (@ravanh)

    Hi, you are using the youtube.com/embed/ url which is an iframe source url instead of the youtube page url. Give each menu item a class fancybox-iframe to make it work or change the urls to those of the youtube page.

    Thank you for the fast answer, but the problem is another one.

    In the options of easy fancybox I have enabled Youtube and switched on Autodetect.

    This works well for every subpages on my page, look here:

    <subpage>
    subpage2

    If you stay on one of the subpages and click on videos, the video is opened in fancybox, how i want, from firebug the code looks like this:

    <a class="fancybox-youtube" href="http://youtu.be/4y19sGhdjFs" rel="fancybox">Rafting Tour</a>

    BUT:

    If I am on the mainpage Home fancybox doesn’t work for the vids, and the code is:

    <a href="http://youtu.be/4y19sGhdjFs" rel="fancybox">Rafting Tour</a>

    The class is missing only on the homepage and I don’t know why. I can’t but the class manually, because the link is created in wp-menu.

    Plugin Author RavanH

    (@ravanh)

    Ah, now I finally see what’s different. On the front page, the obligatory wp_footer() call is not made. Normally this is done in your themes footer.php (which seems to work on sub-pages) but this template file is probably skipped on the home page.

    Check your theme (home.php maybe?) or ask the theme’s devs 🙂

    Thx for the advice.

    I fixed it now myself and it works perfect. 😉

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Youtubelinks problem’ is closed to new replies.