Support » Plugin: Complianz | GDPR Cookie Consent » Youtube video’s not showing

  • Resolved bartjansen

    (@bartjansen)


    Hello,

    Iḿ having a problem with the youtube videos on my website. They are either not showing or way back on the page. I know there’s already a resolved issue with this problem but the solution didn work for me. Iḿ using the twenty sixteen theme with the latest version 1.7 of the plugin.

    Thanks in advance.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Support Aert Hulsebos

    (@aahulsebos)

    Hi Bart,

    We will have a look straight away!

    Regards Aert

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Hi @bartjansen
    This is caused by the specific way in which the Gutenberg editor handles vidoe.

    I have created a patch which should solve this issue.

    If you can check if this solves your issue that would be great:
    https://github.com/rlankhorst/complianz-gdpr

    You don’t need to upload the node_modules folder.

    If you’re not comfortable with uploading the files yourself, you can also await the next version, which we will release early next week.

    Plugin Support Aert Hulsebos

    (@aahulsebos)

    Hi @bartjansen,

    We added a patch for Gutenberg Video Blocks. It’s directly available via https://github.com/rlankhorst/complianz-gdpr or when the next update is due.

    Please contact us at complianz.io/support (in Dutch:)) if you need any help,

    Regards Aert

    Hi,

    This breaks the previous adjustments for iframe …

    I think there may be an error in cookieconfig:

    //reset video height adjustments, but not for elementor
    if (!$(this).parent().hasClass('elementor-wrapper') && !$(this).parent().hasClass('wp-block-embed__wrapper')) {
    	$(this).height('inherit');
    }

    The accolades of if misses maybe.

    Regards.

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Hi @bonaldi,

    Good you checked.

    The accolades don’t need to be there, as it’s just one line.

    This line should run to reset the height of the container div, so it will inherit the height from the parent. But I’ve discovered that inheriting the height when Gutenberg or Elementor is enabled breaks styling. In that case the original height should be kept.

    For this reason, the height is reset when the parent does not have classes from Elementor or Gutenberg. Do you use Elementor or Gutenberg on your site?

    Does it work for you if you comment out this line?

    Hi Rogier,

    I put braces on and it works for me.

    No, I do not use Gutenberg or Elementor.

    Regards.

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Hm, that is very strange. If you test this:

            var t= true;
            if (t) alert('test');
    
            if (t) {
                alert('test2');
            }

    You will see it will both work. I don’t mind putting braces around it, but it does not seem to make any difference. Possibly something else has changed as well, or there was some caching issue?

    OK, I uploaded 2.1.8.1 and it works without braces.

    Maybe grandParent css change or persistent cache, I don’t know.

    Thanks.

    I activated Gutenberg, to test: it does not work.

    There is a problem with the padding-top 56.25%.

    You can check here : /mysite/rgpd-test/
    If you no longer have my url (confidential), I will send it back to you.

    I will investigate.

    Works if I change for:

    //gutenberg
    if (parent.hasClass('wp-block-embed__wrapper')) {
    	/*resetPadding = '56.25%';*/
    	parent.addClass('cmplz-clear-padding');
    }

    Because otherwise the padding-top is doubled: FitVids puts 56,25% and the plugin also.

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    With Gutenberg, Fitvids should not really be necessary, as it will add responsive classes automatically.

    Without Fitvids, this padding is necessary to make the video’s show up.

    I will check if I can add the padding conditionally: not if Fitvids is enabled. The drawback is that there are getting too many conditions and exceptions in this code, which I don’t really like.

    Thanks for your answers Rogier en Aert, I’ll better wait untill the next release otherwise I might be ending up with a messed up website…

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Hi @bartjansen, we’ll keep you posted.

    @bonaldi Can you check if, where you commented out the resetpadding line, it works if you replace it with this, which only resets the padding when not fitvids.

    if (!jQuery.fn.fitVids) resetPadding = ‘56.25%’;

    Hi Rogier,

    I put your line of code online here: /mysite/rgpd-test/
    I leave it some time for you to test.

    Please, keep me informed.
    Thanks.

    As you know, many themes use Fitvids.

    If your extension does not comply with that, it will be a problem.

    Moreover, Gutenberg is not accepted by the whole community.

    So, in my opinion, you need to have both approaches together to spread your extension as well as possible.

    I realize that this involves conditional loops, but that’s the price to pay until Gutenberg is accepted by everyone.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Youtube video’s not showing’ is closed to new replies.