Support » Plugin: Complianz | GDPR Cookie Consent » YouTube videos don’t work since the update

  • Resolved izava

    (@izava)


    Desde la actualización de febrero (hace 2 días) no funcionan los vídeos de youtube. Antes funcionaban perfectamente. Ahora aparecen durante un segundo y después se queda el hueco del vídeo en blanco.

    He comprobado cada plugin y sólo desactivando Complianz | GDPR Cookie Consent vuelven a funcionar así que, de momento, he tenido que desactivarlo.

    ¿Cuál es la solución? Gracias por vuestra atención.

    ————-

    Since the February update (2 days ago), youtube videos do not work. Before they worked perfectly. Now, the videos appears for a second and then the blank video gap remains.

    I have checked each plugin and only disabling Complianz | GDPR Cookie Consent works again so, at the moment, I had to deactivate it.

    What is the solution? Thank you for your attention.

    • This topic was modified 5 months ago by  izava.
Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Hi @izava,

    Youtube videos should get blocked until the users consents to cookies, but should then have a placeholder image. If the video’s also don’t work if you accepted cookies, I’ll have to take a look at the site to see what the problem is. Can you post your domain here, or send it to us at https://complianz.io/support?

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    You can see an example of how it should work here:
    https://complianz.io/documentation/#toggle-id-5

    This is a youtube video, blocked until the user has consented to placing cookies.

    As you can see it works fine on https://complianz.io, so I’ll need to see your site to find out what the issue is.

    izava

    (@izava)

    Hi, Rogier. 😀

    It happens even accepting cookies. Instead of the video, only a blank space is shown. The warning does not appear inside the video, because the video is not appear.

    My website is: https://izaskunvalmaseda.com/. It is still in process, but I´m going to remove now the maintenance mode for you to see it.

    On this page, for example, there are two videos and they are not displayed. Previously, cookies have been accepted through your banner. It does not give the option to accept those of the video, because it is not seen.

    https://izaskunvalmaseda.com/portfolios/rigoletto/

    The same thing happens in this other page and in all the others where there are videos, even if you accept cookies through the banner.

    https://izaskunvalmaseda.com/portfolios/katia-kavanova/

    If I deactivate your plugin they are shown again.

    Thank you for your attention and apologize for my bad English.

    • This reply was modified 5 months ago by  izava.
    • This reply was modified 5 months ago by  izava.
    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    I see the issue. It looks like the cookie enabling script does not succeed in restoring the iframe src.

    When blocking, the plugin moves the video URL to data-iframe-src. When enabling, it moves it back to the iframe src, which enables the video. In your site the src is still a placeholder.

    It does work when you revoke the cookie consent, then refresh the page, then accept cookies.

    This makes me think it might be a conflict with lazyloading: looking at your code it looks like you have lazyloading enabled in your caching plugin. Disabling might resolve the issue.

    If you can confirm this is the cause I will dig into this and try to make it compatible with lazyloading.

    izava

    (@izava)

    I’ll see how I can do it and I’ll tell you something.

    I’m a newbie in WordPress and I’m learning from 0 on the fly!

    …data-iframe-src., iframe src…. you could speak to me in English or in Chinese! jajajajajaj ;-D

    Thank you, Rogier.

    izava

    (@izava)

    Hi again, @rogierlankhorst

    I do not know if I have done exactly what you asked for, but I guess that was the problem.

    What I have done:

    – Configured better my Pugin W3 Total Cache.
    – Uninstalled the a3 Lazy Load Plugin.
    – Lazy Load Plugin installed.

    … and it seems that it is solved.

    Thank you very much for your kindness.

    A fast and great support!

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Hi @izava,

    That’s great!

    Thanks for the update. If you have any other questions, let me know!

    Rogier

    Hello again, Rogier.

    After the last update, the same problem has happened again however, this time, it has not been solved with the steps I did.

    Any super-novice level solution?

    I also wanted to tell you that, every time I update your plugin, I have to redo the banner from the beginning… it´s deconfigured every update.

    Thanks for your attention.

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    hi @izava,

    I checked your site, but it’s in maintenance mode so I can’t really see what the issue is right now. Is there a way to see the site?

    As for the cookie banner, that is weird. As of 3.0 the cookiebanner settings are stored in a different, more robust manner, so maybe this will be solved by this change.

    Rogier

    Ok. Yoy can enter now.

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    I just tried, but still get the maintenance mode. Can you check again?

    Look, there must be some problem with my web or hosting, because today don´t work almost anything and the rest gives me problems… Aghhhh…

    I’m going to check everything and trust in the magic of the internet that solves everything alone! jajajajaj

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.