Support » Plugin: Publish To Apple News » YouTube Videos

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Kevin Fodness

    (@kevinfodness)

    How is the YouTube video at the top included in the post? Is it via a custom field that is included in the output via the template? If so, it will need to be added via a filter.

    The simplest method of including a YouTube video is by simply pasting the URL to the video on a line by itself in the post content, and the embed handlers will pick it up from there.

    If you attach the post content from the Text tab in the editor via a Pastebin link, I can investigate further.

    I’m having the same problem with the video posts on our web site, such as this one…

    https://whiskycast.com/taiwans-king-car-a-distillery-on-fire/

    My theme has a video format option that I’ve been using that includes the option to include the YouTube link under “Additional Options” – which formats the web page nicely, but publishing it to Apple News discards the video. I could change it, but would have to go back and delete the thumbnail “featured image” that I need to have the posts show up with an image on the category page. Saw the reference about “adding a filter” but am not familiar with how to do that…would appreciate any suggestions.

    Thanks!

    Mark

    • This reply was modified 3 years, 10 months ago by mpgillespie.
    Plugin Author Kevin Fodness

    (@kevinfodness)

    Hi @mpgillespie

    Can you send a screenshot of the editor page where you set the YouTube video? That would help me determine how it’s getting included and why Publish to Apple News is discarding it. Thanks!

    The system wouldn’t let me paste it in, but here’s a link:

    https://whiskycast.com/files/editor_screenshot.png

    Thanks!

    Mark

    I’m happy that the plugin works for few articles, but I have the same issue where articles having Youtube or other videos or basically iframe, I receive below error for example;

    There has been an error with the API: FAILED_TO_PARSE_IMAGE – Resource with URI [https://www.youtube.com/embed/YHDJ4EAnLgk?feature=oembed] is not a supported format.

    Article can be found here; http://dontboreus.com.au/used-drop-new-song-announce-album/

    I appreciate for any sort of help.

    Thanks.

    Plugin Author Kevin Fodness

    (@kevinfodness)

    @mpgillespie—The YouTube URL is being included via your theme, which is why Publish to Apple News can’t see it and include it in the content. Publish to Apple News only sees what’s in the content editor box by default. If you want to add the YouTube video to the content that is being published to Apple News, you will need to use one of our filter hooks to prepend it. I would recommend apple_news_exporter_content_pre:

    https://github.com/alleyinteractive/apple-news/wiki/Action-and-Filter-Hooks#adminapple-actionsindexclass-exportphp-1

    Plugin Author Kevin Fodness

    (@kevinfodness)

    @sachinpatelssm

    Are you using oEmbeds for YouTube or another method? The plugin is designed to work with WordPress’ oEmbed system, where you paste the YouTube URL on a line by itself and let WordPress handle conversion for you. The plugin does not handle iframes, and Apple News Format only supports YouTube and Vimeo web video embeds.

    If you’d like me to take a further look into your specific case, please follow the instructions here: https://github.com/alleyinteractive/apple-news/wiki/usage#getting-help

    Plugin Author Kevin Fodness

    (@kevinfodness)

    Closing due to inactivity.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘YouTube Videos’ is closed to new replies.