WordPress.org

Forums

YouTube Embed
[resolved] YouTube video shows above my FancyBox images (2 posts)

  1. Whitenorthstar
    Member
    Posted 2 years ago #

    Your plugin has been working well for me, thank you! However, I'm having a minor issue with it.

    It looks fine on Firefox and Chrome, but in Internet Explorer 10 and Safari, my YouTube video's (when they are playing or finished playing), always render on top of my FancyBox lightbox when I pop out my images.

    As you'll be aware, setting the z-index won't work. I've tried adding 'wmode=opaque' and 'wmode=transparent' to the YouTube URL. This works, but only before the video is played. Once the video is playing, or has completed playing, it will always show through the popped out images.

    Please can you guide me? :)

    http://wordpress.org/extend/plugins/youtube-embed/

  2. Whitenorthstar
    Member
    Posted 2 years ago #

    Sorry, I couldn't get Vixy to work properly... however, by deleting Vixy and using an iframe with some of the settings below, I was able to customize my video enough (fading controls, white progress bar)... and setting wmode to opaque... I was able to get FancyBox and my YouTube videos to display properly on all browsers:

    <iframe width="237" height="133" src="http://www.youtube.com/embed/sOi04BRQI1k?rel=0&showinfo=0&color=white&autohide=1&fs=1&vq=hd720&wmode=opaque" frameborder="0" allowfullscreen></iframe>

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • YouTube Embed
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic