Viewing 7 replies - 1 through 7 (of 7 total)
  • I got that problem too. Youtube video is nor working on mobile devices. I’ve tried youtube embed code and different plugin for embedding and it worked. So is not a youtuve problem. I must say that everything worked fine a couple days ago, I changed nothing but now I have such problem. I tried to remove all parameters in shortcode and plugin settings, but it didn’t work.

    Plugin Author Nico

    (@nico23)

    @DEVIDHENAFF

    From a short look a am 99% your issue is due to 3rd party code intervening. You iframe src is neither parameter free nor youtube-nocookie.com like its done by this plugin.

    @gopnik READ!

    You missed 3 links.

    1. On the plugins main ‘description’ page there is a ‘How to report a problem’ link.
    2. On the FAQ the very first entry answer is: ‘Please read Reporting Issues for Advanced Responsive Video Embedder’ – linked.
    3. When you come to the WordPress support forum there is a yellow sticky thread ‘For support please visit community.nextgenthemes.com’ at the very top. People ignore it continuously. Inside this thread there is the 3rd link.

    Still people keep posting bad and unwanted reports on this forum over and over again. But it gets worse. Some people actually find their way to my support site and they click on ‘Ask Question’. There is this text on the very top of the form: ‘Make sure to follow the instructions here carefully before posting a support question for ARVE’ with the 4th link to the same page. And still they ignore it and post questions without the basic information.

    Then there are the people who actually read it, or at least parts of it, then come back to the forums here and post anyway.

    I am fed up with this, its just pure ignorance!

    So here once again the link –
    Reporting Issues for Advanced Responsive Video Embedder
    . Follow it!

    I reserve the right to mark any question asked in this forum as ‘no support question’ or ‘resolved’ and to delete every support question on my site that is not giving me the information I need. I request a little bit reading and effort from people who request free support. I am also obviously not doing this to annoy people, I am doing this so I can actually see the HTML output in peoples sites so I can actually help. Also to detect compatibility issue right away because there are very very often.

    Obviously not every question needs all the info I ask for, but thats op for everyone to figure out themselves.

    Also people continue to use the plugin rating system to bug reports and the wordpress.org rules/moderators and not doing anything about it. Its much worse on other plugins I have seen.

    Yes, it seems a lot of people are having this problem. It comes of using embeds from “//www.youtube-nocookie.com” rather than “//www.youtube.com”. For the time being I seem to have solved the problem on my site by using

    add_filter( 'the_content', 'nocookie_rewrite_url', 100 );
    
    function nocookie_rewrite_url($URL) {
      $URL = str_replace( '//www.youtube-nocookie.com/', '//www.youtube.com/', $URL );
      return $URL;
    }

    in my functionality plugin (you could just add it to a theme’s function.php). It’s a bit kludgy, but it will probably work until YouTube gets this sorted out. If anyone has a more elegant solution, let us all know.

    Alex

    Plugin Author Nico

    (@nico23)

    @agkezak

    This might be the case for others having this sort of issue, as for DAVIDHENAFF site its actually not the -nokookie URL.

    I think your solution is just fine, just inside a custom-plugin or mu-plugin would probably be better then functions.php

    I actually think its great from YT to give a bit more private embed solution, but they should make it work like the normal one.

    Looks like I need to switch to a normal URL for the time being. Keep looking out for a update.

    Thanks for your answer, I really read your FAQ’s. I have the same issue like many others, so I think you have already dealt with that.

    I found somethig at help forum and this worked for me.

    This is a CORS problem between youtube-nocookie.com and youtube.com. If you manually embed the movie using “Enable privacy-enhanced mode” it generates an iframe on youtube-nocookie.com and this is not working (but it was working some days ago). On the other hand, if you don’t select “Enable privacy-enhanced mode”, the generated iframe points directly to youtube.com, therefore it doesn’t have any CORS problem.

    The TEMPORARY solution, before Google fixes the problem, is to manually update the file class-advanced-responsive-video-embedder-public.php and modify the base url for youtube from “//www.youtube-nocookie.com/embed/” to “//www.youtube.com/embed/”

    Thanks for your answer, I really read your FAQ’s. I have the same issue like many others, so I think you have already dealt with that.

    I found somethig at help forum and this worked for me.

    This is a CORS problem between youtube-nocookie.com and youtube.com. If you manually embed the movie using “Enable privacy-enhanced mode” it generates an iframe on youtube-nocookie.com and this is not working (but it was working some days ago). On the other hand, if you don’t select “Enable privacy-enhanced mode”, the generated iframe points directly to youtube.com, therefore it doesn’t have any CORS problem.

    The TEMPORARY solution, before Google fixes the problem, is to manually update the file class-advanced-responsive-video-embedder-public.php and modify the base url for youtube from “//www.youtube-nocookie.com/embed/” to “//www.youtube.com/embed/”

    Thank you and sorry for posting in the wrong place my message …

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Youtube video gives error on Mobile’ is closed to new replies.