WordPress.org

Support

Support » Plugins and Hacks » OGraphr for WordPress » [Resolved] Youtube Thumbnail Not Working

[Resolved] Youtube Thumbnail Not Working

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author idleberg

    @yathosho

    1. is the trigger for youtube enabled? in some rare cases, the plugin will launch with no settings enable. in this case, it’s recommended to use the “restore default settings” at the bottom of the settings page

    2. have you previously posted the same video on facebook? could the page be cached without thumbnail?

    3. does the thumbnail show up in the source-code?

    Hi there Yathosho.
    Thanks for the responde.

    1 – Yes, is enabled and I´ve tried to restore the default settings as well.
    2 – No, never posted.
    3 – No.

    :´( ..

    PS: Check the Facebook degub results: https://developers.facebook.com/tools/debug/og/object?q=http%3A%2F%2Fwww.topradiosbrasil.com%2F%3Fp%3D1404

    Plugin Author idleberg

    @yathosho

    hm, i wonder what it could be. can i have a look at the settings you’re using (screenshot of the advanced settings)?

    also can you enable the debug-mode (you’ll have to edit the plugin file), then load a page and take a look at output in the html source?

    Plugin Author idleberg

    @yathosho

    also, does this only happen with youtube videos? have you tried vimeo or any other support video player?

    Hi there Yathosho.
    Could this be a conflict with other plugin? Those are the ones I have installed:

    – Contact form 7;
    – Social Sharing Toolkit;
    – Tweetily;
    – Very Simple Google Analytics;
    – WordPress Download Monitor;
    – WordPress Importer.

    Here you can grab the screenshots of the advanced settings:

    http://dl.dropbox.com/u/521666/screen3.png
    http://dl.dropbox.com/u/521666/screen2.png
    http://dl.dropbox.com/u/521666/screen1.png

    How can I enable the debug mode? I´ve searched the plugin file content but didn´t found the option.

    The problem also happen with Vimeo posts.

    Regards.

    Plugin Author idleberg

    @yathosho

    i remember another user had an issue with social sharing toolkit installed, but it didn’t interfere with ographr when i tested it.

    the debug mode can enabled in /wp-content/plugins/meta-ographr/meta-ographr_index.php on line 33 (set it to TRUE)

    could you also state the php version running on your server?

    The server is running PHP version 5.2.17.

    Here is the result of the debug:

    OGRAPHR v0.6.14 DEBUGGER
    Image Retrieval: On-Post
    Last indexed on 2012-05-03, data never expires
    Avatars are filtered
    Emoticons are filtered
    Empty post-meta, using On-View fallback
    Processed in 0.009931 seconds

    This result is the same for ALL my posts.

    Plugin Author idleberg

    @yathosho

    i really appreciate your patience going through this, i hope i can find the issue and solve it

    could you try and edit any of your posts (without actually changing anything) and save it. if that doesn’t change anything, set the plugin to On-View (Image Retrieval -> Everytime your site is visited) and see if that changes anything.

    No, I appreciate your attention. I´ve tried other solutions with the same error but no dev has replied my question.

    And see, I run a website that has planty of video clips and I need more and more likes in my Facebook fan page.

    Visual mathers more than anything and my posts without the correct thumbnail really bothers me.

    I´m pretty sure that I can gain a lot more visitors and likes I my posts works like they are supposed to be.

    Thanks in advance.

    Plugin Author idleberg

    @yathosho

    did you try my last two suggestions? if other plugins didn’t work for you, do you have any idea if your server settings could prevent this from working?

    Hi there. I tried now the things that you suggested.

    1 – Only saving the post without change anything didn´t affect anything. The error persist.
    2 – Changing the plugin setting on-view to ‘everytime your site is visited’ didn´t affect the Facebook Debug result BUT changed the result when trying to make a new post direct thru Facebook.

    Now with the new option, if I grap the post link and try to post on Facebook, it gives me the chance to select 8 thumbnails instead of only one without the option.

    BUT, none of this thumbs are related to the video of Youtube. Most are gifs and jpegs from social networks I have in my site.

    3 – I don´t have any idea if my server settings is preventing this from work.

    4 – I tried to use the Fedmich plugin but it also didn´t work.

    :'(

    Regards.

    Plugin Author idleberg

    @yathosho

    think i might have found the problem, hold tight

    Plugin Author idleberg

    @yathosho

    please try the following

    1. download this updated version
    2. extract it to your current meta-ographr directory
    3. enable debug mode
    4. reload page, view source

    i think your webhoster might have disabled curl support, looking at the debugger will answer that. i’ve already implemented an alternative way to the upcoming version, but i wanted to make sure your problem is caused by that.

    Hi there Yathosho, very exciting news.

    Here is the debug result:

    – OGRAPHR v0.6.14.1 DEBUGGER
    – Image Retrieval: On-View
    – cURL function exists, disabled by user
    – Avatars are filtered
    – Emoticons are filtered

    But according the PHPInfo I uploaded to my server, cURL is actually enabled:

    – cURL support: enabled
    – cURL Information: libcurl/7.15.5 OpenSSL/0.9.8b zlib/1.2.3 libidn/0.6.5

    Plugin Author idleberg

    @yathosho

    that’s too bad, i was hoping that was it

    okay, i guess we you have to enabled wordpress debugging to give me some more insights.

    1. make sure to enable WP_DEBUG and WP_DEBUG_LOG,
    2. create a new post with embedded video (or edit an existing one)
    3. show me the relevant part of wp-content/debug.log

    i’m not sure, whether the debug.log can reveal sensitive data, so please be careful about what you post!

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] Youtube Thumbnail Not Working’ is closed to new replies.
Skip to toolbar