Support » Theme: Themelia » Youtube problem

  • Resolved 200

    (@200-1)


    When I put the youtube videos to the page. The page shows very large blank.
    When i check the code: <iframe width=”1280″ height=”960″ src=”https://www.youtube.com&#8221; frameborder=”0″ allowfullscreen></iframe>

    The height is 960, too high, how to change it to fit the page size, like 485?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Theme Author Dario Devcic

    (@dariodev)

    Theme code has nothing to do with how youtube video is being displayed. If you post an url with the issue I may propose a solution. I’ll try a wild guess, maybe you have some plugin installed which alters iframe.
    Possible solution – try install https://wordpress.org/plugins/fitvids-for-wordpress/

    Thread Starter 200

    (@200-1)

    Yes, I use a plugin to show the videos.
    I tried several responsive-like plugins. No luck.
    I tried several themes. Only Themelia has the problem.
    Anyway, thanks.

    Theme Author Dario Devcic

    (@dariodev)

    Which plugin you are using for videos? I can take a look and try to propose a solution. In my previous message I mentioned FitVids. Just to explain, Themelia already use FitVids. I thought that maybe you are adding videos in some specific way so that the bundled FitVids does not work for you. But in fact it seems to be something else. Now I think that the plugin you are using is in conflict with FitVids bundled with Themelia. Otherwise, Themelia does not have problems with showing up videos. Here is example page with embedded youtube video http://preview.relishpress.com/themelia/sample-page/ko-hyojoo/ But of course, conflicts with certain plugins are always possible. If that’s an issue I would love to fix it.

    Theme Author Dario Devcic

    (@dariodev)

    Will you send a link where I can see the issue? Or just send the name of that plugin.

    Thread Starter 200

    (@200-1)

    It is a paid plugin. So I send you a email about the plugin through your site http://relishpress.com/contact/

    Theme Author Dario Devcic

    (@dariodev)

    OK, I found your email. Thing is that the plugin you are using has built in responsiveness for videos and is wrapping YouTube videos in div with class video-container. Same thing that FitVids script in Themelia does, but div has class fluid-width-video-wrapper. So video is ends up wrapped in two divs, both styled to enable responsive video.

    Now, I don’t own this plugin so I can’t tell which of these two is better to disable, but one of the following CSS snippets should help (add in the Customizer -> Additional CSS):

    
    .fluid-width-video-wrapper {
        padding-top: 0 !important;
    }
    

    or

    
    .video-container {
        padding-top: 0 !important;
    }
    
    Theme Author Dario Devcic

    (@dariodev)

    Hi, did you try using this CSS?

    Theme Author Dario Devcic

    (@dariodev)

    I suppose this is solved.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Youtube problem’ is closed to new replies.