Support » Plugin: WP YouTube Lyte » Youtube Privacy-Enhanced Mode embed coded

  • Resolved matgas85

    (@matgas85)


    Hi there,

    the plugin works really well but I have noticed that the type of embed code of my videos has changed.

    I embed all my youtube videos with the privacy-enhanced code for GDPR reasons, and if I look at the page source, that code (which work with the URL www. youtube-nocookie .com) is gone and it seems that the normal embed code is being used. If I disable the plugin, indeed I have now the normal code and the privacy code is gone.

    Did I do something wrong in the settings? Should I select No for Also act on normal YouTube links and iframes?

    Or is the plugin programmed to replaced the privacy code with the normal one?

    I know that Youtube does place some cookies once you play the video, but with the privacy embed code, these cookies should be less invasive (no personally-identifiable cookies).

    Many thanks,

    Mat

    • This topic was modified 10 months, 4 weeks ago by matgas85.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    No, LYTE uses youtube-nocookie as well and that works for your site as well;

    Hi,

    I don’t know why but the Firefox inspector shows a different code that the one you see (it’s probably me doing something wrong). It’s only when I click the grey EVENT button that I can find some trace of the nocookie URL.

    See screenshots below:
    https://www.dropbox.com/sh/qph6a1a4v07yxbv/AAC_ExAhByuf5NoIstPNbtlua?dl=0

    If I only click “show source” in Chrome then there is no trace of the nocookie url and that’s what fooled me to begin with.

    But when editing the article, I can see that the nocookie code now so I guess it was a false alarm after all.

    Many thanks, again! Your patience and prompt support deserves five stars.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    the screenshot I made is done after clicking the play button, which is when LYTE swaps the dummy player (which does not use the youtube domain at all) for a player iframe which points to the nocookie domain πŸ™‚

    Right, makes sense!

    Now I’m going to close 2019 with an even more silly problem.

    I’ve noticed that all my H2 titles that contain one dash (-) now have a double dash (- -).

    If I disable the plugin, the double dash reverts to a single dash.

    This seems to happen in the text too.

    see example here:
    https://mirrorlesscomparison.com/sony-vs-sony/a7riii-vs-a9/

    Any idea? πŸ™‚

    • This reply was modified 10 months, 4 weeks ago by matgas85.
    • This reply was modified 10 months, 4 weeks ago by matgas85.
    • This reply was modified 10 months, 4 weeks ago by matgas85.
    • This reply was modified 10 months, 4 weeks ago by matgas85.
    Plugin Author Optimizing Matters

    (@optimizingmatters)

    No idea tbh, I’ll test locally to see if I can reproduce to start with.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    I can reproduce, but only when using blocks (not the classic editor) and only if there are spaces around the dash. If LYTE is active on the page, the - becomes --, if LYTE is not active, - becomes – (a long dash). When in classic editor - always becomes – (a long dash) ..

    Now why this happens, that I don’t know yet πŸ™‚

    I just checked and on my site, the - becomes -- also on articles that are not converted to blocks.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    I’ll have to look into that (created an issue on GitHub so I don’t forget), for now maybe replace – with – in your text(s), that will (likely) not be touched?

    It’s ok I’ll wait for now and see if you find a solution.
    Thanks!

    Same problem for me. All the dashes with a space after them are replaced with two dashes, even if the posts are written in the classical editor.
    I hope in a solution. Thanks.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    No short term solution as I don’t have the time to dive in, use – instead of – as workaround.

    I have the same issue with dashes πŸ™‚

    bmoooooo

    (@bmoooooo)

    I also have the exact same issue see
    https://www.liberatedstocktrader.com/top-10-best-stock-market-analysis-software-review/

    • This reply was modified 10 months ago by bmoooooo.
    Plugin Author Optimizing Matters

    (@optimizingmatters)

    well, as a workaround for those on Autoptimize, you could use this code snippet to turn -- into –;

    add_filter('autoptimize_html_after_minify','replace_doubledash');
    function replace_doubledash($in) {
        return str_replace( '-- ', '– ', $in );
    }
    bmoooooo

    (@bmoooooo)

    Hi Frank, what would I do with the code?

    thanks

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Youtube Privacy-Enhanced Mode embed coded’ is closed to new replies.